none
Windows 7 seemless remote desktop

    Question

  • Hi

    => I want to know if it is possible to configure remote desktop connections to NOT goto the splash screen and just display the desktop ?

    e.g. When a CodedUI testing is occuring, if you leave a remote desktop session (i.e. do not log off) and then login later, the splash screen is displayed.

    This will cause a codedui test on a VM to fail.

    => What i want to do is connect again (credentials can be saved) and display the desktop immediately.

    In other words, something like VNC.

    Thanks

    Friday, September 27, 2013 2:01 PM

Answers

All replies

  • Hi,

    Can you give us a screenshot to illustrate your situation?

    How do you leave the remote connection session?  I would like to repro your problem so that we can figure out a workaround.

    If you have any feedback on our support, please click here


    Alex Zhao
    TechNet Community Support

    Monday, September 30, 2013 5:34 AM
    Moderator
  • You can save the login details that you need to use when connecting to the RDP session if that is what you want to do. Click the Options drop down from the Remote Desktop Connection window. In the general tab you can enter the username and have the option to save the credentials used to connect with (see example below)


    Cheers

    Paul | sccmentor.wordpress.com


    Monday, September 30, 2013 9:04 AM
  • Thanks to both

    Cached credentials is not the issue, i can do this, in other words the RDP session logins directly and no extra prompting occurs.

    When you login, you will notice (depending on the speed of the system) a Blue Windows screen with Welcome... which will quickly vanish, and the existing desktop shown where you left it.

    It is this Welcome screen i wish to bypass.

    When a RDP session is running if you go to the top right and close the RDP window, you are NOTbe logged off. The next time you attach, you are logined in again in a similar way that if the system had gone to screen saver...

    I have tied all the tricks and registry settings, but i can't get the Welcome screen to be skipped.

    regards



    Monday, September 30, 2013 1:27 PM
  • I do not think this is possible with RDP. You have to authenticate with the remote device.

    Cheers

    Paul | sccmentor.wordpress.com

    Monday, September 30, 2013 2:45 PM
  • Thanks

    But authenicating is one thing, but this does not need a splash screen, i.e. the program can establish you are a valid user and just expose the desktop.

    The splash screen is the issue for me.

    I think there is nothing more to be done, i will try one of my internal Microsoft contacts and post back if i find something.

    regards

    Tuesday, October 01, 2013 6:38 AM