none
Master Page Display Differences - Myself Vs All Other Accounts

    Question

  • I have an issue with how a SharePoint 2007 Master Page is displayed for others when compared to how it is displayed for me. It will display a new object when added, so I know that it is retrieving the current version of the page.

    I have tried the following combination:

    1. The master page is published as a major version and has an "Approved" Status.
    2. Using the same computer and the same browser (to eliminate browser versions, display resolution, etc...), I have signed in as another user and I see the same difference in the master page.
    3. Copied & Pasted the master page with a new name. Publish it as a major version with an "Approved" Status and changed the master page to the new "copied" version of the master. The problem persists.

    How I see the page:

    My View

    How the other users see the page:

    Other Users View


    Systems Analyst at Reid Hospital in Richmond, IN


    • Edited by ibjokn Tuesday, November 19, 2013 9:22 PM added comments
    Tuesday, November 19, 2013 9:19 PM

All replies

  • Hi ibjokn,

    would you please check with a user account that have same permission as you, whether the master page still has this issue?

    As the master displays different with the same browser, it seems that the user doesn’t open the same version of the page.

    If you deploy the master page using SharePoint designer, checkin the master page from Designer, and check the result from UI.

    If it isn’t the issue, please feel free to let me know.

    Thanks,

    Qiao

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Qiao Wei
    TechNet Community Support

    Wednesday, November 20, 2013 4:59 AM
  • Hi ibjokn,

    Check if there is any SPSecurity trimmed control around the 'div' tags in the master page.

    Check in current navigation for SPSecurity trimmed control.

    Thanks

    

    • Edited by RKP Rohit Wednesday, November 20, 2013 5:15 AM
    Wednesday, November 20, 2013 5:12 AM
  • This is a test site, so I made the test user a site collection administrator to ensure that it wasn't a security issue. The issue still persists.

    I was thinking the same thing regarding a version issue, but I have checked in the master page and even made certain that the status was approved.


    Systems Analyst at Reid Hospital in Richmond, IN

    Wednesday, November 20, 2013 9:23 PM
  • The div tags aren't security trimmed, but the quick launch is trimmed. "<Sharepoint:SPSecurityTrimmedControl runat="server" PermissionsString="ViewFormPages"><div class="ms-quicklaunchheader"><SharePoint:SPLinkButton id="idNavLinkViewAll" runat="server" NavigateUrl="~site/_layouts/viewlsts.aspx" Text="<%$Resources:wss,quiklnch_allcontent%>" AccessKey="<%$Resources:wss,quiklnch_allcontent_AK%>"/></div></SharePoint:SPSecurityTrimmedControl>"

    Systems Analyst at Reid Hospital in Richmond, IN

    Wednesday, November 20, 2013 9:27 PM