none
Network connection problem - Windows Server 2012 as router

    Question

  • Hi!

    Basically, I'm facing two problems which I've been unable to find a solution.

    The first problem occurs when connecting my Android phone to Internet.
    I've got a Windows Server 2012 with RRAS as a router. I get Internet connection to every one device on the network but my phone. I can connect it to network and use local network resources but it won't connect to Internet.

    I also can't get RADIUS working with my WLAN router. I've configured the router and NPS to work together. Every time an authentication request is received by NPS it is logged. However the connecting computer gets "Can't connect to network" error. NPS is configured to allow domain users to connect. If I try connecting from my android phone, I get "Wrong password" error.

    I've been looking for a solution for hours with no success.. Maybe you could help me.

    Best regards,
    Riku Kuusisto

    Thursday, August 29, 2013 8:08 PM

All replies

  • Those are very good posts and I've checked them before. Unfortunately I've done somewhat everything presented in those posts..

    Would there be by default some policy or other filtering that does not allow non-Windows clients to access Internet? I didn't get any success with NPS Network Policies related to RRAS however..
    Friday, August 30, 2013 11:55 AM
  • Hi,

    According to the description, I assume that the problem occurs once clients connect to your network through WLAN router?

    In this case, please check if the router meet the requirement as a RADIUS client.

    Support for Institute of Electrical and Electronics Engineers (IEEE) standard 802.1X authentication

    Support for RADIUS authentication and RADIUS accounting

    You can refer to the following link to see if any helps:

    RADIUS Server for 802.1X Wireless or Wired Connections

    http://technet.microsoft.com/en-us/library/cc731853.aspx

    Creating a secure 802.1x wireless infrastructure using Microsoft

    http://blogs.technet.com/b/networking/archive/2012/05/30/creating-a-secure-802-1x-wireless-infrastructure-using-microsoft-windows.aspx

    Hope this helps.

    Friday, August 30, 2013 1:53 PM
    Moderator
  • I'll check those later. The same problem with RADIUS occurred also with CheckPoint VPN Edge W. Authentication requests are logged, but access isn't granted, even though I've double checked that the policies are matched.

    Nevertheless, that RADIUS problem isn't my main issue, connectivity problem with Android clients is. To be clear, I have configured WPA2-PSK so that the authentication is not dedicated on the server. Is there something that has to be done to get RRAS to let Android devices get the internet connection? I already get fully working network connection but not Internet connection with Android phone. Windows clients do just fine.

    I may be a bit unclear, I'm not native english, so...

    Sunday, September 01, 2013 11:58 AM
  • in your android devices, make sure that the wireless authentication is also WPA2-PSK.

    if it is set to WEP then it will not be able to connect.

    but there are wireless router or Wireless access points, that you can enable or set both authentication WEP and WPA2-PSK.

    this is not a MS issue, but just trying to give my 2 cents of input to help you out. :)


    Every second counts..make use of it. Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.


    • Edited by cguan Monday, September 02, 2013 7:09 AM edit
    Monday, September 02, 2013 6:59 AM
  • Authentication is automatically assigned and as said, network rocks well. I can even connect to my RRAS VPN over 3G with my Android, and use network resources but not Internet. Problem is not connecting Android to my network, but passing it to Internet while other devices do get Internet connection.

    Anyways, I already ordered a brand new router so that I won't need my server to act as router to get full Internet speed (the other routers were up to g standard only, or n supported, but without WAN-port).
    Monday, September 02, 2013 2:03 PM