none
Error to send to gmail.com

    Question

  • Friends, I have an Exchange 2013 and a sudden he no longer send emails to gmail.com

    Googled the error but not its resolving, see:

    mx.google.com rejected your message to these email addresses:

    mx.google.com generated this error: [2002:3207:4784 :: 3207:4784 16] The sender does not meet basic guidelines ipv6 sending of authentication and RDNs resolution of sending ip. Please review https://support.google.com/mail/answer/81126for more information. e49si9606932eep.111 - gsmtp
    Your message was not delivered due to permission problems or safety. She may have been rejected by a moderator, the address only accepts mail from certain senders, or another restriction prevented delivery.


    Can you help me?

    Silvio Tavares - Analista de Sistemas

    Monday, August 19, 2013 1:43 PM

All replies

  • Hiya,

    I'm getting the same error with Exchange 2010 (since this morning), but sometimes the email went well to the destination... Wondering if the problem's not coming from Gmail...

    Best,
    --Fabien

    Monday, August 19, 2013 2:38 PM
  • I've been getting it since Fri. Google must have opened up ipv6 smtp delivery on some of their servers. I'm sure they've done something, or maybe it's the ISP changed something? Not all my clients running Exchange are complaining. The one with the issue is running Time Warner Cable. What about you guys?

    Monday, August 19, 2013 3:22 PM
  • Our server is hosted at Ikoula, but no idea which ISP they are using!

    The strange thing's that we don't have IPV6 on this server... So I barely understand how we can get this error !

    --Fabien

    Monday, August 19, 2013 3:34 PM
  • I do not understand where is this error.

    Silvio Tavares - Analista de Sistemas

    Monday, August 19, 2013 3:40 PM
  • same thing here today, nothing changed on my server

    i can send mail to a gmail account when my smtp server connects to gmail with ipv4, when it connects with ipv6 the delivery gets bounced with the same error :

    to=<xxxxx@gmail.com>, relay=gmail-smtp-in.l.google.com[2a00:1450:400c:c00::1a]:25, delay=3.6, delays=0.26/0.02/2.8/0.57, dsn=5.7.1, status=bounced (host gmail-smtp-in.l.google.com[2a00:1450:400c:c00::1a] said: 550-5.7.1 [2a01:yyyyyyy      16] The sender does not meet basic ipv6 sending guidelines of authentication and rdns resolution of sending ip. Please review  https://support.google.com/mail/answer/81126 for more information.

    i can't tell if my server manages to send ipv6 mail elsewhere as it doesn't have much traffic..

    hopefully it's a gmail configuration problem or excessive security check..


    • Edited by dvbm Monday, August 19, 2013 3:45 PM
    Monday, August 19, 2013 3:44 PM
  • I do not understand where is this error.

    Silvio Tavares - Analista de Sistemas

    Check your SPF et reverse DNS configuration to verify if you're including your IPV6 (if you're using one...)

    --Fabien

    Monday, August 19, 2013 3:49 PM
  • Fabien, look my SPF:

    SPF Record Found

    [OK] <label id="displayPanel_SPFRecsFound">One or more functional SPF record(s) have been found for the domain</label> contoso<label id="displayPanel_yourDomainEPDFound" style="font-weight:bold;">.com.br</label>

    The full text of the domain's SPF record is as follows.
    v=spf1mxmx:webmail.contoso.com.br-all

    I believe that is correct.


    Silvio Tavares - Analista de Sistemas

    Monday, August 19, 2013 3:53 PM
  • I've reconfigured my exchange to prefer ipV4 over ipv6 using http://support.microsoft.com/kb/929852?wa=wsignin1.0. If you are running Exchange 2013 it is very important that you DO NOT disable ipv6 or it will stop working. I'll let you guys know if that fixes things.

    • Proposed as answer by tprovostjr Tuesday, August 20, 2013 12:38 PM
    • Unproposed as answer by Silvio AST Monday, September 16, 2013 3:22 PM
    Monday, August 19, 2013 4:03 PM
  • Fabien, look my SPF:

    SPF Record Found

    [OK] <label id="displayPanel_SPFRecsFound">One or more functional SPF record(s) have been found for the domain</label> contoso<label id="displayPanel_yourDomainEPDFound" style="font-weight:bold;">.com.br</label>

    The full text of the domain's SPF record is as follows.
    v=spf1mxmx:webmail.contoso.com.br-all

    I believe that is correct.


    Silvio Tavares - Analista de Sistemas

    Just saw on a Google's forum that -all instead of ~all may run you with some troubles...

    You should check it on mxtoolbox.com by entering your domain name then "SPF lookup"

    Monday, August 19, 2013 4:04 PM
  • Tin_man_0

    I did not touch anything on my server, simply stopped working.


    Silvio Tavares - Analista de Sistemas

    Monday, August 19, 2013 4:06 PM
  • Fabien, look this:

    spf:contoso.com.br   Find Monitors  

     spf

      

    Record Syntax is invalid: v=spf1mxmx:webmail.contoso.com.br-all:

    dns lookup dns check mx lookup whois lookup
    Reported by ns1.contoso.com.br on 8/19/2013 at 11:08:03 AM (UTC -5)just for you.  Transcrip

    Is this the problem?
    But what I do not understand is that this server has 1 year and only yesterday was giving this problem.


    Silvio Tavares - Analista de Sistemas

    Monday, August 19, 2013 4:10 PM
  • Fabien, look this:

    spf:contoso.com.br   Find Monitors  

     spf

      

    Record Syntax is invalid: v=spf1mxmx:webmail.contoso.com.br-all:

    dns lookup dns check mx lookup whois lookup
    Reported by ns1.contoso.com.br on 8/19/2013 at 11:08:03 AM (UTC -5)just for you.  Transcrip

    Is this the problem?
    But what I do not understand is that this server has 1 year and only yesterday was giving this problem.


    Silvio Tavares - Analista de Sistemas

    Guess your missing some white space. You should get closer to your DNS registrar to know the syntax they are using. BTW, you should have your dns name of your mail server instead of webmail.contoso.com (not sure if you're hiding it or not ;))

    Not all mail server are using the SPF records. Our mail server is running since 4 years but I put the SPF a year ago.

    --Fabien

    Monday, August 19, 2013 4:18 PM
  • I've reconfigured my exchange to prefer ipV4 over ipv6 using http://support.microsoft.com/kb/929852?wa=wsignin1.0. If you are running Exchange 2013 it is very important that you DO NOT disable ipv6 or it will stop working. I'll let you guys know if that fixes things.

    My IPV6 network interface is disabled in my case :s (it has always been like that)

    --Fabien

    Monday, August 19, 2013 4:19 PM
  • Fabien:

    Yes, I'm hiding my domain so that it is not public.

    See the way my SPF record reconfigured the site: http://www.microsoft.com/mscorp/safety/content/technologies/senderid/wizard/default.aspx

    v=spf1
    a
    ip4:200.200.200.200
    ip4:200.200.200.201
    mx:webmail.contoso.com.br
    -all

    I really do not understand how this can stop working d anda time to outroa but be that way is correct?

    Like I said, I do not use ipv6 on my Windows Server 2012 and my Exchange 2013. Just have disabled ipv6 on the properties of the network card, but that I did when I installed Exchange 2013, almost 1 year ago.


    Silvio Tavares - Analista de Sistemas

    Monday, August 19, 2013 4:24 PM
  • Fabien:

    Yes, I'm hiding my domain so that it is not public.

    See the way my SPF record reconfigured the site: http://www.microsoft.com/mscorp/safety/content/technologies/senderid/wizard/default.aspx

    v=spf1
    a
    ip4:200.200.200.200
    ip4:200.200.200.201
    mx:webmail.contoso.com.br
    -all

    I really do not understand how this can stop working d anda time to outroa but be that way is correct?

    Like I said, I do not use ipv6 on my Windows Server 2012 and my Exchange 2013. Just have disabled ipv6 on the properties of the network card, but that I did when I installed Exchange 2013, almost 1 year ago.


    Silvio Tavares - Analista de Sistemas


    No idea, we've both disabled IPV6 and getting an IPV6 error from Google (and only from them). Quite confusing !
    • Edited by Fabien T Monday, August 19, 2013 4:39 PM
    Monday, August 19, 2013 4:32 PM
  • Could it be some sort of IPV4 to IPV6 translation at the firewall? I know I haven't changed anything, I'm almost certain that google has, but I have a feeling that they aren't going to change it back, but rather require corrections of rnds for ipv6 on our part instead. Maybe it's time to contact the isp for rdns on ipv6. Also, SPF means nothing if rdns checking is turned on. Most places require rdns and spf is optional.
    Monday, August 19, 2013 4:43 PM
  • Also, from what I understand, just unchecking the ipv6 box in the network adaptor properties doesn't disable ipv6. You'll need to use the link or change some registry keys. Althogh I will repeat, the last time I really disabled IPV6 on a server running exchange 2013, it stopped working. If I recall, exchange 2013 uses ipv6 for internal transport communication.

    Monday, August 19, 2013 4:47 PM
  • Could it be some sort of IPV4 to IPV6 translation at the firewall? I know I haven't changed anything, I'm almost certain that google has, but I have a feeling that they aren't going to change it back, but rather require corrections of rnds for ipv6 on our part instead. Maybe it's time to contact the isp for rdns on ipv6. Also, SPF means nothing if rdns checking is turned on. Most places require rdns and spf is optional.

    I do not have such IPV6 to IPV4 translation but maybe my ISP does... will ask them, but I'd be glad to know how google's getting an IPV6 from my DNS.

    --Fabien

    Monday, August 19, 2013 4:48 PM
  • They aren't getting it from DNS, the ip is obtained upon connection, echange then reports a name on the ehlo . rDNS is then run on the IP obtained against the isp's records. If the isp rdns matches the name exchange provided on ehlo, then it passes, otherwise it fails.
    Monday, August 19, 2013 5:03 PM
  • I've reconfigured my exchange to prefer ipV4 over ipv6 using http://support.microsoft.com/kb/929852?wa=wsignin1.0. If you are running Exchange 2013 it is very important that you DO NOT disable ipv6 or it will stop working. I'll let you guys know if that fixes things.


    This seems to have fixed it. No more bounce backs after 10+ tests.
    Monday, August 19, 2013 5:15 PM
  • Tim_man_0

    Tell me step by step what you did, I'm not getting ro understand what you did.

    Thank you!

    Silvio Tavares - Analista de Sistemas

    Monday, August 19, 2013 5:18 PM
  • Step 1. Click on the link.

    Step 2. Click on the "Prefer IPv4 over IPv6" Micosoft fix it and save it.

    Step 3. Launch the downloaded msi and complete the setup.

    Step 4. Restart the server

    Step 5. Ensure all services have started successfully after the restart.

    Test.

    Monday, August 19, 2013 5:22 PM
  • Hi, I'm having the same issue here.  Not sure what to do on this one.  This must be related to some change they've made at Google.  I hate to start disabling ipv6 and stuff.  I have been testing and it seems some messages go through and other's don't.   No rhyme or reason to it.
    Monday, August 19, 2013 6:37 PM
  • Tim_man_0

    Tell me step by step what you did, I'm not getting ro understand what you did.

    Thank you!

    Silvio Tavares - Analista de Sistemas


    Did it solve the issue?
    Monday, August 19, 2013 6:56 PM
  • I too am experiencing the same issue with sending to Gmail from two of my Exchange environments.  This has come up since Googles 2 minute total outage on August 16th.

    No Exchange server in in my network or any server in my network for that matter has an Ipv6 address.  However Gmail is bouncing emails sent to it saying that I dont meet Ipv6 sending guidelines.  I have already attempted to disable Ipv6 on the NICs of these serves but it has not resolved the issue.  

    I would really like an update from the OP to see if applying the Prefer Ipv6 over Ipv4 hotfix resolved this issue for him.  

    Monday, August 19, 2013 7:32 PM
  • I too am experiencing the same issue with sending to Gmail from two of my Exchange environments.  This has come up since Googles 2 minute total outage on August 16th.

    No Exchange server in in my network or any server in my network for that matter has an Ipv6 address.  However Gmail is bouncing emails sent to it saying that I dont meet Ipv6 sending guidelines.  I have already attempted to disable Ipv6 on the NICs of these serves but it has not resolved the issue.  

    I would really like an update from the OP to see if applying the Prefer Ipv6 over Ipv4 hotfix resolved this issue for him.  


    Try turning smtp logging on and watch the smtp log. You will probably see Exchange using ipv6 dispite the fact that you have unchecked the box in tcp/ip settings. To my knowledge, simply uncecking the box in the settings doesn't acutally disable ipv6. I theory it unbinds it from that adapotor, but I guess exchange isn't taking the settings from there. Use http://support.microsoft.com/kb/929852?wa=wsignin1.0 and download the Microsoft Fix it to prefer ipv4 over 6. Then restart and watch the logs again.
    Monday, August 19, 2013 7:55 PM
  • I too am experiencing the same issue with sending to Gmail from two of my Exchange environments.  This has come up since Googles 2 minute total outage on August 16th.

    No Exchange server in in my network or any server in my network for that matter has an Ipv6 address.  However Gmail is bouncing emails sent to it saying that I dont meet Ipv6 sending guidelines.  I have already attempted to disable Ipv6 on the NICs of these serves but it has not resolved the issue.  

    I would really like an update from the OP to see if applying the Prefer Ipv6 over Ipv4 hotfix resolved this issue for him.  


    Try turning smtp logging on and watch the smtp log. You will probably see Exchange using ipv6 dispite the fact that you have unchecked the box in tcp/ip settings. To my knowledge, simply uncecking the box in the settings doesn't acutally disable ipv6. I theory it unbinds it from that adapotor, but I guess exchange isn't taking the settings from there. Use http://support.microsoft.com/kb/929852?wa=wsignin1.0 and download the Microsoft Fix it to prefer ipv4 over 6. Then restart and watch the logs again.
    Thank you, I did read the thread and did see the proposed solution.  I am hoping for confirmation that this worked from OP or someone else experiencing this issue before i go and implement the patch on over 30 HUB Servers.  
    Monday, August 19, 2013 8:04 PM
  • I tried running the fix to favor IPv4 over IPv6 and it didn't do anything.  It's still sending from IPv6 and getting a bounce back from Google.
    Monday, August 19, 2013 8:56 PM
  • I am having the same problem. and I tried the fix to favor IPv4 over IPv6

    Im going nuts trying to figure this one out.

    Just out of curiosity could it be a problem with the ISP, I use Comcast Business Internet. I wonder if anyone else is using Comcast and is having the same issue.

    Monday, August 19, 2013 9:15 PM
  • We are having the same issue.

    Googlemail = biggest spam Sender on this planet but telling us we would not send according to their rules nobody understands.

    I tried the MSI Hotfix and restarted our Exchange 2010 but Google is still refusing our mails with that message

    Monday, August 19, 2013 9:24 PM
  • I have just implemented Fixit 50410 as outlined by KB929852 on one of my Exchange 2010 Deployments, patching both HUB TRANSPORT servers, after which I have sent several test emails to Gmail and people with Google Apps accounts.

    After applying the fixit I am no longer receiving bouncebacks from Google.   

    Monday, August 19, 2013 9:48 PM
  • I have just implemented Fixit 50410 as outlined by KB929852 on one of my Exchange 2010 Deployments, patching both HUB TRANSPORT servers, after which I have sent several test emails to Gmail and people with Google Apps accounts.

    After applying the fixit I am no longer receiving bouncebacks from Google.   


    Negative - not working for us here. We tried the same. Still getting bouncebacks from Google since today.
    Monday, August 19, 2013 9:54 PM
  • Hey I think i jut figured out the issue on my end.

    I disabled the IPhelper service. and now mail is moving properly.

    if anyone is having trouble after applying the prefer IPv4 over IPv6 regedit - disable the "ip Helper"service .
    • Edited by DisplayNameIsInUse Monday, August 19, 2013 10:09 PM
    • Proposed as answer by DisplayNameIsInUse Monday, August 19, 2013 10:14 PM
    • Unproposed as answer by Silvio AST Monday, August 19, 2013 11:02 PM
    • Proposed as answer by Fabien T Tuesday, August 20, 2013 10:03 AM
    • Unproposed as answer by Silvio AST Monday, September 16, 2013 3:25 PM
    Monday, August 19, 2013 9:55 PM
  • I am getting some mail through now.  It's been hit or miss with some going through.  Gmail must be getting a huge number of complaints so I wonder if they're dropped the ipv6 RDNS requirement.  Basically, anyone with Exchange 2010 or 2013 and no IPv6 reverse DNS is having issues.  I am working on getting revers DNS setup now but it could be a while before the ISP is able to properly delegate the reverse ipv6 zone to our DNS server.
    Monday, August 19, 2013 10:21 PM
  • that did the trick for us!

    (i´m talking about disabling the IP Helper Service.)

    Cool Workaround :)

    Thanks !


    • Proposed as answer by The_IT_Guys Monday, August 19, 2013 10:52 PM
    • Edited by The_IT_Guys Monday, August 19, 2013 11:02 PM
    • Unproposed as answer by Silvio AST Monday, August 19, 2013 11:02 PM
    Monday, August 19, 2013 10:52 PM
  • I am getting some mail through now.  It's been hit or miss with some going through.  Gmail must be getting a huge number of complaints so I wonder if they're dropped the ipv6 RDNS requirement.  Basically, anyone with Exchange 2010 or 2013 and no IPv6 reverse DNS is having issues.  I am working on getting revers DNS setup now but it could be a while before the ISP is able to properly delegate the reverse ipv6 zone to our DNS server.

    IP helper! why didn't I think of that? :) I knew that some v4 to v6 translations had to be taking place somewhere. It's time to visit ipv6 again, maybe start planning a roll out. It's a pain, but it's coming, and it has a lot of pluses. I wonder if "big brother's" data collection programs cover ipv6, from what I understand ipv6 has natural encryption included?
    Tuesday, August 20, 2013 2:25 AM
  • i couldnt send mail via windows 8 mail app over gmail smtp anymore....because i went to the job with my Laptop which is offline at work (not airplane mode,but i turn off WIFI with the intel wifi manager and turn it back on when i get home) 

    Had to switch on Airplane mode and switch it off again to make this work again (although i was properly connected anyway and could receive mails. Synchronizing hangs forever with no error message and sending mails out of outbox didnt work, now how lame is that?) !?!? boy that client is such a piece of dumb poo.

    Dont ask me why this message composer changes my font size at own will ..no idea.


    • Edited by Br33zer Tuesday, August 20, 2013 6:02 AM
    Tuesday, August 20, 2013 6:02 AM
  • Hi,

    It seems like a hot issue.

    Please refer to the following article:

    http://productforums.google.com/forum/#!topic/gmail/K5klFKDnUAE

     

    Hope it is helpful

     

    Thanks

    Mavis

    Tuesday, August 20, 2013 9:37 AM
  • Hi again,

    On my side, applying the "Prefer IPV4" and stopping the IP Helper service seems to work well!

    Thanks for both solutions !

    --Fabien

    Tuesday, August 20, 2013 10:05 AM
  • Hello everyone,

    We use Exchange 2010, and we got the same error 1-2 days ago.

    We only have one ipv4 address for the external adapter and IPV6 is disabled on the external network adapter.

    After applying Microsoft Fix it 50410 ("Prefer IPv4 over IPv6") on the exchange server and after a server restart we don't have the problem anymore and users can send e-mail to @gmail.com again.

    Thanks for the quick and free help! Microsoft Support Forums rullz :)


    • Proposed as answer by Alex Bogdan Tuesday, August 20, 2013 12:00 PM
    • Edited by Alex Bogdan Tuesday, August 20, 2013 12:02 PM
    • Unproposed as answer by Silvio AST Monday, September 16, 2013 3:35 PM
    Tuesday, August 20, 2013 12:00 PM
  • Thank you. Resolution was immediate after applying the "Prefer IPv4 over IPV6" hotfix. Important to note that even with IPV6 disabled on the machine from first time it was powered on, the issue still appeared for us.
    Tuesday, August 20, 2013 12:39 PM
  • I wound up setting our server to "perfer IPv4 of IPv6" and rebooted.  No dice, but after turning stopping and disabling the IPHelper service messages are now going through to Gmail accounts.

    I did some digging in our logs and round this started on Thursday night or Friday morning. It seems that, by default, Exchange will send using IPv6 somewhat randomly, or "when it can".  I read on one site that Google switched to Postini recently.  Whatever they did, their SMTP servers are now requiring valid RDNS for IPv6.  Problem is most places don't have a proper public IPv6 address.  Some probably can't even get one from their ISP if they wanted to.  This lack of a public IP doesn't stop Exchange from using the IPv6 address of the 6TO4 adapter to send the messages to Gmail.   I am not sure if this is something Gmail should change back or if MS needs to release a patch for Exchange.  What we've done is a hack, so I'm hoping this will be addressed my Google or MS soon.

    Tuesday, August 20, 2013 6:46 PM
  • I wound up setting our server to "perfer IPv4 of IPv6" and rebooted.  No dice, but after turning stopping and disabling the IPHelper service messages are now going through to Gmail accounts.

    I did some digging in our logs and round this started on Thursday night or Friday morning. It seems that, by default, Exchange will send using IPv6 somewhat randomly, or "when it can".  I read on one site that Google switched to Postini recently.  Whatever they did, their SMTP servers are now requiring valid RDNS for IPv6.  Problem is most places don't have a proper public IPv6 address.  Some probably can't even get one from their ISP if they wanted to.  This lack of a public IP doesn't stop Exchange from using the IPv6 address of the 6TO4 adapter to send the messages to Gmail.   I am not sure if this is something Gmail should change back or if MS needs to release a patch for Exchange.  What we've done is a hack, so I'm hoping this will be addressed my Google or MS soon.


    A quick update. While "Perfer IPv4 to IPv6" greatly reduces the bounce backs, it doesn't completely eliminate the problem. I'll be disabling the IP Helper service as well in the interim until proper IPv6 implementation.
    Wednesday, August 21, 2013 4:18 AM
  • i applied the fix as well and am still not working. i too have Comcast business. 
    Wednesday, August 21, 2013 12:04 PM
  • i applied the fix as well and am still not working. i too have Comcast business. 

    Did you stop the IP Helper Service ? (if you're not using IPV6)
    • Edited by Fabien T Wednesday, August 21, 2013 12:14 PM
    Wednesday, August 21, 2013 12:08 PM
  • I have applied the IPv4 to IPv6 patch and disabled the IPhelper service.  I am still get the error.  I attempted disabling the IPv6 completely and the server stopped working. Mail worked, but the server other than mail seized. 

    Any more help would be great. I am at a complete loss. 

    Wednesday, August 21, 2013 12:20 PM
  • Yes I did stop the IP helper service. 

    i am getting the same mx.google.com message when sending to other random domains as well but not all.

    All of this started happening in the exact same time frame as everyone else on here. 

    The server is SBS 2008 and it seems tied to IPv6 and can't function without it, even though i am not using it. 

    Any other suggestions? 



    • Edited by talk2tim Wednesday, August 21, 2013 1:01 PM
    Wednesday, August 21, 2013 12:49 PM
  • Yes I did stop the IP helper service. 

    i am getting the same mx.google.com message when sending to other random domains as well but not all.

    All of this started happening in the exact same time frame as everyone else on here. 

    The server is SBS 2008 and it seems tied to IPv6 and can't function without it, even though i am not using it. 

    Any other suggestions? 

    Do an ipconfig /all on the server running exchange and see if there is another adapter advertising an IPv6 address.

    If there is not check to see if your firewall is using an IPV6 address. Disable IPv6 if it is not being used.

    If you want to use IPv6 make sure you have assigned the proper address, create the appropriate AAAA record,  modify your SPF record in DNS, and make sure your PTR record is configured for that ipv6 address.


    Wednesday, August 21, 2013 1:42 PM
  • Also when you say that you stopped the iphelper service, make sure you disabled it from starting.

    If you just hit stop it will restart when the server reboots.


    Wednesday, August 21, 2013 1:49 PM
  • Yes I did stop the IP helper service. 

    i am getting the same mx.google.com message when sending to other random domains as well but not all.

    All of this started happening in the exact same time frame as everyone else on here. 

    The server is SBS 2008 and it seems tied to IPv6 and can't function without it, even though i am not using it. 

    Any other suggestions? 

    Do an ipconfig /all on the server running exchange and see if there is another adapter advertising an IPv6 address.

    If there is not check to see if your firewall is using an IPV6 address. Disable IPv6 if it is not being used.

    If you want to use IPv6 make sure you have assigned the proper address, create the appropriate AAAA record,  modify your SPF record in DNS, and make sure your PTR record is configured for that ipv6 address.


    i did an Ipconfig.  both IPv4 and IPv6 both say (Preferred) behind the address.  I thought by running the fix and rebooting it would just have one as preferred not both. 
    Wednesday, August 21, 2013 3:14 PM
  • i did an Ipconfig.  both IPv4 and IPv6 both say (Preferred) behind the address.  I thought by running the fix and rebooting it would just have one as preferred not both. 

    Talk2tim, are you still having trouble, i am not sure from your last post?

    You should definitely disable IPv6 if you are not using it.

    Do the following steps again to make sure IPv6 is disabled (only if you have no use for IPv6 at this time ).

    Run the preffer IPv4 over IPv6 fixit, or manually edit the registry.

    Disable the IPv6 protocol from the network adapter properties.

    Check to be sure that the IPhelper service is disabled and not set to run at startup

    Reboot the server

    Check again on your server by doing the ipconfig /all, make sure that there is no IPv6 address listed. 


    Wednesday, August 21, 2013 3:41 PM
  • Talk2Tim,

    Look at this link for disabling ipv6 on 2008 SBS

    http://blogs.technet.com/b/sbs/archive/2008/10/24/issues-after-disabling-ipv6-on-your-nic-on-sbs-2008.aspx

    Here is a copy of what is posted there...

    Properly Disabling IPv6

    SBS 2008 is designed to fully support IPv6 and has IPv6 enabled by default.  Most users should never need to disable IPv6, however if you must disable IPv6 here is how to disable it properly:

    Important: This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756 (http://support.microsoft.com/kb/322756/)

    1. Uncheck Internet Protocol Version 6 (TCP/IPv6) on your Network Card. 
    2. In Registry Editor, locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\
    3. Double-click DisabledComponents to modify the DisabledComponents entry.
      Note If the DisabledComponents entry is unavailable, you must create it. To do this, follow these steps:
      1. In the Edit menu, point to New, and then click DWORD (32-bit) Value.
      2. Type DisabledComponents, and then press ENTER.
      3. Double-click DisabledComponents.
    4. Enter "ffffffff" (eight f’s), and then click OK:

      image 
    5. Reboot the SBS 2008 server.

    RRAS (VPN) Note: If you plan to enable VPN on your SBS 2008 server, you MUST also Export and then Delete the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\RouterManagers\Ipv6

    If you do not delete this key you will get an 20103 Event when trying to start RRAS with IPv6 disabled.  You must reboot after removing this key.

    For more information please see:

    Wednesday, August 21, 2013 3:54 PM
  • other than the last step of exporting the RAS key, that is what i did. the fix it changed the values to ffffffff but i will manually do it. I can only do this after hours as it an active server. when i used the fix it tool to disable the whole serer froze up and i could only set it back by entering in safe mode and manually changing the registry.  

    Once i will will try this again i will let you know if the resolution worked. 

    Thank you. 

    Wednesday, August 21, 2013 4:39 PM
  • other than the last step of exporting the RAS key, that is what i did. the fix it changed the values to ffffffff but i will manually do it. I can only do this after hours as it an active server. when i used the fix it tool to disable the whole serer froze up and i could only set it back by entering in safe mode and manually changing the registry.  

    Once i will will try this again i will let you know if the resolution worked. 

    Thank you. 

    Good Luck! Let me know what happens.
    Wednesday, August 21, 2013 5:34 PM
  • I did all the steps above and the server froze again. I set the server back to IPv4 over IPv6 and left the two Nics binding to IPv6 unchecked. IPv6 no longer shows in the ipconfig listing. My mistake may have been to not have both Nics unbound.  The only thing i can figure.  Everything appears to be running normal and gmail is going out without bouncing. 

    Still not sure why the whole server craps out when the IPv6 is completely disabled. 

    Thanks for your help!
    Thursday, August 22, 2013 2:18 PM
  • Talk2Tim, May you give us your SPF record for your IPv6 please ? If it doesn't want to work using the IPv4 you should find the correct SPF record which will satify GMail policy! --Fabien
    Thursday, August 22, 2013 6:56 PM
  • It worked for me on 2008 STD , exch 2007.

    ipv6 was disabled by default on the network adapter.

    1. checked the ipv6 on

    2. checked the ipv6 off

    3. stop ip helper service

    4. start ip helper service

    msg arrived from exch to gmail acc.

    Hope it helps for someone.

    Greg.

    (on network adapter status ipv6 connection status was local)
    • Edited by sandokan_ Wednesday, September 04, 2013 10:06 PM
    Wednesday, September 04, 2013 10:02 PM
  • These steps seem to have worked for me...

    Run the prefer IPv4 over IPv6 fixit, or manually edit the registry.

    Disable the IPv6 protocol from the network adapter properties.

    Check to be sure that the IPhelper service is disabled and not set to run at startup

    Reboot the server

    ---

    We run MS Exchange 2007 on SBS 2008.  ISP is Comcast business class.


    Saturday, September 07, 2013 12:19 AM
  • I really do not understand.

    The link down when the fix, the installer says it does not apply to my system.

    Tell me, how did you solve the problem?

    I use Windows 2012 and Exchange 2013.

    Thank you.

    Silvio Tavares - Analista de Sistemas

    Monday, September 16, 2013 3:16 PM
  • I really do not understand.

    The link down when the fix, the installer says it does not apply to my system.

    Tell me, how did you solve the problem?

    I use Windows 2012 and Exchange 2013.

    Thank you.

    Silvio Tavares - Analista de Sistemas

    Monday, September 16, 2013 3:23 PM
  • I really do not understand.

    The link down when the fix, the installer says it does not apply to my system.

    Tell me, how did you solve the problem?

    I use Windows 2012 and Exchange 2013.

    Thank you.

    Silvio Tavares - Analista de Sistemas

    Monday, September 16, 2013 3:26 PM
  • Hi,

    We are using Windows 2012 and Exchange 2013. We are facing the bounces as below too. We are using only IPv4 and is not able to set reverse DNS for ipv6 as the IPv6 used by default on the exchange server is not public.

    We cannot use IPv4 over IPv6 registry fix as it is incompatible with windows server 2012.

    We disabled Ipv6 interface and it doesn't work as it stopped all the flow of emails.

    Please advise?

    Received: from SG1APCEXCSVR.abc.sg (2002:7832:2d8a::7832:2d8a) by
     SG1APCEXCSVR.abc.sg (2002:7832:2d8a::7832:2d8a) with Microsoft SMTP
     Server (TLS) id 15.0.712.24; Sun, 22 Sep 2013 12:12:01 +0800
    Received: from SG1APCEXCSVR.abc.sg ([fe80::38cb:7a08:5eca:1164]) by
     SG1APCEXCSVR.abc.sg ([fe80::38cb:7a08:5eca:1164%12]) with mapi id
     15.00.0712.012; Sun, 22 Sep 2013 12:12:01 +0800
    From: "test@xxx.asia" <test@xxx.asia>
    To: "jackson@gmail.com" <jackson@gmail.com>
    Subject: test2
    Thread-Topic: test2
    Thread-Index: AQHOt0njXZZr95Jqp0ebxhVX1mQZjA==
    Date: Sun, 22 Sep 2013 04:12:01 +0000
    Message-ID: <164adc3fbbaf426b874ca8b7fd0285db@SG1APCEXCSVR.abc.sg>
    Accept-Language: en-SG, en-US
    Content-Language: en-SG
    X-MS-Has-Attach:
    X-MS-TNEF-Correlator:
    x-originating-ip: [182.19.162.146]
    Content-Type: multipart/alternative;
         boundary="_000_164adc3fbbaf426b874ca8b7fd0285dbSG1APCEXCSVRabcsg_"
    MIME-Version: 1.0


    Jackson Yap 



    • Edited by jacksony Sunday, September 22, 2013 4:28 AM change
    Sunday, September 22, 2013 4:26 AM
  • I have same problem "mx.google.com rejected your message to the following e-mail addresses" if you have figure it out how to fix this please help me.

    Dewan Rupu

    Sunday, September 14, 2014 8:17 AM