none
Public Folder Migration - toomanylargeitemspermamentexception

    Question

  • Fatal error  toomanylargeitemspermanentexception.

    I have 20 GB of Public Folders to move. This is my script.

    Exchange 2010 to Exchange 2013 on-premise Migration.

    New-PublicFolderMigrationRequest -SourceDatabase (Get-PublicFolderDatabase -Server EX2010) -CSVData (Get-Content C:\PF-Import-File\PFFolder2Mailbox.csv -Encoding Byte) -AcceptLargeDataLoss -BadItemLimit 40000

    No matter what I try I get to 95 % and fail. I have broken it into several Mailbox Folders, changed bad -item limit, etc.

    I cannot find the large files in public folders because there are too many of them. I assume I must remove the items larger than 35mg before I can successfully move the PF's.

    Is there a way to increase this limit or a script I can run that will tell me the large items in Public folders?

    Thanks

    Thursday, July 11, 2013 1:58 AM

Answers

  • New-PublicFolderMigrationRequest -SourceDatabase (Get-PublicFolderDatabase -Server PDX-EXCH2010) -CSVData (Get-Content E:\PF-Import\PFtomail.csv -Encoding Byte) -AcceptLargeDataLoss -BadItemLimit 10 -Largeitemlimit 10

    This is the Powershell statement I used

    From:

    http://technet.microsoft.com/en-us/library/jj218636(v=exchg.150).aspx

    The LargeItemLimit parameter specifies the number of large items to skip if the request encounters such items in the mailbox. Use 0 to not skip any large items. If any number above 50 is specified, the AcceptLargeDataLoss parameter must also be specified. The default value is 0. We recommend that you use the default value of 0 and increase the LargeItemLimit parameter value only when large items are encountered


    • Edited by CalhounRSB Monday, July 15, 2013 12:01 AM Update
    • Proposed as answer by Ed CrowleyMVP Monday, July 15, 2013 6:08 AM
    • Marked as answer by CalhounRSB Monday, July 15, 2013 1:23 PM
    Sunday, July 14, 2013 11:53 PM

All replies

  • I'm pretty sure the 95% is a red herring.  The move request goes to 95% when it's in completion mode, i.e., when it's done moving data.

    That's a awfully large BadItemLimit.  You're telling it to essentially throw away up to 40,000 items.  When you look at the statistics of the migration request, how many bad items are you seeing?

    As to your real question, I'm afraid I can't find anything on this either.  I assume you only added the -AcceptLargeDataLoss switch after it didn't work without it.

    I can't find where the maximum size is configured, but I'm guessing it's related to the maximum message size in the organization.  What are your organizational message sizes set to?  You might try temporarily enlarging your organizational message limits a lot to see if it fixes your problem.

    http://technet.microsoft.com/en-us/library/bb124345(v=exchg.150).aspx


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Saturday, July 13, 2013 2:23 AM
  • I never tried to move forward because it stated "Fatal Error", I assumed it never was successful.
    Saturday, July 13, 2013 2:29 AM
  • Try step by step : http://technet.microsoft.com/en-us/library/jj150486(v=exchg.150).aspx
    You can always start from beginning if it fails.
    Saturday, July 13, 2013 3:22 PM
  • I have followed those steps to the letter  many times

    I have change baditem limit high and low, I have inserted -acceptlargedataloss  to no avail

    Fatal Error - toomanylargeitemspermanentexception

    How do I find the large items?  It seems this is my only recourse

    Saturday, July 13, 2013 10:09 PM
  • You need to add switch –AllowLargeItems !

    • Marked as answer by CalhounRSB Sunday, July 14, 2013 5:05 PM
    • Unmarked as answer by CalhounRSB Monday, July 15, 2013 1:23 PM
    Sunday, July 14, 2013 9:20 AM
  • That switch does not apply to a New-PublicFolderMigrationRequest.

    I don't know who marked this as an answer, but it definitely is not.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Sunday, July 14, 2013 5:54 PM
  • I answered it as solved because that is exactly the option I choose that allowed me to get past my error.

    When using get-publicfolder migration request status, the Largeitemlimit parameter now states  10 where before it was zero. My migration has now passed  the error and I am able to complete the PF migration.

    Sunday, July 14, 2013 6:03 PM
  • Where did you specify that parameter?  Please post the PowerShell commands you used.  That parameter isn't in the documentation for New-PublicFolderMigrationRequest, and it doesn't appear to be valid in the command when I try to use it.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Sunday, July 14, 2013 9:46 PM
  • New-PublicFolderMigrationRequest -SourceDatabase (Get-PublicFolderDatabase -Server PDX-EXCH2010) -CSVData (Get-Content E:\PF-Import\PFtomail.csv -Encoding Byte) -AcceptLargeDataLoss -BadItemLimit 10 -Largeitemlimit 10

    This is the Powershell statement I used

    From:

    http://technet.microsoft.com/en-us/library/jj218636(v=exchg.150).aspx

    The LargeItemLimit parameter specifies the number of large items to skip if the request encounters such items in the mailbox. Use 0 to not skip any large items. If any number above 50 is specified, the AcceptLargeDataLoss parameter must also be specified. The default value is 0. We recommend that you use the default value of 0 and increase the LargeItemLimit parameter value only when large items are encountered


    • Edited by CalhounRSB Monday, July 15, 2013 12:01 AM Update
    • Proposed as answer by Ed CrowleyMVP Monday, July 15, 2013 6:08 AM
    • Marked as answer by CalhounRSB Monday, July 15, 2013 1:23 PM
    Sunday, July 14, 2013 11:53 PM
  • That's better.  The post marked as an answer has a different parameter, AllowLargeItems, which does not exist.  I did find LargeItemLimit, but the documentation made it seem as if it didn't apply to your case based on your description.  Please unmark the wrong answer and mark your last post as an answer.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    Monday, July 15, 2013 6:08 AM
  • Hi

    I ran into "toomanylargeitemspermamentexception" error during Exchange 2007 to 2013 Public Folder Migration and adding the -Largeitemlimit parameter in the move command helped.

    Harinder

    Thursday, November 14, 2013 4:12 PM
  • please keep in mind that you did not FIX the issue, you only told the migration NOT TO COPY that large files...

    I think the consensus is that people want to know where why & how the restraint is set. IE what can we change on the target (assuming on-premise) that will allow large items to be migrated WITHOUT having to use the -largeitemlimit switch. As this DOES NOT COPY THE LARGE FILES, & skips them, essentially losing the item FOREVER!

    Friday, January 17, 2014 6:36 PM