none
User profile synchonization timer job

    Question

  • Hello, 

    I have 4 servers in farm 2 WFE’s and 2 App servers. One of application servers is hosting Central Administration as well as User Profile Synchronization service. That one is started and configured. But the problem is that even though it is scheduled to run incremental synchronization at 01:00 AM every day it works only sometimes.

    After some investigation I have find out that in timer job history user profiles synchronization timer job is starting on random servers all across the farm instead of just only on the one hosting FIM service. If it hits the correct server, then it is everything ok and synchronization works normally if not then it fails with “RPC server is unavailable”.

    Is there some way how to prevent timer jobs form starting on random server in farm, so far I cannot find anything useful.

    SharePoint 2010 build 14.0.6112.5000 October CU 

    Thank you!

    Tuesday, November 22, 2011 9:35 AM

Answers

  • To resolve this, follow this:

    1. Go to Central Administration

    2. Application management - manage service applications

    3. Select your User Profile Service and from the ribbon select Properties icon

    4. Find Profile Synchronization instance field and select your UPS server there.


    Regards, Stanisław Delost, MCP, MCTS, MCITP @ NETPRIME.
    Check my SharePoint Blog
    • Marked as answer by Seven M Friday, December 02, 2011 8:36 AM
    Tuesday, November 22, 2011 12:43 PM

All replies

  • Hi Bubak,

    Under Central Administration -> System Settigns -> Services on Server, you can configure on which servers certain services are running.

    In the top right corner you can select the server you want to configure, and then stop the services you do not want to run (user profile synchronization service).

    Cheers.


    Kind regards,

    Nico Martens
    SharePoint 2010 Infrastructure Consultant
    Blog: SharePoint Related
    E-mail: info@sharepointrelated.com
    Tuesday, November 22, 2011 9:43 AM
  • Hi Nico,

     UserProfile synchronization service is running only on the CA hosting server and it is provisioned only for one User Profile Application. So this is not the case.

     

    Thank you.

    Tuesday, November 22, 2011 10:11 AM
  • To resolve this, follow this:

    1. Go to Central Administration

    2. Application management - manage service applications

    3. Select your User Profile Service and from the ribbon select Properties icon

    4. Find Profile Synchronization instance field and select your UPS server there.


    Regards, Stanisław Delost, MCP, MCTS, MCITP @ NETPRIME.
    Check my SharePoint Blog
    • Marked as answer by Seven M Friday, December 02, 2011 8:36 AM
    Tuesday, November 22, 2011 12:43 PM
  • Hello,

     

    this is set correctly to the CA hosting server as well. I have reupdated the settings so i will see during the next scheduled run.

     

    Ragard, Pavel

    Tuesday, November 22, 2011 1:21 PM
  • Hi,

    I'm facing the same issue. Profile Synchronization instance points to the only web front where the User Profile Synchronization Service is running, but sync jobs are created randomly in different web servers, failing when they fall into any other front-end.

    Regards,

    António Ribeiro


    aribeiro
    Thursday, December 22, 2011 4:09 PM