none
No network connectivity on VM

    Question

  • Hi

    We are rolling out Hyper-V 3.0 and converting our network from VMware to Hyper-v as we go.

    So far so good, but one of the virtual machines I have converted from VMDK to VHD can't be accessed over the network and it can't see outside itself.

    I have installed the Intergration Tools (the guest is S2003R2) and it connected it to the same HV Switch as the other VMs.  It appears to have it's NIC there OK and I have given it a static IP address.  It shows it's status as "Connected".  It won't get a DHCP address either.

    The only thing I can see that is different from other VMs is that in the VM Network Settings it has a MAC made up of 00:00:etc. when it is both on and off (I would expect it to have 00 if it were off, but not on).  I have attempted to give it a static MAC but this did not fix the problem.

    I have uninstalled/reinstalled the Integration Tools but again does not seem to fix the issue.

    Any ideas?

    Many thanks

    Thursday, September 26, 2013 10:27 AM

Answers

  • A dynamic MAC of 00:00:00:00:00:etc. means that the VM is not getting a MAC assigned form the pool of MACs that the Hyper-V Server has.

    usually a MAC is not assigned dynamically to a vNIC until the VM is powered on for the first time.

    I am assuming that the VM is 2003 R2 with SP2.  You state that you installed the Integration Components after moving it to the Hyper-V Server, so I am assuming that it is the latest.

    Another option is to remove any third party NIC drivers or monitoring agents (if there are any).

    And, as was suggested, be sure that the VMware Tools are properly gone and disabled.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Thursday, September 26, 2013 2:43 PM
  • I have seen issue with a hidden NIC

    open cmd prompt
    set devmgr_show_nonpresent_devices=1
    devmgmt.msc
    in Device Management window that opens, cliclk on VIEW > Show Hidden Decivices
    the hidden devices are greyed out, just uninstall all grayed out NIC's

    I would also go so far as to remove the active NIC from the VM (Both in Vm manager and  on the VM itself) and then reboot

    Then add a new NIC back in and try and see if that clears up the issue.


    James_Stephan@yahoo.com visit my blog stephanco.blogspot.com

    Thursday, September 26, 2013 3:06 PM
  • I have also seen this happen when you assign a static IP address and another computer on the network already has that address.  In that case, the machine will default to an APIPA address.

    What's the output of an ipconfig /all on the problematic VM?


    .:|:.:|:. tim

    Thursday, September 26, 2013 4:25 PM
  • The network settings tab is all about the Integration Components.  The information here comes up from the VM through them.

    That said, the MAC shouldn't, the IP should.  As the MAC is assigned by the hypervisor.

    Did you check that Integration Services are enabled in the VM settings?

    And you mentioned that the legacy NIC does not work.  Seems like I recall something long ago about that and Server 2003 x64.

    http://technet.microsoft.com/en-us/library/ee956895(v=WS.10).aspx


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Thursday, September 26, 2013 9:42 PM

All replies

  • Hi Flanjman, 

    what happens if you give you VM another VNIC? Do this one get an IP via DHCP? What do you use for the VM (Private, Internal or External HV Switch?) 

    Can you create a new VM and attache the VHD and see what happens? 

    Best regards 

    Flo 


    Thursday, September 26, 2013 10:49 AM
  • You removed the VMware Tools?
    Thursday, September 26, 2013 11:00 AM
  • Hi there ,

    Insure the VMtools have been removed from the programs directory.

    check the registry  for any VMtools entries as well as the[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\
    Parameters\Tcpip]

    Thursday, September 26, 2013 11:09 AM
  • Hi

    Thanks for your replies.

    I have added a new vNIC and also tried adding a Legacy adapter but no luck on either.

    I don't have the original VHD anymore but can convert from VMDK if necessary.  I will do this as a last resort if necessary,

    I did remove VMware Tools before converting to VHD and there is no reference to VMware in the Reg adapter properties.

    Thursday, September 26, 2013 11:59 AM
  • A dynamic MAC of 00:00:00:00:00:etc. means that the VM is not getting a MAC assigned form the pool of MACs that the Hyper-V Server has.

    usually a MAC is not assigned dynamically to a vNIC until the VM is powered on for the first time.

    I am assuming that the VM is 2003 R2 with SP2.  You state that you installed the Integration Components after moving it to the Hyper-V Server, so I am assuming that it is the latest.

    Another option is to remove any third party NIC drivers or monitoring agents (if there are any).

    And, as was suggested, be sure that the VMware Tools are properly gone and disabled.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Thursday, September 26, 2013 2:43 PM
  • I have seen issue with a hidden NIC

    open cmd prompt
    set devmgr_show_nonpresent_devices=1
    devmgmt.msc
    in Device Management window that opens, cliclk on VIEW > Show Hidden Decivices
    the hidden devices are greyed out, just uninstall all grayed out NIC's

    I would also go so far as to remove the active NIC from the VM (Both in Vm manager and  on the VM itself) and then reboot

    Then add a new NIC back in and try and see if that clears up the issue.


    James_Stephan@yahoo.com visit my blog stephanco.blogspot.com

    Thursday, September 26, 2013 3:06 PM
  • I have also seen this happen when you assign a static IP address and another computer on the network already has that address.  In that case, the machine will default to an APIPA address.

    What's the output of an ipconfig /all on the problematic VM?


    .:|:.:|:. tim

    Thursday, September 26, 2013 4:25 PM
  • Thanks for all your replies.

    It is indeed 2003R2 SP2.  VMware Tools def removed.  Latest Integration Services installed.

    There are some hidden NICs, but they refer to PPTP L2TP VPN connections.  There are no greyed out connections when I unhide things in Device Manager.

    I have removed the NIC entirely and reinstalled it.

    I reassigned a different IP to the NIC also.

    I have also migrated the VM to another host to see if it would pick up a MAC address.

    IPCONFIG /ALL attached.  It does appear to have a HV MAC address, but this does not show in the Network Settings tab in VM Settings.

    Thursday, September 26, 2013 8:49 PM
  • The network settings tab is all about the Integration Components.  The information here comes up from the VM through them.

    That said, the MAC shouldn't, the IP should.  As the MAC is assigned by the hypervisor.

    Did you check that Integration Services are enabled in the VM settings?

    And you mentioned that the legacy NIC does not work.  Seems like I recall something long ago about that and Server 2003 x64.

    http://technet.microsoft.com/en-us/library/ee956895(v=WS.10).aspx


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Thursday, September 26, 2013 9:42 PM
  • Hi flanjman,

    Is there any update? I would like to check if you need further assistance.

    Thanks.


    Best Regards
    Jeremy Wu

    Monday, September 30, 2013 6:46 PM
  • Hi Jeremy

    I am starting from scratch by converting the VMDK again, I just need to schedule some time in.

    As soon as I have done this I will update the post.

    Many thanks

    Tuesday, October 01, 2013 6:37 AM
  • Hi

    This has now been resolved, I started the conversion from VMDK to VHD afresh.

    Thanks for all your suggestions.

    Wednesday, October 02, 2013 9:09 AM