none
VIDEO STREAMING

    Question

  • HAY PEOPLE,

    I HAVE A PROBLEM.

    I OPENED RECENTLY A WEB SERVER, AND I STARTED LEARNING HTML LANGUAGE. (YESTERDAY, HAHA)

    I AM DOING WERY WELL, AND I REACHED THE POINT WHERE I INCLUDE VIDEO FILES IN MY WEB PAGE.

    WITH THIS SYNTAX:

    <video width="320" height="240" controls>
      <source src="movie.mp4" type="video/mp4">
    </video>

    THIS SYNTAX WORKS PERFECTLY ON MY SERVER LOCALLY.

    SO, WHEN I OPEN AN HTML PAGE IN MY BROWSER ON SERVER, VIDEO IS PLAYED WITOUT ANY DIFFICIOULTIES.

    BUT, WHEN I ACCESS THE SAME WEB PAGE REMOTELY (FROM CLIENT COMPUTER) I KEEP GETTING THIS ERROR MESSAGE:

    404 - File or directory not found.

    WHEN I ACCESS THE SAME WEB PAGE FROM SERVER, BUT USING SERVER IP ADDRESS I KEEP GETTING THIS MEESSAGE:

    HTTP Error 404.3 - Not Found

    BUT, THE PROBLEM IS, THE FILE IS THERE, IT EXISTS, AND IT IS NOT NAMED INCORECCTLY.

    AND WEB PAGE LOADS PERFECTLY, VIDEO PLAYS WHEN I OPEN HTML PAGE DIRECTLY. BUT FROM CLIENT COMPUTER IT DOES NOT WANT TO OPEN.

    SO, WHAT CAN I DO?

    (PLEASE KEEP IN MIND THAT I FIRST TIME EVER STARTED LEARNING HTML YESTERDAY, AND THAT I STARTED MY FIRST WEB PAGE YESTERDAY, SO PLEASE, KEEP YOUR ANSWERS UNDERSTANDABLE. AND MAYBE IT IS SOMETHING SMALL, WERY SMALL SETTING SOMEWHERE WHICH KEEPS BLOCKING ACCESS ;)

    I AM USING WINDOWS SERVER 2008 WITH IIS 7.0

    PLEASE HELP


    • Edited by SYOB SYOT Sunday, March 02, 2014 6:44 AM
    Sunday, March 02, 2014 6:40 AM

Answers

  • Hi,

    Based on my research, the error code 404.3 indicates MIME map policy prevents the access request, please make sure that this policy is configured correctly.

    Here are some troubleshooting links below for your references:

    How system administrators can troubleshoot an "HTTP 404 - File not found" error message on a server that is running IIS

    http://support.microsoft.com/kb/248033

    Description of Microsoft Internet Information Services (IIS) 5.0 and 6.0 status codes

    http://support.microsoft.com/kb/318380

    I also suggest you refer to Microsoft IIS forum to get professional support if this problem persists:

    http://forums.iis.net/

    Best Regards,

    Amy Wang

    • Marked as answer by SYOB SYOT Tuesday, March 04, 2014 11:00 PM
    Tuesday, March 04, 2014 6:11 AM

All replies

  • Hi, watchout for the CAPs PLEASE. Kinda hard to read.

    That mean in your IIS your Default website does not have the file. You must had created a alias, but didn't set it to the default. 


    Regards, Philippe

    Tuesday, March 04, 2014 2:43 AM
  • Hi,

    Based on my research, the error code 404.3 indicates MIME map policy prevents the access request, please make sure that this policy is configured correctly.

    Here are some troubleshooting links below for your references:

    How system administrators can troubleshoot an "HTTP 404 - File not found" error message on a server that is running IIS

    http://support.microsoft.com/kb/248033

    Description of Microsoft Internet Information Services (IIS) 5.0 and 6.0 status codes

    http://support.microsoft.com/kb/318380

    I also suggest you refer to Microsoft IIS forum to get professional support if this problem persists:

    http://forums.iis.net/

    Best Regards,

    Amy Wang

    • Marked as answer by SYOB SYOT Tuesday, March 04, 2014 11:00 PM
    Tuesday, March 04, 2014 6:11 AM
  • THANK YOU, AMY, THE FIRST TROUBLESHOOTING LINK HELPED ME DO IT.

    IT TOOK ME WHOLE 15 SECONDS TO FIX IT.

    BUT, AS I SAID BEFORE, I STARTED THIS WEB SERVER TWO DAYS AGO, AND THIS WEB SERVER IS MY FIRST SERVER IN MY LIFE, SO, MANY THINGS, SIMPLE AS THIS, I DO NOT KNOW.

    THANX. :P

    Tuesday, March 04, 2014 11:00 PM
  • Hi,

    Glad to hear that it helped!

    We all have things that we are not familiar with, just take it slow, I believe you will be doing great!

    Have a nice day,

    Amy

    Wednesday, March 05, 2014 1:42 AM
  • THANX. :D
    Thursday, March 06, 2014 9:18 PM