none
Wildcard certificate on RD session host

    Question

  • Hi there,

    I am having some troubles with using a wildcard certificate on the RD session host. I have a wildcard certificate from Digicert as *.abc.com (for example). I am able to configure this to:

    • RD web
    • Remote app manager for signing the rdp

    But when it comes to RD session host configuration it just don't allow me to select the wildcard cert, when I go to RDP-tcp->properties->General->Select, it just gives me "There are no certificates installed on this remote desktop session host server".

    I am running Windows server 2008 R2 SP1 and from what I searched it should be accepting the wildcard certificates. Does anyone has any ideas on this?

    Thanks,

    Adrian.

    Saturday, September 28, 2013 4:48 PM

Answers

  • Hi Adrian,

    Firstly, let me know whether you import the certificate and its private key into the Local Computer Personal store?

    You must install in personal certificate of computer account and not on your personal. After performing that it will be visible and selectable.  It is possible that if you will drag the certificate to computer\personal it will remove the private key. You must directly import into that location. If you requested/installed the certificate using a different server please export it along with its private key as a .pfx file and then import it on your RDSH server.

    For a test, please delete the certificate from the stores from where you have imported it into and then re-import it, if you have not tried this.
    You can also try using certutil.exe –repairstore option with admin rights. Refer certutil for more option.

    Hope This Helps!
    Thanks.

    • Marked as answer by Adrian_Y Monday, September 30, 2013 3:22 PM
    Monday, September 30, 2013 6:17 AM
    Moderator

All replies

  • Hi Adrian,

    Firstly, let me know whether you import the certificate and its private key into the Local Computer Personal store?

    You must install in personal certificate of computer account and not on your personal. After performing that it will be visible and selectable.  It is possible that if you will drag the certificate to computer\personal it will remove the private key. You must directly import into that location. If you requested/installed the certificate using a different server please export it along with its private key as a .pfx file and then import it on your RDSH server.

    For a test, please delete the certificate from the stores from where you have imported it into and then re-import it, if you have not tried this.
    You can also try using certutil.exe –repairstore option with admin rights. Refer certutil for more option.

    Hope This Helps!
    Thanks.

    • Marked as answer by Adrian_Y Monday, September 30, 2013 3:22 PM
    Monday, September 30, 2013 6:17 AM
    Moderator
  • Hi,

    Your suggestions work flawlessly. I remove the existing cert and re-import directly to the personal cert store of the machine account and it is now available for selection. Guess when I do the import earlier it got imported to the user account instead and when I try to move the cert to a different store the private key got lost.

    Thanks a lot.

    Adrian.

    Monday, September 30, 2013 3:22 PM
  • Hi,

    Glad to hear that your issue resolved.

    In future if you want any further help, kindly place your question in Forum.

    Thanks.
    Tuesday, October 01, 2013 4:31 AM
    Moderator