none
How do I configure WHS to enable laptop to play music off home server? (worked with XP but not WHS)

    Question

  • I recently switched from XP on my home server to Windows Home Server for the backup capabilities.

     

    With XP installed I was able to use remote desktop to access the server, launch Media Player, and play music through my Crestron Audio Distribution system.

     

    With WHS installed I can start Media Player 10 and play music through the Crestron system, but that requires a trip to the downstairs storage room where the server is located.

     

    When I connect to WHS via REmote Desktop session as Administrator, I can launch Media Player but when I try to play a song I get the following error msg:

     

    "Windows Media Player cannot play the file because there is a problem with your sound device. There might not be a sound device installed on your computer, it might be in use by another program, or it might not be functioning properly."

     

    How can I configure WHS to make this work?

     

    Jeff

    Monday, June 23, 2008 12:27 AM

All replies

  •  jeff_r_thiel wrote:
    I recently switched from XP on my home server to Windows Home Server for the backup capabilities.

     

    With XP installed I was able to use remote desktop to access the server, launch Media Player, and play music through my Crestron Audio Distribution system.

     

    With WHS installed I can start Media Player 10 and play music through the Crestron system, but that requires a trip to the downstairs storage room where the server is located.

     

    When I connect to WHS via REmote Desktop session as Administrator, I can launch Media Player but when I try to play a song I get the following error msg:

     

    "Windows Media Player cannot play the file because there is a problem with your sound device. There might not be a sound device installed on your computer, it might be in use by another program, or it might not be functioning properly."

     

    How can I configure WHS to make this work?

     

    Jeff

     

    First, that is not the intended use of WHS.  You are trying to use it as a client PC (which it's not).  You should be using it to stream music/photos/videos to other computers and devices.  You should not be attempting to logon to the desktop and play files locally.

     

    Having said that, it sounds to me like you're missing audio drivers for your sound card.

    Monday, June 23, 2008 12:51 AM
    Moderator
  • Hi Jeff,

    This thread is quite old, I don't know whether you solved the problem or not. I am using the home server to play audio through the house, with a similar setup. server in the basement connected to central audio system.

    First of all, to log on as administrator you need to add "/admin" to the Start Menu command. It should look like this: %windir%\system32\mstsc.exe /admin

    It's /admin for both Vista and Windows7, and /console for XP.

    You also have to set the sound to play on remote computer in Remote Desktop/Options/Local Resources.

    Go  to Start/Control Panel/Sounds And Audio Devices/Audio on your server and check that your audio drivers are shown there.

    That should be it. I can recommend you the add-in WebRadio which alows you to set up internet stations. Works excellent and remains connected even after you disconnect the Remote Desktop session.

    Now if you need to control your sound over internet, you can activate the web settings for remote desktop, or what I am using for better encryption is OpenVPN. OpenVPN is free download and works really well. Once you establish the connection between your laptop and the server (over internet) you just use Remote Desktop as administrator.
    If you need help setting up OpenVPN, let me know.

    Alin
    Wednesday, August 26, 2009 8:38 PM