none
using custom Target Namespace for EDI 834 schemas

    Question

  • Hi ,

    I am using BizTalk 2010.

    Currently i am facing an issue in customizing EDI schemas foir my project.

    I am using my own custom target namespace"http://sample.EDI/834/single" for the X12 EDI schemas, instead of the default target namespace"http://schemas.microsoft.com/BizTalk/EDI/X12/2006".

    I have Parties configured in my sample project.

    If i deploy the schemas with default namespace, the end to end application is working fine.

    If i change the default namespace & use my custom namespace its throwing the below error:

    Finding the document specification by message type "http://schemas.microsoft.com/BizTalk/EDI/X12/2006#X12_00401_834" failed. Verify the schema deployed properly. 

    I changed the party agreement to have the new custom namespace using the Custom Target namespace option, even then I am getting the same error.

    Please help me out to resolve it.

    Thanks

    J

    • Edited by JK_1418 Friday, September 13, 2013 1:32 AM
    Friday, September 13, 2013 12:01 AM

Answers

  • First, make sure Fallback Settings are Disabled.  It sounds like you're Agreement is not resolving properly.

    If you are able to see your custom namespace on the Local Host Settings page, then your schema is deployed properly.

    To disable Fallback Settings, Right click Parties, X12 Fallback Settings, make sure Enable Fallback Settings is unchecked.

    Friday, September 13, 2013 1:53 PM

All replies

  • If the EDIDisassembler is still expecting the default namespace, it means that it has not matched your X12 document with the Agreement where the custom namespace has been declared.

    Check your ISA settings under "Identifiers".

    Morten la Cour

    Friday, September 13, 2013 4:32 AM
  • Hi Morten,

    I checked my Identifiers under ISA Settings.

    Its correct.

    If i just change the custom namespace to default namespace in the aggrement(after making appropriate changes in schmea in the solution), its working fine.

    just if i revert back & use custom namespace it throwing the same error.

    Thanks

    J


    Thanks, J

    Friday, September 13, 2013 1:18 PM
  • First, make sure Fallback Settings are Disabled.  It sounds like you're Agreement is not resolving properly.

    If you are able to see your custom namespace on the Local Host Settings page, then your schema is deployed properly.

    To disable Fallback Settings, Right click Parties, X12 Fallback Settings, make sure Enable Fallback Settings is unchecked.

    Friday, September 13, 2013 1:53 PM
  • Hi Jk,

    There is one more thing you need to check.

    Did you build and deployed the custom schema?



    I hope this helps!!!!!!

    Maheshkumar S. Tiwari|BizTalk Developer Interview Questions and Answers

    http://tech-findings.blogspot.com/


    Saturday, September 14, 2013 12:33 AM