none
Address Resolution

    Question

  • Hi,

    I have a problem resolving email address in mixed mail infrastructure. Below is the scenerio.

    I have a user who has a mailbox on Exchange but is configured not to receive any email.
    The same user has a mailbox configured on internal mail application
    The email address used for exchange is an internal email address while the one on internal mail application its an open/public email address

    On Exchange: abc@admin.123.int
    On Mail App: abc@123.com

    Now whenever someone tries to send email to abc@123.com outlook/exchange resolves it to abc@admin.123.int and we get an NDR.

    Please suggest a resolution.

    Outlook version 2010 & 2003


    Thanks in advance !!

    Monday, September 16, 2013 2:54 PM

Answers

  • Thanks, that's clearer now. I think your issue is almost certainly that in Exchange the 123.com domain is currently setup in Accepted Domains as being Authoritative, so it will never get passed elsewhere. Two possible things you could do.

    1) Change the Accepted Domains setting to make 123.com an External Relay, and then in Send Connectors add an entry for 123.com with the Network part set to route mail through a smart host which you then configure as the mail application server. This way, as long as all mail for 123.com first hits your Exchange server all valid local addresses will receive their email, but anything that's not found locally will be passed onto the send connector, therefore delivering mail for abc@123.com to the application server. It does mean however that all mail for invalid mail aliases will go to and be handled by the application server rather than Exchange.

    2) If the application server is able to handle having multiple domains and aliases configured for a single user, create a dummy domain for instance 123.foo. On the application server configure set it up to accept mail for 123.foo and add abc@123.foo as an alias to the existing account (so it can accept mail to either abc@123.com or abc@123.foo) while keeping abc@123.com as the default sending address. On Exchange add abc@123.com to the existing Exchange account, but then configure it to forward all mail to abc@123.foo instead (eg, properties, Mail Flow Settings, Delivery Options, Forward to). Add 123.foo to accepted domains as an external relay, and as in the first suggestion add 123.foo as a send connector with the smarthost as the application server.

    I know the first option works as we use the same thing with some users who have their email received outside of Exchange, but while more faff, the second option might be preferable since you're only passing messages for that specific user to the application server.

    Monday, September 16, 2013 8:49 PM

All replies

  • If all the users in Exchange have their email set to @admin.123.int, and no one on exchange has @123.com configured, have you checked that Exchange isn't configured to treat 123.com as being local to itself? If Exchange thinks the domain is local to itself then it will assume it is the only destination for mail to that domain, and if it doesn't find a matching recipient locally it will reject the message rather than try to send it elsewhere.

    If you tell Exchange that it isn't authoritative for the 123.com domain then if it doesn't find the recipient locally it will try to deliver it elsewhere.

    On the users unused Exchange mailbox (abc@admin.123.int) has someone added abc@123.com as an email alias? That might explain why the messages are being resolved to the wrong address and therefore trying to be delivered to the wrong account.

    Finally, when you say it resolves the address what exactly do you mean, do you mean after you send the message, or while you're typing the email address? Has the user previously been configured to use the exchange mailbox? If Outlook's auto-completing the wrong destination it could be because it has old cached information which need clearing rather than assuming you want to send to the old destination.

    Monday, September 16, 2013 6:53 PM
  • Hi Keith,

    Our servers our in the domain admin.123.int hence by default all exchange users will have xxxx@admin.123.int

    Since this is an internal domain no one can reply to this email from external email address i.e gmail, hotmail, etc.

    The problem user at my side has a mailbox configure to send email but cannot receive email; and the only email address that is assigned is abc@admin.123.com.

    The email address that is know to the public is abc@123.com; so if I have to send email from outlook to this user I have to send it to abc@123.com. But when I type the email address abc@123.com outlook is resolving it to abc@admin.123.com automatically.

    I have cleared the cache, created a separate mail contact, have hidden it from exchange list but no go, the problem persist.

    Note: The domain @123.com is set for many other user who have the ability to send & receive emails from exchange/outlook.

    Monday, September 16, 2013 8:02 PM
  • Thanks, that's clearer now. I think your issue is almost certainly that in Exchange the 123.com domain is currently setup in Accepted Domains as being Authoritative, so it will never get passed elsewhere. Two possible things you could do.

    1) Change the Accepted Domains setting to make 123.com an External Relay, and then in Send Connectors add an entry for 123.com with the Network part set to route mail through a smart host which you then configure as the mail application server. This way, as long as all mail for 123.com first hits your Exchange server all valid local addresses will receive their email, but anything that's not found locally will be passed onto the send connector, therefore delivering mail for abc@123.com to the application server. It does mean however that all mail for invalid mail aliases will go to and be handled by the application server rather than Exchange.

    2) If the application server is able to handle having multiple domains and aliases configured for a single user, create a dummy domain for instance 123.foo. On the application server configure set it up to accept mail for 123.foo and add abc@123.foo as an alias to the existing account (so it can accept mail to either abc@123.com or abc@123.foo) while keeping abc@123.com as the default sending address. On Exchange add abc@123.com to the existing Exchange account, but then configure it to forward all mail to abc@123.foo instead (eg, properties, Mail Flow Settings, Delivery Options, Forward to). Add 123.foo to accepted domains as an external relay, and as in the first suggestion add 123.foo as a send connector with the smarthost as the application server.

    I know the first option works as we use the same thing with some users who have their email received outside of Exchange, but while more faff, the second option might be preferable since you're only passing messages for that specific user to the application server.

    Monday, September 16, 2013 8:49 PM