none
Information Management Policy not triggering SPD workflow

    Question

  • Hi All,

    I have a document library with no special fields (i.e. Lookups) and I have created a workflow via SPD to create a task to review the document and send to a Records Center, if necessary. The WF is working properly.

    I then set an Information Management Policy on the library through the SharePoint UI following these steps:

    1. Define a policy...
    2. Policy Statement: This document expires in 1 day (testing)
    3. Checked "Enable Expiration ":
           The retention period is: Modified + 1 + days
           When the item expires:
           Start this workflow: IMP WF Test 2


    But the IMP never triggers the workflow.

    • I have checked the "Information Management Policy Configuration" via Central Administration, and "Expiration" is available and set to run daily.
    • I have tried the "Process Expired Items Now" manual option via the CA "Configure Expiration" page.
    • I have tried this with "Require Check Out" enabled and disabled with no success in either case.
    • I have tried this with Publishing features enabled and disabled with no success.
    • I have combed this forum thoroughly looking for similar situations and possible resolutions with no success.

    Can anyone offer any other suggestions?

    Thank you in advance for any help.

    CG


    Chris G.
    Monday, February 21, 2011 4:31 PM

Answers

  • Got it!  Check your timer job service and make sure that your WSS Timer Jobs is running. Something killed mine.
    Chris G.
    • Marked as answer by Peng Lei Monday, February 28, 2011 1:55 AM
    Tuesday, February 22, 2011 8:18 PM

All replies

  • Got it!  Check your timer job service and make sure that your WSS Timer Jobs is running. Something killed mine.
    Chris G.
    • Marked as answer by Peng Lei Monday, February 28, 2011 1:55 AM
    Tuesday, February 22, 2011 8:18 PM
  • Hi,

       Is there any specific timer job to watch out ?

    I am facing the same problem.


    We have a SP 2010 environment.
    • Edited by chanakya26 Tuesday, February 21, 2012 4:14 PM
    Tuesday, February 21, 2012 4:13 PM