none
Microsoft SqlServer 2008 Management SqlStudio Error

    Question

  • I am just installed SqlServer 2008 and then i am getting error when i am exploring server in Management Studio

    OS Windows 7 Home Premium.

    I and then when i am lunched Management studio there am getting popup window with the willowing error:

    Value cannot be null.
    Parameter name: viewInfo (Microsoft.SqlServer.Management.SqlStudio.Explorer)

    Here is detailed information of this error:

    ===================================

    Value cannot be null.
    Parameter name: viewInfo (Microsoft.SqlServer.Management.SqlStudio.Explorer)

    ------------------------------
    Program Location:

    at Microsoft.SqlServer.Management.SqlStudio.Explorer.ExplorerViewDescriptor..ctor(IFactoryService factoryService, INavigationViewInfo viewInfo, String urnPath, IDictionary`2 allEntities)
    at Microsoft.SqlServer.Management.SqlStudio.Explorer.NavigationService.GetView(String urnPath)
    at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItemBuilder.<GetColumnsFromNavigationService>d__f.MoveNext()
    at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItemBuilder.AddFields(List`1 list, IEnumerable`1 fields, IDictionary`2 allValidFields, AddFieldsFlags flags)
    at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItemBuilder.GetFields(INodeInformation source, Dictionary`2& allValidColumns)
    at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItemBuilder.BuildDynamicItemWithQuery(IList`1 nodes, INodeInformation source, INavigableItem sourceItem, String urnQuery, Boolean registerBuilder, Boolean registerBuiltItems)
    at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItemBuilder.BuildDynamicItem(IList`1 nodes, INodeInformation source, INavigableItem sourceItem, IFilterProvider filter)
    at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItemBuilder.Build(IList`1 nodes, INodeInformation source, INavigableItem sourceItem, IFilterProvider filter)
    at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItem.RequestChildren(IGetChildrenRequest request)
    at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.ExplorerHierarchyNode.BuildChildren(WaitHandle quitEvent)

    Any ideas Why it is happening?

    How may i fix it?

    Sunday, July 25, 2010 10:50 AM

Answers

  • See the workaround suggested in the following connect item helps..

    https://connect.microsoft.com/SQLServer/feedback/details/573771/value-cannot-be-null?wa=wsignin1.0#

     

    >>It turned out that during installation \Framework\v2.0.50727\CONFIG\machine.config was modified and other windows accounts (not the one which performed the installation) lost access to the file. Granting explicit rigths to the file resolved the issue. \Framework\v2.0.50727\CONFIG\machine.config was modified and other windows accounts (not the one which performed the installation) lost access to the file. Granting explicit rigths to the file resolved the issue.

     

    Sunday, July 25, 2010 11:07 AM

All replies

  • See the workaround suggested in the following connect item helps..

    https://connect.microsoft.com/SQLServer/feedback/details/573771/value-cannot-be-null?wa=wsignin1.0#

     

    >>It turned out that during installation \Framework\v2.0.50727\CONFIG\machine.config was modified and other windows accounts (not the one which performed the installation) lost access to the file. Granting explicit rigths to the file resolved the issue. \Framework\v2.0.50727\CONFIG\machine.config was modified and other windows accounts (not the one which performed the installation) lost access to the file. Granting explicit rigths to the file resolved the issue.

     

    Sunday, July 25, 2010 11:07 AM
  • I find an another solution, maybe helo you

     

    1. Open Windows Explorer, paste the %USERPROFILE% in the navigation bar, or go to your user profile.

    2. Navigate to the following directory: Documents\SQL Server Management Studio\Settings and delete all file what you are find here

    3. Restart the SQL Server management Studio, and everything is working again correctly.

     

     

    Monday, August 02, 2010 12:16 PM
  • I saw this late, but neither of these solves it for me (on R2).  Perhaps someone could be more specific about what user permissions to add to machine.config?  I added the usual dbo user of sql server, giving all permissions to all machine.configs, but it made no difference.  Do I need to add one of the system accounts?  The problem seems to have arisen right after the security updates from microsoft (but it may have been caused by windows live installation also--both occurred about the same time).  even a complete repair does not correct.

    Please follow on this thread:
    http://social.msdn.microsoft.com/Forums/en-US/sqltools/thread/7e0287b3-cd37-408e-8145-4b9dba8c7811

     

    Sunday, October 17, 2010 4:31 PM
  • So i digged a little deeper and figured out it was a missing directory/file in %TEMP%. Seems some CleaningTool removes all files/directories in %Temp% and after that SSMS was not working any longer. The missing file is actually not needed, but the missing directory causes the "Value cannot be null" error.

    My missing file name was:
    C:\Users\<username>\AppData\Local\Temp\2\6vvdaozf.tmp
    But the file name changes on every startup.
    So my missing directory name was:
    C:\Users\<username>\AppData\Local\Temp\2
    After creating a empty directory with the name "2" in %TEMP% all went back to work fine for me.

    I'm not sure the directory name is every time the same, but you can discover your missing file with the process monitor from Sysinternal Tools and filters to "Process Name is ssms.exe" and "Path contains AppData\Local\Temp"

    Hope this helps other people to solve their issues too.
    Wednesday, December 01, 2010 10:43 AM
  • This solution worked for me. I am using Windows 7 and for some reason %Temp% opened in C:\Windows\Temp. I created the "2" folder there  and SSMS stopped popping up that exception.

    Thank you very much for the suggestion !

    • Proposed as answer by Matt Fox Friday, May 13, 2011 7:34 PM
    Monday, January 10, 2011 5:51 PM
  • this resolved my problem. i looked throgh the process manager. it was 4 for me so i create a directory suc as C:\Users\<username>\AppData\Local\Temp\4 and it worked. it is such a troublesome bug. :((
    Tuesday, March 29, 2011 2:45 PM
  • HI ALL, I have disable UAC or I Have used "run as administrator" REGARDS
    Marco Tarulli MCT
    Friday, May 06, 2011 8:03 PM
  •  

     

    Thanks it worked me in 2008 R2

    thank you very much..


    Christopher - |MCP Windows XP |MCITP:Server Administrator,Database Administrator,Ax2009 Installation & Configuration|SharePoint Administrator 2010 | CCNA ....
    Friday, September 23, 2011 6:14 AM
  • Superrrb! Your solution works perfectly... I had my head banging for 1 hour before I came to this page :)
    Saturday, December 31, 2011 4:19 PM
  • In my case I deleted all the files in C:\Users\<username>\AppData\Local\Temp, including the "2".  This caused the error to go away after re-opening SSMS.
    Thursday, January 12, 2012 5:53 PM
  • this works for me , and thanks a lot
    Wednesday, January 18, 2012 8:20 AM
  • I had this same issue; tried everything I could find any/every where through this date to no avail.

    Finally discovered a complaint about the '=' sign in the <customErrors  /> line below,

    from the file: C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG\machine.config:

        <system.web>
           
    <customErrors = "Off"/>
       
    </system.web>

    Removed that line an Voilà!  Resolved.  Later found references indicating it should have been:

        <system.web>
           
    <customErrors mode="Off"/>
       
    </system.web>

    Gads...  a full day of head scratching...   no hair left ....



    • Edited by tballister Tuesday, September 25, 2012 12:57 AM typo
    Tuesday, September 25, 2012 12:54 AM
  • Alternatively - Try: RUN AS ADMINISTRATOR

    Either right click the SQL Mgt Studio Icon and choose Run as Administrator.

    Or edit the advanced properties of the SSMS shortcut and tick Run as Administrator.

    Monday, November 11, 2013 3:57 AM
  • Chiken79 you are the man! Nicely done. 
    Wednesday, November 20, 2013 2:15 PM
  • Let us know if you see this issue in SQL 2014

    you can create a SQL 2014 Virtual machine on Windows Azure - http://azure.microsoft.com/en-us/pricing/free-trial/
    or
    You can download SQL 2014 from http://technet.microsoft.com/en-US/evalcenter/dn205290

    Thanks
    Sethu Srinivasan [MSFT]
    SQL Server


    Thanks, Sethu Srinivasan [MSFT] SQL Server http://blogs.msdn.com/sqlagent -------------------------------------------------------------------------------- This posting is provided &amp;quot;AS IS&amp;quot; with no warranties, and confers no rights. Please remember to click &amp;quot;Mark as Answer&amp;quot; and &amp;quot;Vote as Helpful&amp;quot; on posts that help you. This can be beneficial to other community members reading the thread.

    Wednesday, April 09, 2014 12:25 AM