none
Set MaximumErrorCount does not work!

    Question

  • Hi,

     

    I'm new in SSIS and I'm trying to copy data (1 table) from server1 to server2; I've set the MaximumErrorCount to 10 at control flow level, the transfer fails with this message :

     

    Warning: The Execution method succeeded, but the number of errors raised (3) reached the maximum allowed (1); resulting in failure. This occurs when the number of errors reaches the number specified in MaximumErrorCount. Change the MaximumErrorCount or fix the errors.

     

    1. I'm wondering why SSIS tells me the maximum allowed (1) even if MaximumErrorCount = 10 ? do I miss something in settings ?

     

    2. How to tell SSIS to transfer fails row to flat file and continue to processes next rows.

     

    Thank you very match for your help

     

    Tuesday, February 13, 2007 4:17 PM

All replies

  • Set it on the data flow, not the control flow.
    Tuesday, February 13, 2007 4:23 PM
  • Set it on the data flow, not the control flow.

    where specifically??

    2003

    Thursday, July 04, 2013 8:51 PM
  • Set it on the data flow, not the control flow.


    where specifically??

    2003

    Click on the data flow, hit F4 to call in the properties window and set MaximumErrorCount to 10.

    MCSE SQL Server 2012 - Please mark posts as answered where appropriate.

    Friday, July 05, 2013 7:46 AM