none
Problema con predeterminación de documento en IIS 7.5

    Question

  • Buenos días,

    El problema que tengo es que al registrar el documento index.php como predeterminado en mi sitio web, no toma el cambio y sale el siguiente error al cargar mi sitio en el navegador del servidor:

    Resumen de error

    Error HTTP 500.19 - Internal Server Error

    No se puede obtener acceso a la página solicitada porque los datos de configuración relacionados de la página no son válidos.

    <fieldset><legend>Información de error detallada</legend>
    Módulo IIS Web Core
    Notificación Desconocido
    Controlador No determinado aún
    Código de error 0x80070005
    Error de configuración No se puede leer el archivo de configuración porque los permisos son insuficientes
    Archivo de configuración \\?\G:\prensanet\web.config
    Dirección URL solicitada http://192.168.1.36:80/
    Ruta de acceso física
    Método de inicio de sesión No determinado aún
    Usuario de inicio de sesión No determinado aún
    </fieldset>

    Esto es lo que contiene el archivo web.config de mi sitio:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <defaultDocument>
                <files>
                    <add value="index.php" />
                </files>
            </defaultDocument>
            <directoryBrowse enabled="false" />
        </system.webServer>
    </configuration>

    He intentado hasta darle permisos a Todos a la carpeta de mi sitio web y aún así no funciona.

    Wednesday, November 28, 2012 11:18 AM

All replies

  • Hola Juan Diego!

    Ante todo, al parecer este error no es por setear el documento predeterminado, sino porque el application pool o el usuario de navegación de tu página web en el servidor no tiene derechos suficientes para leer en el directorio donde tenés publicada la aplicación.

    Te sugiero revisar lo siguiente:

    • ¿Qué usuario utilizás para el Application Pool de la aplicación web?: esto lo verificás desde las opciones avanzadas (advance settings) de tu application pool, en la opción "Identity".
    • ¿Qué usuario utilizás para navegar anónimamente en tu aplicación web?: esto lo verificás desde las propiedades de tu sitio web, opción "autenticación" (authentication) y autenticación anónima (Anonymous Authentication).
    • En base a los resultados anteriores, ¿tenés correctamente seteado los permisos NTFS en la seguridad de tu carpeta de publicación del sitio?

    Esperamos tu feedback!

    Saludos!!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    Wednesday, December 05, 2012 4:04 AM
  • Hola Juan Diego!

    ¿Pudiste solucionar este problema que informaste?

    Saludos!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    Tuesday, December 11, 2012 2:01 AM