none
Arquivos TIF - Visualizador Default

    Question

  • Prezados,

     

    em um cliente, temos uma aplicação de GED, onde estão todos os arquivos da empresa digitalizados em .tif, os usuários utilizam ou o visualizador de imagens do windows ou o Imaging. Pelo menos uma vez por mês (após a aplicação das atualizações Microsoft) o Windows perde referência do programa para abrir arquivos .TIF, sendo necessário ir em ferramentas > opções de pasta > tipos de arquivo > novo e criar o extenção TIF.

     

    alguem sabe porque isso acontece? e como posso corrigir isso de forma automática

     

    muito obrigado a todos.

    Wednesday, December 17, 2008 6:53 PM

Answers

  • Olá,

    Faça o seguinte:

    Exporte as chaves de registro referente à extensão dos arquivos que você deseja :

    [HKEY_CLASSES_ROOT\]
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\

    Salve como .reg

    E crie um script bat com o conteúdo:

    regedit.exe /s c:\arquivo.reg

    Onde arquivo.reg é o arquivo com o conteúdo das chaves.

    Salve essa bat e utilize como logon script.

    Até mais,

    Jesiel

    Obs.: Se útil, classifique
    Thursday, December 18, 2008 11:46 AM
  • Caro Josiel,

     

    Obrigado pela dica, haviamos preparado um reg, mas não havia funcionado completamente, com o seu tb não, mas juntamos tudo e o resultado foi esse abaixo. quando o arquivo é acessado pelo IE ele agora abrirá automaticamente sem pedir para escolher o programa.

     

    Code Snippet

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.tif]
    "Content Type"="image/tiff"
    @="ft000004"
    "PerceivedType"="image"

    [HKEY_CLASSES_ROOT\.tif\MSPaper.Document]

    [HKEY_CLASSES_ROOT\.tif\MSPaper.Document\ShellNew]

    [HKEY_CLASSES_ROOT\.tif\OpenWithList]

    [HKEY_CLASSES_ROOT\.tif\OpenWithList\mspview.exe]
    @=""

    [HKEY_CLASSES_ROOT\.tif\OpenWithProgids]
    "TIFImage.Document"=hex(0):

    [HKEY_CLASSES_ROOT\.tif\PersistentHandler]
    @="{58F2E3BB-72BD-46DF-B134-1B50628668FB}"

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.tif]
    "Progid"="MSPaper.Document"

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.tif\OpenWithList]
    "MRUList"="acb"
    "a"="MSPVIEW.EXE"
    "c"="mspaint.exe"
    "b"="shimgvw.dll"

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.tif\OpenWithProgids]
    "TIFImage.Document"=hex(0):
    "MSPaper.Document"=hex(0):
    "ft000004"=hex(0):

     

    [HKEY_CLASSES_ROOT\.tiff]
    @="ft000005"
    "PerceivedType"="image"

    [HKEY_CLASSES_ROOT\.tiff\OpenWithProgids]
    "TIFImage.Document"=hex(0):

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.tiff]
    "Progid"="MSPaper.Document"

     

     

    abraço,

    Thursday, December 18, 2008 1:19 PM

All replies

  • Paolo,

     

    clica com o botão direito no arquivo, escolha Abrir Com, se não aparecer esta opção, pressione SHIFT e clique com o botão direito, escolha Abrir Com, escolha o programa de sua preferência e marque a caixa de seleção "Usar sempre o programa selecionado..."

     

    Abraços

     

    Wednesday, December 17, 2008 9:59 PM
  • Prezado Gilberto,

     

    Acho que você não entendeu, mesmo que eu faça isso desta forma ou de outra tantas, as vezes após as atualizações as referencias são perdidas novamente, sendo necessário fazer esse procedimento de novo, imagina isso pra um parque com 200 máquinas.

     

    Gostaria de saber porque essas atualizações fazem com que a referência para arquivos TIF sejam perdidas e como caso não seja possivel corrigir, fazer que esse procedimento de configurar o arquivo tif para abrir com seja feito de forma automática (seja por script, registro ou qualquer outra forma).

     

    desde já, obrigado.

     

    Thursday, December 18, 2008 10:53 AM
  • Olá,

    Faça o seguinte:

    Exporte as chaves de registro referente à extensão dos arquivos que você deseja :

    [HKEY_CLASSES_ROOT\]
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\

    Salve como .reg

    E crie um script bat com o conteúdo:

    regedit.exe /s c:\arquivo.reg

    Onde arquivo.reg é o arquivo com o conteúdo das chaves.

    Salve essa bat e utilize como logon script.

    Até mais,

    Jesiel

    Obs.: Se útil, classifique
    Thursday, December 18, 2008 11:46 AM
  • Caro Josiel,

     

    Obrigado pela dica, haviamos preparado um reg, mas não havia funcionado completamente, com o seu tb não, mas juntamos tudo e o resultado foi esse abaixo. quando o arquivo é acessado pelo IE ele agora abrirá automaticamente sem pedir para escolher o programa.

     

    Code Snippet

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.tif]
    "Content Type"="image/tiff"
    @="ft000004"
    "PerceivedType"="image"

    [HKEY_CLASSES_ROOT\.tif\MSPaper.Document]

    [HKEY_CLASSES_ROOT\.tif\MSPaper.Document\ShellNew]

    [HKEY_CLASSES_ROOT\.tif\OpenWithList]

    [HKEY_CLASSES_ROOT\.tif\OpenWithList\mspview.exe]
    @=""

    [HKEY_CLASSES_ROOT\.tif\OpenWithProgids]
    "TIFImage.Document"=hex(0):

    [HKEY_CLASSES_ROOT\.tif\PersistentHandler]
    @="{58F2E3BB-72BD-46DF-B134-1B50628668FB}"

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.tif]
    "Progid"="MSPaper.Document"

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.tif\OpenWithList]
    "MRUList"="acb"
    "a"="MSPVIEW.EXE"
    "c"="mspaint.exe"
    "b"="shimgvw.dll"

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.tif\OpenWithProgids]
    "TIFImage.Document"=hex(0):
    "MSPaper.Document"=hex(0):
    "ft000004"=hex(0):

     

    [HKEY_CLASSES_ROOT\.tiff]
    @="ft000005"
    "PerceivedType"="image"

    [HKEY_CLASSES_ROOT\.tiff\OpenWithProgids]
    "TIFImage.Document"=hex(0):

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.tiff]
    "Progid"="MSPaper.Document"

     

     

    abraço,

    Thursday, December 18, 2008 1:19 PM