none
Word 2010, Windows 7, very slow editing

    Question

  • I upgraded my Dell Inspiron 2GB ram E1505 laptop to Windows 7 Professional and Word 2010.    I recently began editing a Word document that was created in a previous version of Word 2007, about 12 pages with 9000 words and more than 10 drawing canvases.  The keystroke response time to do anything is excruciatingly slow.  Editing the drawings is extremely slow.  Adding or deleting single letters in sentences takes about 2 seconds per keystroke.  Each letter added or deleted seems to require that the whole document redisplay. Scrolling up and down takes multiple seconds per page per key stroke.  

    Both of my attempts to work around the situation failed.  First, I created a new document and selected all the information from the old document and pasted it into the new document, but performance did not improve.  Second, from Jennifer Zhan’s prior posting, I unchecked the Trust Center options, but performance did not improve. 

    Unless I can address this performance issue very quickly, I will likely be forced to remove Office 2010 from my computer, go backwards, and reinstall Office 2007.

    Any assistance will be appreciated.

     

    Sunday, August 15, 2010 10:03 PM

Answers

  • Hi,

    First, try to start Word in safe mode [hold ctrl key while startup] to see if this issue is caused by some add-ins. If it works well in safe mode, disable all add-ins. How to do this, see here:

    http://office.microsoft.com/en-us/outlook-help/enable-or-disable-add-ins-in-office-programs-HA010034127.aspx

    Also you may try some other methods:

    Reset the Word data key in the Windows Registry

    • Click Start and then click Run. In the Open box, type Regedit and then click OK.
    • Open the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word
    • Under the Word key, click the Data subkey.
    • On the Edit menu, click Delete. Click Yes if the following message appears: Are you sure you want to delete this key?
    • On the Registry menu, click Exit. Re-start Word.

    Repair or replace damaged or missing fonts

    Damaged or missing fonts can cause the issue that word runs slowly when you edit in Word. To correct this problem, remove and reinstall the fonts.

    In addition, if you use printer on this PC, try to delete and reinstall your printer driver.

    If all of above has no avail, I suggest you uninstall your office 2010 and re-install it.

    • Marked as answer by Jennifer Zhan Monday, August 23, 2010 2:26 AM
    Tuesday, August 17, 2010 3:38 AM

All replies

  • Hi,

    First, try to start Word in safe mode [hold ctrl key while startup] to see if this issue is caused by some add-ins. If it works well in safe mode, disable all add-ins. How to do this, see here:

    http://office.microsoft.com/en-us/outlook-help/enable-or-disable-add-ins-in-office-programs-HA010034127.aspx

    Also you may try some other methods:

    Reset the Word data key in the Windows Registry

    • Click Start and then click Run. In the Open box, type Regedit and then click OK.
    • Open the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word
    • Under the Word key, click the Data subkey.
    • On the Edit menu, click Delete. Click Yes if the following message appears: Are you sure you want to delete this key?
    • On the Registry menu, click Exit. Re-start Word.

    Repair or replace damaged or missing fonts

    Damaged or missing fonts can cause the issue that word runs slowly when you edit in Word. To correct this problem, remove and reinstall the fonts.

    In addition, if you use printer on this PC, try to delete and reinstall your printer driver.

    If all of above has no avail, I suggest you uninstall your office 2010 and re-install it.

    • Marked as answer by Jennifer Zhan Monday, August 23, 2010 2:26 AM
    Tuesday, August 17, 2010 3:38 AM
  • Same problem here. When editing heaters of images and graphs, changing styles or changing font size word slows down markedly making all these easy operations very frustrating loosing a lot of time.  Also, sometimes word just crash while saving the document. If I save the document in word 97/2003 there s no more slow down but of course I cannot edit graphs and images.

    Tryed all methods suggested by Dr.Biscotto and by Jennifer but I haven't seen any improvement. 

    So, if there s no fixes to adress this issue I had to reinstall office 2007 that used to work perfectly (even in the same document).

     

    Hope someone can help me.

    Wednesday, November 03, 2010 5:46 PM
  • Just to say I've been suffering from the same problems and the suggested solutions don't work at all.

    It becomes terribly slow as I add more and more figures and equations; yes, very frustrating and wasting lots of my valuable time -- just inserting a character (not even word) and scrolling took literally minutes with my 4-GB PC. Strange thing is that all other applications work as usual while the word is not responding.

    Looking forward to a true solution from MS.

    Tuesday, January 25, 2011 6:13 PM
  • Hello, I'd like to say that I'm having the same problem with Word 2010. It's fine with very simple documents but anything with a few text boxes and images and then every key stroke starts to take about 3 seconds. I have a fairly new machine with 6 gigs of ram and Windows 7. Everything else runs fine.

    Does anyone have any other ideas that might fix the issue?

     

    Thanks,

    Tuesday, February 01, 2011 9:22 PM
  • I am also experiencing slow editing with word 2010 on windows 7 x64. When ctrl-clicking on a table of contents link, word takes about 30sec to respond. Text editing is also very slow. I didn't notice this when I installed office, but am experiencing this behevior now. There seems to be a link between the slow typing and some shapes I copied into this document from power point. The slow table of contents response dosn't seem to depend on shapes however.

     

    2.0Ghz dual core 4gb ram


    errold32
    Monday, February 07, 2011 12:05 AM
  • Hi all, I also experience the same behaviour. I bought a new pc, 8gigs of ram, solid state disk, windows 7 64 bits and office 2010 (installed 64 bits). I use word and excel on a daily basis and mostly make charts in excel and import them into word. In office 2003 I never had a problem with that. Now, after spending some time to adjust to 2010 in the different modules (excel and word) I started doing what I always do and import excel graphs into word. This takes at least 7-10 seconds to load into word (ctrl-c in excel and paste special, picture (enhanced meta-file) in word), but more annoyingly is it that (re)placing the picture in the word document is very slow. I can not see what happens because the image will not move as I move the cursor, but when I let loose of the mouse button the image jumps to that cursor location and that is not accurate at all and takes me ages to fine tune the location of that picture. The other thing is that when I browse through the whole of the word document, every time I come to, or pass, these pages with these imported graphs even the browsing slows down. It looks like the screenframe is being build up, like the graphics card has to render a lot of data (AMD Radeon 6870). If this is how Office 2010 operates on such easy tasks I just spend a lot of money for nothing and can return to office 2003, so please help !!
    Wednesday, February 09, 2011 5:14 PM
  • I am having the same issue.  I bought a new ASUS laptop (Intel Cor i3 2.4 GHz, 4.0 GB RAM) and it runs very well, except when I run Word 2010.  Word runs fine, but when I try to navigate away from word to another program, my laptop is extremely slow.  When I shut down Word, my laptop runs fine.  I tried the solutions above (short of reinstalling) and nothing worked. Please does anyone have other solutions?

     

    Seems to be a common problem.  Hopefully Microsoft can solve this.

     

    Cheers!

    Wednesday, February 16, 2011 6:38 PM
  • HI,

    I have the problem of a very slow Word 2010. Even a simple document  with a few lines of text is editet very slow. The "time-glass" is appearing every 5 seconds. I have not tried the above mentioned solutions yet. I have tried to check off spell checking and a few other things but Word is still very slow.

    Like other people here I hope it is a problem that Microsoft will fix-

     

    BR

    Lars

     

    Saturday, March 05, 2011 6:44 AM
  • I also notice this.  With an empty file, editing is pretty fast.  But once I have a couple of pages of equations, editing becomes very slow.  I've resorted to splitting up my documents into smaller files for editing and then combining them for printing.  Not very convenient!  Love the equation editor, though!!!
    Tuesday, March 15, 2011 7:02 PM
  • I am having the exact same problem, MS Word slows down to a crawl when you've got a couple equations on the page. The stuttering is making my brain boil. This, despite modern processing power? This is embarrassing, talk about shoddy, inefficient coding. It's a shame, because the entry method in the new equation editor in 2010 is quick and intuitive, it made me come back to MS Word after years of having switched over to LyX (which I highly recommend to anyone looking for an alternative) (http://www.lyx.org/), but now I have to return to LyX.

     

    Sorry Microsoft, I tried, but its unbearable.

    Saturday, March 26, 2011 8:25 PM
  • I had the same problem, but after I removed the add-ins "cite while you write", word 2010 is very fast. I think the problem is Endnote, not Word2010

     

     

    Sunday, May 15, 2011 2:41 AM
  • Paola_S,

    I'm not using Endnote, but have had this problem since upgrading.

     

    Regards,

    Joseph

    Tuesday, May 17, 2011 9:19 AM
  • Hello I think I may know the reason for the slow down,

    I have the same problem with word 2010. Maybe in other applications of office 2010 there will be the same problem.

    I think the problem is deep into the MS office source code. In Office 2007 there was a limitation to group pictures with shapes. This was caused because different drawing engines were used for pictures and shapes. Because of this we at the office saved our documentation files in 97/2003 office format. Now when Office 2010 appeared I decided to check if this issue is solved and I discovered that it is possible to group pictures and shapes in 2010 *.docx and to use some new fancy features applied on them. The problem shows up when you have lots of shapes represented into your document - somehow maybe the rendering using the new drawing engine can't handle the shapes.

     

    I believe this should be solved in some future updates since such an issue is ridiculous. I don't believe that any add-ins bother the shapes - in a safe mode it is the same blaaah. Anyway if somebody has an idea how to shortcut the problem and still use the new 2010 docx format please let us know.

    Thursday, May 26, 2011 2:15 PM
  • I too am having the same issue with Microsoft Word 2010. Very slow with typing and editing. I have a new Dell laptop XPS with top rated graphics card and updated drivers and fast processor since I do graphics. My work around for the typing is to type everything in notepad then copy paste it into Word. I cannot believe this atrocity that Microsoft has created. It is unacceptable and I would love to see a new standard word processor emerge.
    Sunday, May 29, 2011 6:29 PM
  • I have the same problem. Running on a HP Elitebook 2530p - 8 GB RAM and Windows 7 64bit, there is a 3-4 second lag on every action and typing is slow! Come on this issue is old and there must be a solution coming from Microsoft soon??
    Monday, May 30, 2011 10:31 AM
  • I noticed a marked improvement when I set the default printer to "Microsoft XPS Document Writer"

    This seems to have worked for me.    I guess the render engine in word is constantly asking questions of the default printer.

    This gave me the clue http://cybertext.wordpress.com/2011/04/21/word-very-slow-to-load-and-respond-solved/

    The question now becomes: Why does every key stroke require a query to the default printer?  I am using a word processor from 2010 not a type writer from 1949 where I expect a key press to print. Anyway I hope this works for others.

     

    • Proposed as answer by Jimbo Bats Friday, January 04, 2013 12:22 PM
    Thursday, June 09, 2011 4:53 AM
  • Word get slower the more objects you put in (visio elements, excel data, images, etc..)

    I usually make the drawings in some graphical program, export them optimized in file size and import them in word as image. This helps the performance in Word.

    Saturday, June 18, 2011 2:19 PM
  • I have had issues as well ... I got a new Dell XPS laptop with 8 gigs of RAM, fast processor, etc...  When I opened Word 2007 in Windows 7, everything would slow down to a snail's pace.  It was basically unusable.  My solution has been to install the Virtual XP environment and to run Word 2007 and Endnote in the Virtual XP mode.  It works fine, and my PC is lightning fast again.  It is really unbelievable that Word is causing so many problems for some many people though.  I would have used Open Office for word processing, but my version of Endnote is not compatible with it.

     

    Tuesday, June 21, 2011 5:50 PM
  • I found that if you change your view from Print Layout to Draft, you get past the slowness problem. It seems to have more to do with how the print layout view functions. 
    Tuesday, June 28, 2011 12:09 PM
  • Hi,

     

    I encountered similar problems as described in this thread. Word reacts extremely slow on my desktopPC with a fast CPU (i7-2600k);

    it is as typing through a 300bps modem in the eighties. The problem particulary shows when there is a drawing on the page which consists

    of multiple objects. I have tried an XPS-writer because I noticed in the past that Office Programs slow down if they can't locate the printer.

    I have followed the advice to disable all add-ins; doesn't make any difference. The I saved the document in Word97-2003 format and that

    version operates as it should be; scrolling to the page with the drawing is now quick and without any slow-down. The characters appear

    instantaneously as it should be. But that implies that you can't make use of the 2010 features anymore.

    I am a bit amazed that the status for this issue is marked "answered" in August 2010 while there are apparantly many people actually

    waiting for a real fix for this issue.  Can anyone from the MicroSoft Team provide an update on this issue?

    • Proposed as answer by rednamala Wednesday, April 04, 2012 3:31 PM
    Monday, July 04, 2011 8:55 PM
  • I have the same problem. Inserting any character in pages with big equations takes seconds. This makes the equation feature only usefull for small equations. If you have many big equations DON'T use Microsoft Office because it will be anoyingly slow. I guess I'll use some other better text editor that cares about its users and don't have so many bugs.
    Monday, July 04, 2011 9:58 PM
  • Hi Jennifer

    I have been reading this thread and agree with the comment on you marking this as answered. it is far from answered.  I am using state of the art new machines and creating big, graphic intensive documents 20 -100Mb.  Lots of text boxes and photos and clip art.  Those who are complaining of 2-3 seconds per key stroke are the lucky ones...! Scroll zoom is taking 30secs - it used to be real-time!!!

    Please ask MS to fix this and fast!  Our businesses depend on it.  It is costing me money; in that documents in 2010 are taking me 2-3 times the time they used to.

    While you are at it, ask them the fix the group select tool that has vanished in the latest version (the ability to draw a box around the 200 small images on a page and group them or move them together).  Have you any idea how long it takes to individually select 200 small dots?

    Alternately, MS could just start a roll-out of 'money back' for all those who are dissatisfied with the latest offering...?  Tweaking is not going to make a difference, we are talking about an order of magnitude slower than it used to be!  I invested in new machines, as I thought it was a hardware problem... wrong again!

    Neil

    Business Consultant who spends a lot of time at the PC

    Sunday, July 10, 2011 9:54 AM
  • I don't know if the problem we're having here is the same as above. It sounds similar but we're running windows XP and it happens with documents that only have a few characters on it.

    Our problem is this... It started with one user complaining to me. He said he could type just fine in Word, but as soon as he used the mouse to click in another area of the document it would hang for 10 seconds or so.

    I looked at his computer, he did not have a great deal of applications open, He had three Word documents open. When I click in another area, the cursor would hang and then pop over after 5-10 seconds. I brought up task manager and found that Word would immediately start taking up about 40% processor when I did that. it would settle down and I could type just fine at very fast speed but as soon as I clicked again to go to another area of the document, CPU would spike and then it would hang again.

    I rebooted the system, in case that was it. Then I brought up Word by itself and tested it and the same problem exhibited itself.  I searched online for a long time and couldn't find any answers so I simply rebuilt him a new computer from our stock and chalked it up as a fluke. Well, now another user is complaining of the same problem. I have 100 users here and I don't want this to turn into an epidemic!

    Thursday, August 18, 2011 12:37 PM
  • this is, at least in my case, 100% a docx problem.  I spent a lot of time putting text boxes in a document for users to fill out.  After only 7 boxes text entry started to slow noticably.  I soldiered on and ended up with about 80 boxes and text entry was horrible.  I saved the file into the .doc (word 97-03 format) and BAM! Text entry was as fast as my typing of this message.  If I get some time I will try to isolate what the problem is.  This document has a full page jpg background and different formatting on many of the boxes.  Initial toying has not located "the" culprit but what is certain that it want from dog slow to real time just by going to the old file format.  If someone at ms would like to repeat the effect they can e me and I will happily send the doc in.
    -Further Update-

    Saving the "fast" .doc file to docx format slows text entry to a grindingly slow pace.  Checking the "Maintain compatibility" box keeps text entry speed just fine.  I guess the new version of Word is advanced like a 486 is advanced compared to the i7.  This problem is definitely NOT fixed

    • Edited by billb1313 Friday, September 02, 2011 5:34 PM
    Friday, September 02, 2011 4:21 PM
  • Hi,

    First, try to start Word in safe mode [hold ctrl key while startup] to see if this issue is caused by some add-ins. If it works well in safe mode, disable all add-ins. How to do this, see here:

    http://office.microsoft.com/en-us/outlook-help/enable-or-disable-add-ins-in-office-programs-HA010034127.aspx

    Also you may try some other methods:

    Reset the Word data key in the Windows Registry

    • Click Start and then click Run. In the Open box, type Regedit and then click OK.
    • Open the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word
    • Under the Word key, click the Data subkey.
    • On the Edit menu, click Delete. Click Yes if the following message appears: Are you sure you want to delete this key?
    • On the Registry menu, click Exit. Re-start Word.

    Repair or replace damaged or missing fonts

    Damaged or missing fonts can cause the issue that word runs slowly when you edit in Word. To correct this problem, remove and reinstall the fonts.

    In addition, if you use printer on this PC, try to delete and reinstall your printer driver.

    If all of above has no avail, I suggest you uninstall your office 2010 and re-install it.

    The registry entry worked for me!
    • Proposed as answer by Dieder Cuijpers Wednesday, October 05, 2011 10:33 AM
    • Unproposed as answer by Dieder Cuijpers Wednesday, October 05, 2011 10:34 AM
    Monday, September 12, 2011 5:58 AM
  • I have the same problem on Windows 7 64 bit, Office 2010 32 bit, 4 GB RAM, 2,5 GHz Dual Core CPU. 

    I think the problem in my case is related to a new form of handling Windows Metafile (WMF) or EMF inside Word. I'm used to insert vector images drawn in Visio or PPT as EMF using the clipboard (insert as enhanced meta file) since it makes it easier to scale the images and used to save storage as well in Office 2003. Since Office 2010 this doesn't work any more (I'm not quite sure about 2007). If I insert the clipboard data as EMF instead of MS Office drawing, the file size grows dramatically. If you open the docx as ZIP you see that the six EMF files in my document are together 110 MB uncompressed and still 7 MB compressed, whereas the PPT with the original drawings is only 81 kB. 

    The slowing down in my case only occurs when such a drawing is visible on the screen. Then as reported by others, every keystroke takes about 2 seconds. If I scroll down a little bit, so that the image is not visible any more, typing is just fine, as if there were no images in the document.

    I think this analysis should help MS to figure out how to solve it. Unfortunately it doesn't help me much in my case, since inserting the file as MS Office drawing object is having other issues and therefore no workaround for me.


    • Edited by René Peinl Tuesday, September 20, 2011 4:54 PM
    Tuesday, September 20, 2011 4:53 PM
  • you would think a 3.8ghz amd 6 core, 12gb of ram, with dual 560ti's would be able to handle word -_- 

    microsoft... i am dissapoint.

    i have a gaming pc, that can handle advanced dx11 real time processes, i can run every program i own 
    at the same time (including every adobe program, itunes, chrome, cad, reason, sonar, etc)... while gaming and streaming torrents...  but i can barely edit this poster with a few images on it, with nothing else open......     WOW.

    • Edited by mpRag3 Monday, October 17, 2011 7:28 PM
    • Edited by David Wolters Tuesday, October 18, 2011 3:45 PM Language
    Monday, October 17, 2011 7:16 PM
  • I had the same issue and found that it was related to one specfic image in the word doc. When I cut it and pasted it back in as a normal default image it was all good again. Also saving it to doc worked but then I don't have my biblio.
    Sunday, October 23, 2011 6:14 AM
  • I noticed a marked improvement when I set the default printer to "Microsoft XPS Document Writer"

    This seems to have worked for me.    I guess the render engine in word is constantly asking questions of the default printer.

    This gave me the clue http://cybertext.wordpress.com/2011/04/21/word-very-slow-to-load-and-respond-solved/

    The question now becomes: Why does every key stroke require a query to the default printer?  I am using a word processor from 2010 not a type writer from 1949 where I expect a key press to print. Anyway I hope this works for others.

     


    This has worked for me also as a temporary workaround, and I whole-heartedly agree with this user's sentiment.  In my specific case, I am working with an unresponsive table of contents page in a document that has many small tables in it (created in Word itself).  It's pathetic that this would cause such a huge delay in a table of contents page, which is essentially just hyperlinks within your document.....
    Tuesday, November 01, 2011 2:31 PM
  • Today I encountered the same problem. I had about 3k words worth of text. For layout purposes I needed to put it into a text box. As soon as I did that word became very slow with scrolling, typing etc to the point of being unworkable. I tried the workarounds proposed here. No success.

    This is fairly fresh (less than 2 weeks) default installation of MS word. I'm on windows XP, well above minimum hardware requirements.
    • Edited by ArtW Wednesday, November 02, 2011 8:30 PM
    Wednesday, November 02, 2011 8:25 PM
  • I am running Office 2010 on Windows 7 32 bit on dual core Intel, 1.83GHz, 3GB RAM. The specs should be more than sufficient to handle Office 2010. But I am having the same problem of everything slowing to a crawl when editing text boxes. I have tried disabling all add-ins (I use Mathtype, Endnote, Acrobat) and that did not change anything. I also tried the suggested solution of setting Microsoft XPS Document Writer as default printer. Still nothing. Based on the number of comments in this thread, this is not an isolated problem or a problem with our individual hardware or any particular add-in and more of a Word/Office internal bug. I hope Microsoft will look into this and release a fix in future updates.
    Thursday, November 03, 2011 2:55 PM
  • I found that the TOC is really slow if it is trying to do page numbers and hyperlinks. It will do page numbers just fine and it will do hyperlinks alone (if you go to insert a new TOC, not one of the 3 presets it will give you options), but if you try to have it do hyperlinks and page numbers it will go very slow. The other odd thing is that if you select the TOC first and then do the hyperlink, it will go very quickly. If you try to just do the hyperlink, it will still go slow.
    Wednesday, November 23, 2011 5:34 PM
  • I started getting this problem as well - its pretty nasty.  I always paste pictures as Enhanced Metafile. 

    I did fix the slow down by pasting the picture a second time as follows:

    • Copy the picture from source (in my case Powerpoint) and go to place in word document where you want to paste it
    • Paste Special -> Enhanced Metafile
    • Word drops the picture in at original scale and then after an age, automatically resizes it to fit the page
    • Now any typing while the picture is displayed is really slow (read unusable) so we have the problem
    • Select the pasted picture (in the word document)
    • Cut it
    • Paste it back in (Paste Special -> Enhanced Metafile)
    • Bingo - all fixed!

    Makes no sense but it works.

    I'm running this on a fully up to date Win 7 64bit laptop w/ i7-2620, 8GB RAM and SSD so its pretty well the text book platform.

    Curiously, earlier in the day I had Microsoft Font Cache going crazy (consuming 25% CPU) - this is used by Windows Presentation Foundation so I killed it and things seemed to settle down a bit then the problem came back - just suspicious that there is some deep code there that is misbehaving badly which is somehow disengaged by doing the repaste.

    Hopefully the problem will mysteriously manage in some future Windows update :)

    Tuesday, December 13, 2011 4:41 AM
  • I found that the TOC is really slow if it is trying to do page numbers and hyperlinks. It will do page numbers just fine and it will do hyperlinks alone (if you go to insert a new TOC, not one of the 3 presets it will give you options), but if you try to have it do hyperlinks and page numbers it will go very slow. The other odd thing is that if you select the TOC first and then do the hyperlink, it will go very quickly. If you try to just do the hyperlink, it will still go slow.


    I have a powerful new Win 7 Ultimate fully loaded with quad and memory - same problem.  Specifically, when I try to page down or scroll through pages with figures, and TOC MS Word hesitates for many seconds and has slow performance on the keyboard.  This is a new install of Win 7 and MS Office Pro 2010 - so no I won't uninstall/reinstall or change registry settings, that's crazy.

    The TOC suggestion from aohelaman solved part of my problem, by choosing to edit options and turning off Hyperlinks for the TOC performance improved tremendously, basically from dead stuck to real-time scrolling and typing.

    I have changed from a networked printer to a local printer (XPS, PDF) and see better performance as well but this isn't an option for me just a test.

     

    Monday, December 19, 2011 9:53 PM
  • This is definitely the root of the problem, it has something to do with images. For me it was images in the header, if i remove them, the document works well, if i go to draft mode where they are already removed the document works well. The problem I have is that this document is a template, so I don't have the option of removing, or even cutting and trying to re-position them. Is there any way to transform the images in word in one shot?
    Tuesday, December 20, 2011 1:02 AM
  • This is still a problem in Word 2010.

    I do have better performance if I paste the pciture as bitmap, and also when the picture is small.

    Friday, January 27, 2012 10:05 AM
  • 206 total, hidden & non-hidden
    Tuesday, February 07, 2012 10:22 PM
  • Hi

    Just upgraded and having very similar problems. The moment I paste a ppt image into a word document (as an Enhancedmeta file) word simply slows down to alomst unusable. Like others have mentioned it does appear it's to do with rendering the image, because word is OK when the image is not on the screen.

    I've tried all the potential fixes as above but it does not seem resolve the problem.

    Has anyone found / heard of a more robust solution / workaround or fix from Microsoft?

    Thanks in advance

    Steve

    Wednesday, April 18, 2012 11:16 AM
  • Same problem started on my Word 2003 /Win7 since last week: even with empty documents and in safe mode typing is extremely slow.

    Friday, May 04, 2012 3:37 PM
  • I've been having the same problem, in both MS Word and MS ppt. The equation editor has improved a lot in terms of the keystroke system - it adopted a lot from LyX and made several improvements even over that, so theoretically my equation entry is quite fast, I'm finding faster than handwriting, *until*, as mentioned, you get a few equations down. I'm using a PC with 6GB RAM clocked at 1600MHz, OCZ Vertex 3 SSD, and i7-970 CPU, and it still slows to a crawl for me, which I have to say is not reasonable when you compare to products like Matlab which do fairly enormous calculations on the same computer, without GPU use, within seconds or minutes. Just entering and rendering the equations - there's gotta be a more efficient way to do that than what MS is doing here.

    Any chance of this getting patched? I teach courses that involve a lot of math equations and I type handout notes to each section, so it would be nice to have it working on the MS Office side, otherwise I've been forced to go back to LyX, which is great but I don't love it for formatting and for exporting to other programs like InDesign

    Wednesday, June 27, 2012 8:07 PM
  • Same problem, if I copy all the graphic objects in the document, and paste them as a photo, the problem is fixed, 

    but that's unacceptable with my documents, which need to be ready for edit at any time. 

    Also it lowers the quality of the objects, they become a bit blurry.

    has anyone tried to work with power point, doing the same document?

    also, be ashamed of yourself microsoft, this thread opened up 2 years ago and still no answer.

    • Edited by teachong Wednesday, July 04, 2012 7:36 AM
    Wednesday, July 04, 2012 7:35 AM
  • Same problem with me Word slowing down, I have just posted on the main forum asking for a solution.

    All I asked it to do was change the orientation to landscape from portrait.!!

    If it doesn't get sorted I'm going to buy an iMac as I'm sick of Microsoft problems...

    2 years for Microsoft to respond to a forum on their servers... Who is the customer???

    I don't suppose they care once they have the money...
    Sunday, August 19, 2012 7:57 PM
  • I finally found a fix to this issue!

    At least it worked in my case...

    Check your default printer, is it a network printer? if so, then change your default printer to anything other than a network printer, reboot and try again. This fixed the issue for me!

    Friday, October 05, 2012 8:00 PM
  • Same here, still happening.

    I have a picture of our floor plans and reception usually adds text boxes on top to indicate seating charts and phone numbers.

    I went to add in some network printer info and any delete, backspace or key input has a good 5-7 second delay.

    She said it took her hours to do it.

    Changed my default printer, nothing.

    Safe mode, same thing.

    Saved to .doc, and works fine now.

    Thursday, January 03, 2013 1:28 PM
  • Yeah setting the printer to a non networked/dummy printer solved the speed and brought Word back to useable.
    • Proposed as answer by RotondoJ Tuesday, January 15, 2013 8:43 PM
    • Unproposed as answer by RotondoJ Tuesday, January 15, 2013 8:43 PM
    Friday, January 04, 2013 12:23 PM
  • I ran across this post while having slow editing responses with Word.  For my case, disabling the COM Add-ins did the trick.  Go to File-->Options-->Add-ins-->Manage: COM Add-ins and disable all of the add-ins.  I think I had a similar issue with a Bluetooth add-in awhile back.  Hope that helps someone.  
    Tuesday, January 15, 2013 8:48 PM
  • Hi All

    The solution is incredible simple:

    Update the Table of Contents and the lag should stop

    Method:

    Click on the table, and click on Update Table, select "update entire table", profit.

    Cheers,

    and (if it works for you too), you are welcome

    Wednesday, January 16, 2013 1:27 PM
  • Hi All

    The solution is incredible simple:

    Update the Table of Contents and the lag should stop

    Method:

    Click on the table, and click on Update Table, select "update entire table", profit.

    Cheers,

    and (if it works for you too), you are welcome

    Wednesday, January 16, 2013 1:28 PM
  • I have the same problem with lag when editing  a word document with table. It dose not have a  table  of contents. It would probably take a few hours to set one up. So  the above solution would not work for me.
    Saturday, January 19, 2013 12:36 AM
  • Sorry to hear that. I am sure that, with such a complex program there are many reasons for the lag. Some of the discussion here centered around the TOC, so I responded to that.

    Have you tried the other solutions offered up here?

    I am sure you have looked at RAM/CPU usage etc....

    Saturday, January 19, 2013 6:28 AM
  • With all due respect, Word is not a complex program by todays standards. Given the number of years Office has been around and the number of users globally it should have been the best tuned software ever. A tiny improvement and you change the environmental footprint and our collective stress level.

    None of the fixes above worked for me, nor has the IT support at my office been able to resolve it (very big company). This has a major impact on my daily work. Since I must get my job done I started doing drawings in LibreOffice and including them at the end of the writing process. Ntyo optimal though, an certainly not acceptable.

      
    Wednesday, March 27, 2013 8:42 AM
  • Some 20 years ago I used FrameMaker that was able to handle hundreds of pages with mixed graphics and text flawlessly and smoothly with the comparably slow computers at the time. Surely it must be bug.

    Wednesday, March 27, 2013 8:45 AM
  • I recently posted a fix that, in the long run didn't work, but yesterday I fixed a different problem and today my TOCs are causing no problems at all!

    All I did was disable my COM add-ons. The main culprit seems to be the Adobe PDFMaker Office COM Addin.

    Hope this helps.

    Word 2010 directions: 

    • File --> options
    • add-ins
    • Manage Com Add-ins --> Go
    • uncheck all addins --> ok

    If this helps then slowly re-add them to find out which one was the problem.

    Thursday, April 04, 2013 12:23 PM
  • I recently posted a fix that, in the long run didn't work, but yesterday I fixed a different problem and today my TOCs are causing no problems at all!

    All I did was disable my COM add-ons. The main culprit seems to be the Adobe PDFMaker Office COM Addin.

    Hope this helps.

    Word 2010 directions: 

    • File --> options
    • add-ins
    • Manage Com Add-ins --> Go
    • uncheck all addins --> ok

    If this helps then slowly re-add them to find out which one was the problem.

    Thursday, April 04, 2013 12:25 PM
  • January 2014, I am having this exact same problem with word 2010 and windows 7 and there is no solution in this forum or anywhere else online. i5-2410M processor and 8 GB ram. No Word or Excel add-in's running. Runs complex stats and other graphic software no problem. But when editting a 5000 word document with 10 embedded charts it operates excruciatingly slow when typing of text or editting charts. If I save the file as a *.doc all the charts are converted to images and the file becomes responsive. If I view it in draft mode and the charts are hidden, it runs fine. So the problem is that word 2010 cannot handle embedded charts.

    There is a serious flaw in this software and 3.5 years after this was originally posted the problem persists. Looks like a "downgrade" to word 2007 is in the works for me too.

    Wednesday, January 15, 2014 8:44 PM
  • Jennifer this is not the answer, the OP's problem was not solved by your suggestion nor the many others who posted here with the same problem.
    Wednesday, January 15, 2014 8:45 PM
  • I have this problem too. Once there are many vector graphics, the document becomes slow!
    Wednesday, April 09, 2014 12:38 PM
  • @nerdasdasd et. al. :

    I followed the advice of robert_orton (Thursday, June 09, 2011 4:53 AM) and read the linked blog post. Have you tried changing your default printer to a non-networked printer yet?

    This seems to have fixed my terribly slow response time in both Excel and Word. Thank heavens. I was even able to change back to my network printer and the problem seems to have stayed fixed. (Maybe it just needed to be pointed once to a local print view source??)

    I agree with the frustration that these applications are so closely tied to default printer. Hopefully there is a solution in the future. In the meantime, I am able to work again.
    • Edited by aschredder Monday, April 28, 2014 3:33 AM
    Monday, April 28, 2014 3:29 AM
  • As can be surmised from the number of responses to this thread, in most (all?) cases this doesn't have anything to do with safe mode/addins. Its due to a change in the way office works.

    In earlier versions word always operated in the equivalent of draft mode. With the change to 2010 office works in print preview mode and queries the printer constantly. I'm  not sure what its doing when it does this but it does this constantly. I suppose its attempting to present the page closer to what it will appear as on paper.

    In consequence changing the default printer to, say, the XPS driver will have an effect on the speed as its a different driver and your printer driver may be much slower than the xps driver.

    The solution is to switch to draft mode (someone below mentioned this mid thread).

    This has the effect of not querying the printer driver after every keystroke and the performance returns to what it was before. 

    This only occurs on complex documents because it takes much longer to rerender a complex document than a simple one... hence the slowdown on equations and tabled. Text is fast, tables are slow.

    You can add a 'draft mode' button to the toolbar on the top left, beside the undo/redo buttons by clicking on the little dropdown arrow beside those. Open more commands and then select all commands. Search down for the draft button and click on add. The button should appear. You will need to click on the button each time you open word, but it works.

    You can get a document to always open in draft mode by doing the following:
    1. Click the File Tab, and then click Options.
    2. Click Advanced.
    3. Under General, click to select the Allow opening a document in Draft view check box.
    4. Click OK.
    5. On the View tab, click Draft in the Document Views group.

    once saved, it will always re-open in draft mode and the response will be as with word 2003

    • Proposed as answer by imurphy Tuesday, September 16, 2014 9:35 AM
    Tuesday, September 16, 2014 9:35 AM