none
"1158: ": erro de instalação do age of empires III ápós último update do wxpsp2

    Question

  • Ao tentar instalar o Age of Empires III, após o último pacote de update do WXP SP2, tenho recebido, após clicar em instalar na janela aberta pelo autorun, uma caixa de diálogo somente com a inscrição "1158:" e um botão de comando com "OK". Nada mais. Nem os moderadores do fórum da Ensemble Studios sabem o que é e disseram que deveríamos buscar ajudo aqui nos fórums da MS.

    A única coisa quye sei é que foi depois desse update porque em outro pc que tenho, onde não fiz esse update (opção avisar antes de baixar e atualizar), ele instala normalmente. Esse AOE foi comprado esse ano nas Lojas Americanas e já tinha sido instalado nesse mesmo PC, entao no HD antigo e outra instalação do WXP. Por isso, acho que não deve ser de hardware ou algo do tipo.

    Muito obrigado.

    Ivan

    isnpms@gmail.com

    Monday, November 20, 2006 11:33 PM

Answers

  • Acir, eu já tinha tentando instalar no modo de segurança, coo administrador e tentatado finalizar processos de vários softwares ativos e impedir até que alugns inicializassem, mas nada funcionou. Vou ver de quando é meu último ponto de restauração e vou tentar. Instalei o jogo em outro PC na rede aqui em casa e passei ele todo pela rede pro meu e ele rodou. O problema mesma é a instalação que, apesar de eu tê-lo trazido pro meu, o windows não reconhece como instalado, apesar de funcionar sem problemas.

     

    Valeu as dicas e vou tentar o ponto derestauração pra ver se descubro o que faz ele para na instalação.

    Muito Obrigado.

     

    Ivan SInigaglia.

    Wednesday, November 22, 2006 3:14 PM

All replies

  • Possivelmente a mensagem que está aparecendo está indicando alguma incompatibilidade de programas instalados no computador, por exemplo o jogo esta tentando acessar algum recurso que esta em uso por outro programa, experimente fechar todos seus aplicativos e tentar executar o programa para ver se consegue ter exito, caso não consiga experimente entrar em modo de segurança e tentar executar somente para ver se roda,

    Uma saida seria vc tentar a restauração do sistema, se for algum problema do windows possivelmente ele irá corrigir.

    Não esqueça de ter um ponto de restauração antes de fazer as alterações .

    Abraço

    Tuesday, November 21, 2006 10:14 PM
  • Acir, eu já tinha tentando instalar no modo de segurança, coo administrador e tentatado finalizar processos de vários softwares ativos e impedir até que alugns inicializassem, mas nada funcionou. Vou ver de quando é meu último ponto de restauração e vou tentar. Instalei o jogo em outro PC na rede aqui em casa e passei ele todo pela rede pro meu e ele rodou. O problema mesma é a instalação que, apesar de eu tê-lo trazido pro meu, o windows não reconhece como instalado, apesar de funcionar sem problemas.

     

    Valeu as dicas e vou tentar o ponto derestauração pra ver se descubro o que faz ele para na instalação.

    Muito Obrigado.

     

    Ivan SInigaglia.

    Wednesday, November 22, 2006 3:14 PM
  • Prezado Ivan,

    Já resolvi este tipo de problema executanto o sfc /scannow.

    abraço

    Friday, December 01, 2006 12:51 PM
  • Sinceramente, acredito que o problema é o leitor de CD.

    Se possível,  coloque outra no seu computador e inicie a instalação do jogo.

    Esse problema normalmente é problema na leitura.

    Caso não tenha como verificar com outro leitor de CD, efetue o seguinte.

    Copie os 3 CD´s para uma pasta no disco rígido.

    Se der o problema, confirma-se o problema do leitor de CD.

    Friday, December 01, 2006 10:04 PM
  • Achou pouco provável que seja a leitora porque são três computadores que tinham a versão instalada e após os upgrades do windows os três não puderam instalar mais. Além disso, mesmo passando os arquivos dos CDs pro meu HD pela rede a partir de um computador que o instalou e rodou normal, e executando o setup pelo meu, ele deu o mesmo erro.

    O que consegui melhorar foi abrir o arquivo 0x0409.ini do Age of Empires III - War Chiefs (AOEIII-WC) - versão em inglês - e passar esse conteúdo para o arquivo 0x0416.ini do AGEIII, e editando a primeira linha trocando o cabeçalho pra 0x0416. Ele leu e iniciou a instalação, mas parou logo após a mensagem de que estava iniciando o Windows Installer e deu uma mensagem de erro: 1628=Failed to complete installation. Progredi porque ando para um novo erro mas ainda não instala. O AOEIII-WC não da esse erro e vai bem até perceber que o AOEIII não está instalado. Segue  código do arquivo 0x0416.ini.

     


    [0x0416]
    TITLE=Choose Setup Language
    DESCRIPTION=Select the language for this installation from the choices below.
    REBOOTMESSAGE=The installer must restart your system to complete configuring the Windows Installer service.  Click Yes to restart now or No if you plan to restart later.
    ONUPGRADE=This setup will perform an upgrade of '%s'. Do you want to continue?
    LATERVERSIONINSTALLED=A later version of '%s' is already installed on the this machine. The setup cannot continue.
    OK=OK
    Cancel=Cancel
    Password=Password:
    1100=Setup Initialization Error
    1101=%s
    1102=%s Setup is preparing the %s, which will guide you through the program setup process.  Please wait.
    1103=Checking Operating System Version
    1104=Checking Windows(R) Installer Version
    1105=Configuring Windows Installer
    1106=Configuring %s
    1107=Setup has completed configuring the Windows Installer on your system. The system needs to be restarted in order to continue with the installation. Please click Restart to reboot the system.
    1108=%s
    1150=Setup has detected an incompatible version of Windows. Please click OK and verify that the target system is running either Windows 95 (or later version), or Windows NT 4.0 Service Pack 6 (or later version), before relaunching the installation
    1151=Error writing to the temporary location
    1152=Error extracting %s to the temporary location
    1153=Error reading setup initialization file
    1154=Installer not found in %s
    1155=File %s not found
    1156=Internal error in Windows Installer
    1158=Error populating strings. Verify that all strings in Setup.ini are valid.
    1200=Restart
    1603=Error installing Windows Installer engine.  A file which needs to be replaced may be held in use.  Close all applications and try again.
    1201=Setup needs %lu KB free disk space in %s. Please free up some space and try again
    1202=You do not have sufficient privileges to complete this installation for all users of the machine. Log on as administrator and then retry this installation
    1203=Command line parameters:
    1204=/L language ID
    1205=/S Hide intialization dialog.  For silent mode use: /S /v/qn.
    1206=/V parameters to MsiExec.exe
    1207=Windows(R) Installer %s found. This is an older version of the Windows(R) Installer. Click OK to continue.
    1208=ANSI code page for %s is not installed on the system and therefore setup cannot run in the selected language. Run the setup and select another language.
    1604=This setup does not contain the Windows Installer engine (%s) required to run the installation on this operating system.
    1607=Unable to install %s Scripting Runtime.
    1608=Unable to create InstallDriver instance, Return code: %d
    1609=Please specify a location to save the installation package.
    1611=Unable to extract the file %s.
    1612=Extracting files.
    1613=Downloading file %s.
    1614=An error occurred while downloading the file %s.  What would you like to do?
    1615=hr
    1616=min
    1617=sec
    1618=MB
    1619=KB
    1620=/sec
    1621=Failed to verify signature of file %s.
    1622=Estimated time remaining:
    1623=%d KB of %d KB downloaded at
    1624=Preparing to Install...
    1625=Get help for this installation.
    1626=Help
    1627=Unable to save file: %s
    1628=Failed to complete installation.
    1629=Invalid command line.
    1630=/UA<url to InstMsiA.exe>
    1631=/UW<url to InstMsiW.exe>
    1632=/UM<url to msi package>
    1633=/US<url to IsScript.msi>
    1634=Setup Initialization Error, failed to clone the process.
    1635=The file %s already exists.  Would you like to replace it?
    1636=/P password mode
    1637=/A administrative installation
    1638=/J advertise mode
    1639=/X uninstall mode
    1640=/F repair mode
    1641=/B cache installation locally
    1642=Could not verify signature.  You need Internet Explorer 3.02 or later with Authenticode update.
    1643=Setup requires a newer version of WinInet.dll.  You may need to install Internet Explorer 3.02 or later.
    1644=You do not have sufficient privileges to complete this installation. Log on as administrator and then retry this installation
    1645=Error installing Microsoft(R) .NET Framework, Return Code: %d
    1646=%s optionally uses the Microsoft (R) .NET %s Framework.  Would you like to install it now?
    1648=Setup has detected an incompatible version of Windows. Please click OK and verify that the target system is running either Windows 95 (or later version), or Windows NT 4.0 Service Pack 3 (or later version), before relaunching the installation
    1649=%s optionally uses the Visual J# Redistributable Package. Would you like to install it now?
    1650= (This will also install the .NET 1.1 Framework.)
    1651=Setup has detected an incompatible version of Windows. Please click OK and verify that the target system is running Windows 2000 Service Pack 3 (or later version), before relaunching the installation

    1652=%s requires that the following requirements be installed on your computer prior to installing this application. Click OK to begin installing these requirements:
    1653=Installing %s
    1654=Would you like to cancel the setup after %s has finished installing?
    1655=The files for installation requirement %s could not be found. The installation will now stop. This is probably due to a failed, or canceled download.
    1656=The installation of %s appears to have failed. Do you want to continue the installation?
    1657=Succeeded
    1658=Installing
    1659=Pending
    1660=Installed
    1661=Status
    1662=Requirement
    1663=Failed
    1664=Extracting
    1665=Downloading

    [Languages]
    0x0404=Chinese (Traditional)
    0x0804=Chinese (Simplified)

    Friday, December 01, 2006 11:55 PM
  • Valeu mesmo a sugestão, mas não funcionou.

    O pior é que no site da Enssemble eles não sugerem nada e dizem desconhecer esse erro, mesmo com muitas pessoas fazendo parte do fórum com essa dúvida.

     

    Obrigado.

    Saturday, December 02, 2006 12:18 AM
  • 1. Right-Click the Start button and select "Explore"
    2. Navigate to the "All Users" directory, then "Start Menu", then "Programs"
    3. Create a directory called "Microsoft Games"
    4. In that directory, create another directory called "Age of Empires III"
    5. Re-Run the War Chiefs install program.

    Tuesday, January 02, 2007 9:38 PM
  • A mensagem refere se a incompatibilidade dos requisitos minimos do jogo.

    Geralmente é relacionado à placa de vídeo. Veja os requisitos em http://www.agecommunity.com/Requisitos_do_sistema.aspx 

    Clique em Iniciar > Executar > digite 'msconfig' e pressione Ok.
    Na guia Geral, clique em Inicialização Seletiva e desmarque a opção 'Carregar itens de inicialização'. reinicie o computador. Vc poderá conseguir instalar o jogo, mas se não atender aos requisitos, irá travar na inicializaão do jogo.

    Wednesday, January 03, 2007 12:21 PM
  • boa noite. mais de um ano depois apareco aqui com o mesmo problema. nao estou achando a solucao na web. fiz exatamente o que foi postado acima e nao instalou. minha placa e uma x 1950 pro, entao acredito que ela supere bem os requisitos exigidos. alguem ja tem a solucao deste problema? nao estou conseguindo instalar a expansao war chiefs. o age puro foi de boa, ja instalei, reinstalei-o e nada . a expansao nao vai. ja troquei o dvd na loja e tb nao virou. alguem me ajude por favor, estou ficando louco.

    Wednesday, May 21, 2008 2:36 AM
  • desculpem ter aberto um topico com referencia esse erro. fui redundante, desculpem, nao foi a intencao. mas o problema persiste. se alguem puder me ajudar, agradeco.

    Friday, May 23, 2008 12:39 AM

  • Após o sp2 dá esse erro..é só criar uma pasta com o nome "Microsoft Games" dentro do diretorio arquivos de programas e dentro dessa pasta criar outra com esse nome tambem "Age of Empires III"..o caminho tem que ficar assim:
    C:\Arquivos de programas\Microsoft Games\Age of Empires III

    depois é só mandar instalar o jogo...
    Thursday, August 06, 2009 2:05 AM