none
Computer Startup Scripts not executing when Hybrid Boot is active?

    Question

  • Hello,

    we use computer startup scripts running before login with system account rights.
    This works well on XP and Win7.

    Now, using Windows 8, the scripts only run when I do a restart, but not on (hybrid) shutdown and start.
    Only when I force a complete shutdown, the script is executed on startup.

    I cannot find any informations about this issue in the web, so it seems to be not as common as I think.
    Anyone else with this problem around? Any solution or hint?

    Yes, I could disable hybrid boot, but I like it and would prefer another solution. :-)
    There is no security issue with the script. Even when I use a local policy with a local script, it will not be executed as it should.

    Thanks,
    Alexander

    Friday, September 13, 2013 2:13 PM

Answers

  • as far as I understand it, hybrid boot isn't suitable if you're using GPO startup scripts, since hybrid boot performs a suspend/hibernate of session0, and it's the initialisation of session0 which kicks in the startup scripts module of the scripts CSE.

    but maybe you should ask this in the GP forum, where the GP MVP's are to be found?

    I know that I've read in the past, that for some situations you have to disable certain boot or logon enhancements, to get particular GP features (like, to avoid two or more reboots before Folder Redirection applies, MS recommend disabling fast user switching, or something like that) 


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Friday, September 20, 2013 10:30 AM

All replies

  • It seems, the problem is not as common as I thought...
    It would be useful if someone could confirm that startup scripts are working correct with hybrid boot.
    Then I knew my setup is false.

    Thanks.

    Tuesday, September 17, 2013 6:36 AM
  • Hi,

    According to your description, this problem obviously related with Windows 8 fast boot feature. May be you can try to check and enable “Allow wake timers” in Power manager advanced settings for test.

    Control Panel->System and Security->Power Options->Edit Plan Settings->Change advanced power settings.


    Roger Lu
    TechNet Community Support

    Wednesday, September 18, 2013 9:02 AM
  • Hi Roger,

    I've tried out your suggestion, but it did not help.
    After activating the "Allow wake timers" setting, I shut down with fast-boot and startet the system again.
    The script was not executed.
    Then I rebootet the system, and the script runs.
    At another fast-boot-shutdown-start the script was not started again.

    Any other ideas?

    Thanks. Alex.

    Friday, September 20, 2013 7:05 AM
  • as far as I understand it, hybrid boot isn't suitable if you're using GPO startup scripts, since hybrid boot performs a suspend/hibernate of session0, and it's the initialisation of session0 which kicks in the startup scripts module of the scripts CSE.

    but maybe you should ask this in the GP forum, where the GP MVP's are to be found?

    I know that I've read in the past, that for some situations you have to disable certain boot or logon enhancements, to get particular GP features (like, to avoid two or more reboots before Folder Redirection applies, MS recommend disabling fast user switching, or something like that) 


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Friday, September 20, 2013 10:30 AM