none
Sharepoint 2013 - Fast Search - Creating a new Topology - Failed Login to Database

    Question

  • Hi,

    I have a problem accessing the database by running the New-SPEnterpriseSearchTopology command. Knowing that database "Search_Service_Application_DB_ {}" is administered by the user account "DOMAINE\Sp_Search".

    PS C:\Users\SP_Install> $newTopology = New-SPEnterpriseSearchTopology -SearchApp
    lication $ssa
    New-SPEnterpriseSearchTopology : Cannot open database
    "Search_Service_Application_DB_f2efeec46f894b3f8c0afec7aff28eaf" requested by
    the login. The login failed.
    Login failed for user 'DOMAINE\SP_Install'.
    At line:1 char:16
    + $newTopology = New-SPEnterpriseSearchTopology -SearchApplication $ssa
    +                ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidData: (Microsoft.Offic...wSearchTopology:
       NewSearchTopology) [New-SPEnterpriseSearchTopology], SqlException
        + FullyQualifiedErrorId : Microsoft.Office.Server.Search.Cmdlet.NewSearchT
       opology
    
    PS C:\Users\SP_Install>

    Can any one help me .. plz !!

    Thank's on advance.

    Tuesday, January 07, 2014 10:29 AM

Answers

  • Is SP_Install a sysadmin on the SQL instance? Or at least dbcreator and securityadmin?

    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Tuesday, January 07, 2014 8:05 PM