none
Acceso lento al iniciar sesión y verificar la configuración integral del dominio de una empresa con Active Directory e ISA 2006 en un servidor de Windows Server 2003, con 2 dominios coexistiendo en la misma red

    Question

  • Hola gente conocedora, como les va? Hace 8 meses que me contrataron como Administrador de red en una empresa, la cual cuenta con 2 dominios.

    El Dominio 1 es el principal (llamemoslo Gain) y el Dominio 2 es un dominio que no está asociado al primero, y es independiente (llamemoslo VTDOM).

    Ahora, las máquinas del area administrativa se conectan al Gain, mientras que las máquinas del área de reportes y trabajo se conectan al VTDOM. Pero he aqui los detalles.

    El servidor que controla Gain, tiene ISA 2006 instalado (no fue nada del otro mundo, lo uso solamente para el cache de internet y firewall), como decía, Gain dá acceso a internet a toda la empresa, y a su vez controla el dns de toda la empresa. Y a su vez tiene una base de datos SQL que usa un programa de facturación y manejo de nómina. Por allí no hay problemas y todo bien

    El servidor que controla VTDOM tiene una base de datos SQL y terminal services, hasta ahora todo bien, el detalle está en éste dominio.

    Como el servicio de internet lo controla Gain, desde el principio según supe del Administrador anterior, las máquinas de VTDOM no podían entrar a internet y conectarse a la base de datos de sql al mismo tiempo, manualmente en las máquinas cliente (Windows XP), había que quitar el dns de la conexión de red para que pudiesen usar la base de datos sql, eso parece que lo pude resolver poniendo manualmente un puntero que apuntara al servidor del dominio de VTDOM (el servidor de llama vtserv, con ip 10.10.2.20), después de ese cambio todo funcionaba al punto, podían accesar a internet e interactuar con la base de datos.

    Pero el problema que aún no logro arreglar es con el inicio de sesión en VTDOM. Vean, la gente que se conecta al Gain inicia sesión en un tiempo digamos normal, entre 5 a 30 segundos, mientras que en el VTDOM toma a lo sumo 5 minutos hasta 15. Y hasta el sol de hoy no tenga idea de porqué. Me dijeron que probara iniciando sesión en una máquina y quitando el cable de red, si al quitarlo la máquina entraba rápido el problema era el servidor, sino era el cliente. Y según las pruebas parece ser el servidor. Buscando por google encontré que un inicio de sesión lento puede ser causado por un dns mal configurado, pero no le conseguí falla alguna (bueno ya estaba configurado todo, lo que agregué fue el puntero al vtserv).

    Lo más raro del caso es que el servidor Gain, que tiene dns, está lanzando unos errores de replicación raros, y físicamente hay 4 servidores, de los cuales 1 tiene acceso a internet y el resto no, y los principales son gain y vtserv en cuando a importancia. Y de replicación como tal, ningun otro servidor tiene servicio dns instalado.

    Si tienen alguna idea de que pasos puedo seguir para arreglar éste desastre. Lo primero es arreglar el inicio de sesión en el vtdom.


    Que por cierto, me faltaba mencionar, que el vtdom está presentado un error raro en cuanto al controlador de dominio, por ejemplo, si deseo cambiar de grupo a un usuario (de usuarios de dominio a otro, por ejemplo) me dá el siguiente error:

    El programa no puede abrir el cuadro de dialogo requerido porque no se pueden encontrar las ubicaciones. Cierre este mensaje, y vuelva a intentarlo de nuevo.

    Y luego dice en otra caja de diálogo: "El parámetro no es correcto".

    Y si por ejemplo entro a las propiedades de X grupo de seguridad, por ejemplo Administradores de dominio, y me voy a la ficha de "Miembro de", me lanza éste error:

    "No se puede contactar a un catálogo global (DC). Es necesario un catálogo global para poner en una lista las pertenencias al grupo de objetos. El catálogo Global puede no estár disponible de forma temporal. O, si su empresa no tiene un Controlador de dominio configuradocomo un catalogo general, configure uno. Pongase en contacto con el administrador de su sistema paa recibir ayuda"

    Ahora según lo que sé, cada dominio tiene su DC, y lo correcto según mi logica es que si cada dominio es independiente, entonces GAIN es un DC y VTSER es otro DC, cada uno excluyente del otro que no se tocan ni nada, solamente coexistente en la red pero no interactuan ni nada. La pregunta es, porque el servidor está dando ese error? si él deberia ser controlador en su dominio (vtdom en éste caso).

    Ha, los servidores todos son Windows Server 2003 con R2 SP1 y todas las actualizaciones hasta el día de hoy y la mayoria de los clientes son XP con SP3, y según veo todo está configurado usando plantillas, es decir, todo está muy pero muy a lo predeterminado.
    Saturday, May 16, 2009 10:46 PM

Answers

  • La mayoria de los problemas de inicio de sesion lento se deben a problemas de DNS, en ese caso en el dominio VTDOM asegurate de que todas las maquinas apunten su direccion DNS a tu controlador de dominio VTDOM y que VTDOM apunte su direccion DNS primaria a si mismo. 
    Tambien deberias asegurarte que todos los registros SRV esten correctamente registrados en tu servidor DNS


    How to Verify the Creation of SRV Records for a Domain Controller
    http://support.microsoft.com/?scid=kb;en-us;241515&x=18&y=16


    Slds
    Sebastian del Rio

    Saludos. Colabora con el foro y vota si el mensaje es util.
    Sunday, May 17, 2009 1:18 AM
  • Seguí tus instrucciones y todo parece correcto, y me di cuenta que las máquinas que estan en VTDOM tenían el DNS hacia el servidor de GAIN, en el VTDOM, instalé el servicio de DNS, corregí el ip para que usaran el DNS de VTDOM y ahora inician sesión como una chispa, y navegan y todo sin problema, que tal? Y en el servidor propiamente dicho puse en los reenviadores que reenviara todos los "query" de dns (se dice asi?) al servidor GAIN que es el que tiene acceso a internet.

    Que cosas, no sabía si se podría hacer eso, o si en realidad sería algo correcto, ya que como son dos dominios distintos, no pensaba que podría existir ese nivel de colaboración.

    Que les parece la solución? Dará problemas a futuro? o tienen otra teoría?
    • Marked as answer by StreetDog Tuesday, May 19, 2009 2:45 AM
    Tuesday, May 19, 2009 1:32 AM

All replies

  • La mayoria de los problemas de inicio de sesion lento se deben a problemas de DNS, en ese caso en el dominio VTDOM asegurate de que todas las maquinas apunten su direccion DNS a tu controlador de dominio VTDOM y que VTDOM apunte su direccion DNS primaria a si mismo. 
    Tambien deberias asegurarte que todos los registros SRV esten correctamente registrados en tu servidor DNS


    How to Verify the Creation of SRV Records for a Domain Controller
    http://support.microsoft.com/?scid=kb;en-us;241515&x=18&y=16


    Slds
    Sebastian del Rio

    Saludos. Colabora con el foro y vota si el mensaje es util.
    Sunday, May 17, 2009 1:18 AM
  • Seguí tus instrucciones y todo parece correcto, y me di cuenta que las máquinas que estan en VTDOM tenían el DNS hacia el servidor de GAIN, en el VTDOM, instalé el servicio de DNS, corregí el ip para que usaran el DNS de VTDOM y ahora inician sesión como una chispa, y navegan y todo sin problema, que tal? Y en el servidor propiamente dicho puse en los reenviadores que reenviara todos los "query" de dns (se dice asi?) al servidor GAIN que es el que tiene acceso a internet.

    Que cosas, no sabía si se podría hacer eso, o si en realidad sería algo correcto, ya que como son dos dominios distintos, no pensaba que podría existir ese nivel de colaboración.

    Que les parece la solución? Dará problemas a futuro? o tienen otra teoría?
    • Marked as answer by StreetDog Tuesday, May 19, 2009 2:45 AM
    Tuesday, May 19, 2009 1:32 AM
  • Pareceria ser todo correcto :)

    Bien ... ha sido facil :)

    Me alegro que hayas solucionado tu incoveniente.

    Slds
    Sebastian del Rio


    Saludos. Colabora con el foro y vota si el mensaje es util.
    Tuesday, May 19, 2009 1:46 AM
  • Gracias :D
    Tuesday, May 19, 2009 2:45 AM