none
Changing Max Color Depth Greyed Out - RD Session Host Config

    Question

  • Hello,

    We are using RD 7.1 on our Windows Server 2008 R2 server, and I am unable to change the maximum color depth from 8bit. We need this set to at least 16bit. This area is greyed out, but everything else can be changed.

    I have edited the local GPO and it does not take effect (I read that the GPO cannot exceed the limit set on the RD Session Host Configuration setting, so this is likely why it is not working).

    According to my boss we don't have any GPO's setup to change this, as our other Terminal Servers are not having this issue at all. He set it up and I assume likely changed something that will not allow us to change this setting.

    I have changed the registry to reflect the 16bit, but a simple restart of the system for any reason will change it right back to 8bit.

    I have done the technet article on enabling Desktop Composition (http://technet.microsoft.com/en-us/library/dd759195.aspx) and that did NOTHING.

    I need help ASAP

    Tuesday, July 30, 2013 1:33 PM

Answers

  • Figured out it was a GPO setting on the OU in AD for where this server is located.
    • Marked as answer by DCap88 Tuesday, July 30, 2013 7:38 PM
    Tuesday, July 30, 2013 7:37 PM

All replies

  • IF you check the device manager, is the graphic card drivers installed correctly?
    Tuesday, July 30, 2013 1:35 PM
  • Drivers are working 100%. There is a setting for Remote Desktop causing this. I logged into the server locally and it is perfectly fine.
    Tuesday, July 30, 2013 1:41 PM
  • Keep in mind, that you are in a RD Session.

    It might be that the Connection is slow and therefore you are on limited graphics.

    Double check the Graphics card under Device Manager.

    If the graphics card is up to date, then check and see what you graphics card can support, to make sure that your graphics card can handle 16bit.

    Try teamviewer instead of RD, this might allow you change then settings and it might keep the changes when you go to RD.

    You might have to create a new GP and just move that machine to the new GP in order to be able to change it

    Hope this helps, Have a good day.

    -LT

    Tuesday, July 30, 2013 1:45 PM
  • The card can handle more than 16bit, it is on 24 bit when on locally. There is a setting somewhere causing it to stick with 8bit. 

    Our other RDP sessions work perfectly fine and are set to 16 and 24 bit color management.

    EDIT - - - - - - - - - - -

    I have edited 2 registry keys, and restarted. Seems to be sticking at 16bit right now.

    • Edited by DCap88 Tuesday, July 30, 2013 1:57 PM edit
    Tuesday, July 30, 2013 1:54 PM
  • Here you go DCAP

    http://technet.microsoft.com/en-us/library/cc772048.aspx

    To specify the maximum color depth for a remote session
    1. On the RD Session Host server, open Remote Desktop Session Host Configuration. To open Remote Desktop Session Host Configuration, click Start, point to Administrative Tools, point to Remote Desktop Services, and then click Remote Desktop Session Host Configuration.

    2. Under Connections, right-click the name of the connection, and then click Properties.

    3. In the Properties dialog box for the connection, on the Client Settings tab, select the Limit Maximum Color Depth check box, and then select the appropriate value for your environment.

      The default value is 32 bpp. A color depth of 24 bpp is only supported on Windows XP Professional and Windows Server 2003.

    4. Click OK. Changes to color depth settings are not applied to sessions that are connected when the change is made. The changes will take effect the next time the user establishes a new connection to the RD Session Host server.

    There you go DCAP

    have a good day

    -LT

    Tuesday, July 30, 2013 1:58 PM
  • I've tried that numerous times, the setting is greyed out, thats the issue that I am/was having. Editing the registry seemed to fix this. Will need to confirm before I close this.
    Tuesday, July 30, 2013 2:05 PM
  • Figured out it was a GPO setting on the OU in AD for where this server is located.
    • Marked as answer by DCap88 Tuesday, July 30, 2013 7:38 PM
    Tuesday, July 30, 2013 7:37 PM