none
Ripristino di sistema da un'immagine WindowsImageBackup su unità esterna.

    Question

  • Buongiorno al forum, è il mio primo invio su questo forum e temo di risultare fuori luogo con i miei dubbi. In tal caso chiedo scusa in anticipo. 

    Avevo creato una WindowsImageBackup dal centro di ripristino e backup. A seguito di un crash che aveva compromesso la leggibilità di alcuni settori dell'Harddisk (spegnimento ex-abrupto) il sistema non riusciva a riavviarsi. La partizione di ripristino tuttavia sembra non essere compromessa, e così avevo potuto ripristinare il sistema alle condizioni di fabbrica, sperando di potere successivamente recuperare la partizione creata. Tuttavia accedendo al centro di backup e ripristino non riuscivo più a trovare traccia di alcun punto di ripristino (è ragionevole dato che ho reinstallato ex-nuovo) né delle immagini di sistema (che però riuscivo a visualizzare in forma di directory all'interno dell'unità esterna di backup). Alla fine mi ero arreso, perché tutto sommato i file più importanti li avevo sempre in disponibilità dai backup ordinari compresenti nello stesso disco. E' passato diverso tempo, ho installato software e adesso mi trovo nuovamente con lo startup che non si avvia. Stavolta non ho tenuto da parte immagini di backup, il danno è meno severo della volta precedente, windows non si avvia né in modalità normale né in modalità provvisoria ed ora ho solo due opzioni avvio in modalità normale oppure rispristino.

    Riesco infatti ad accedere all'applicazione di ripristino, e da qui ad avviare una shell dos ed accedo alla partizione Windows ed alle directory. Volevo ripristinare alle condizioni di fabbrica facendo prima un backup del disco che però non va a buon fine:

     

    la tabella di backup viene preparata, il backup si avvia regolarmente, ma si arresta quando è arrivato a circa il 60%. 

     

    Per evitare che nel 40% restante ci siano cose che considero importanti proverò a salvare manualmente i file principali che mi interessano tramite una distribuzione live o direttamente dalla shell dos della configurazione di ripristino.  


    Leggo adesso, in questo articolo:

    http://www.ilsoftware.it/stampa_articolo.asp?id=7336

     

    che probabilmente sarebbe stato sufficiente premere ignora per procedere. 


     Chiedo se avete consigli per risolvere i problemi con il backup attuale che non va a buon fine e se in effetti posso successivamente procedere al rispristino dell'immagine di sistema da quella precedente immagine di backup che ancora conservo. 

    Aggiungo che in una partizione separata della mia unità di backup avevo fatto una immagine di sistema fin dal primo lancio ed avevo anche creato un disco di ripristino ed un'immagine su ulteriori 3 dvd, che finora non mi era sembrato necessario utilizzare. Ho provato adesso ad avviare il sistema dal disco di ripristino e mi trovo in pratica nello stesso ambiente a cui posso accedere dalla partizione di ripristino, con le solite opzioni, non mi viene proposto in ogni caso un rispristino da immagine di sistema e per accedere alle opzioni di ripristino da windows dovrei uscire dalla utilitiy di ripristino e potere avviare Windows, quindi fin tanto che non ho fatto il backup e non ho reinstallato una versione funzionante penso di dovere rimandare gli esperimenti di ripristino del sistema dall'immagine di backup. E' corretto questo oppure c'è un modo per avviare windows in versione live dal disco dvd di ripristino?


    • Edited by Gianm Friday, February 03, 2012 12:05 PM
    Friday, February 03, 2012 12:03 PM

Answers

  • La spunta dovrebbe essere sempre impostata di default anche nella partizione di recovery.

    Se il clone di Cyberlink non ripristina non ti resta che provare il ripristino dall'immagine creata con l'utility di Windows 7.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    Tuesday, February 07, 2012 7:06 PM
    Moderator

All replies

  • Ma avviando il pc con il cd di ripristino ottieni questa schermata:

    Quindi cliccando su Ripristino immagine del sistema dovresti poter selezionare l'immagine precedentemente salvata.

    (se è in un disco esetrno usb deve essere collegato Prima di avviare dal cd.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration
    Friday, February 03, 2012 8:04 PM
    Moderator
  • Scusa il ritardo nel rispondere: dal disco di ripristino si apre un rispristino guidato che mi pare di parti terze, in pratica compare il marchio cyberlink, con le opzioni elencate su tre colonne, da indagine internet trovo che è la soluzione commerciale scelta da Hp. A quanto pare HP fa questa scelta, per chissà quale motivo, anche su macchine a 64 bit con Windows 7 preinstallato. Per questa ragione non ho accesso diretto ai tool di ripristino immagine che vedo nel pannello che hai indicato. Fra parentesi scrivi che se è un disco esterno usb (si, il disco che contiene l'immagine di backup recente è effettivamente di un disco esterno collegato con USB) devo collegarlo prima di avviare dal cd, in effetti l'ho collegato prima ancora di accendere la macchina. Purtroppo HP non fornisce dischi con il sistema operativo. Aggiungo che nel recovery manager di Cyberlink c'è anche un'opzione per il ripristino da Windows, selezionando questa opzione il Cyberlink manager si disattiva, ma vengo indirizzato ad una finestra che offre solo il ripristino dalla tabella dei punti di ripristino (tabella che peraltro è assente) e non dalle immagine di sistema.

    • Edited by Gianm Monday, February 06, 2012 11:42 AM
    Monday, February 06, 2012 11:35 AM
  • Sbagli procedura.

    Il disco di ripristino creato dall'apposita utility in Windows 7 è un cd AVVIABILE.

    Quindi:

    1) Inserisci il cd di ripristino dell'unità ottica e collega il disco esterno usb contenente l'immagine.

    2) Riavvia ed immediatamente premi (probabilmente Esc) il tasto per ewntrare nel bios o per visualizzare l'utility che imposta le priorità di avvio.

    3) Imposta l'unità ottica come prima unità di avvio ed esci salvando.

    4) Appare la scritta "premi un tasto per avviare da cd-rom" , esegui.

    5) Verranno caricati i file ed apparirà la finestra che ho postato.

    Poi devi solo seguire le istruzioni.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration
    Monday, February 06, 2012 11:45 AM
    Moderator
  • La procedura che ho seguito era pedissequamente quella che hai indicato.

    Cioè per default ho l'unità ottica interna come prima unità di boot, il disco esterno su usb come seconda e l'hard disk interno solo come terza.

    Dopo aver ricontrollato che fosse così, ho avviato, il CD avvia Windows regolarmente, compare una schermata azzurra sulla quale si apre per una frazione di secondo una shell dei comandi, ed a questo punto si avvia a pieno schermo l'utility di Cyberlink con il messaggio seguente:  di default l'utilità di ripristino è avviata dall'hard-disk, ma si può scegliere di avviarla dal disco di ripristino.

    E siamo punto daccapo perché anche scegliendo l'avvio da disco ottico parte l'utility di Cyber-Link. Probabilmente ho fatto un errore da dilettante all'inizio, quando ho creato i dischi di ripristino evidentemente ho usato l'unità software di Cyberlink backup manager, piuttosto che il Windows Backup and Recovery Manager.

    Ma forse posso rimediare dopo avere ripristinato alle condizioni di fabbrica? Se vado creare un disco di ripristino dall'unità di Backup e ripristino adesso funzionerà? Intanto ho quasi completato il backup a forza di xcopy.

     

    Altri test: il fylesystem risulta danneggiato solo sulla partizione di Windows sia se visto da GParted che se visto da una Live di Ubuntu che ho provato.

    Diskpart invece non segnala alcun danno, però in fase di copia mi accorgo dei problemi perché diversi files in diverse cartelle non possono essere copiati nemmeno manualmente (a meno di forzare la trascrizione). 

    Siccome l'utilità di riparazione chkdsk impiegava tempi biblici 1 file ogni 20 secondi o più ho fatto una scansione con i Seagate tool, nella speranza che riparasse la partizione, in effetti rivela gli errori, ma non riesce a ripararli perché il drive è della Western Digital e le utility della Western Digital, sul sito della compagnia, non sono aggiornate per l'uso su sistemi a 64 bit tramite dos. 



    • Edited by Gianm Monday, February 06, 2012 3:48 PM
    Monday, February 06, 2012 3:39 PM
  • Negativo.

    Stai usando altri dischi per l'avvio.

    DEVI usare il disco di ripristino della tua versione di Windows (Pannello di controllo > backup e ripristino > crea un disco di ripristino) oppure un DVD di Windows 7 della tua versione.

    Ciò che stai usando sono dischi di ripristino creati con l'utility di Cyberlink.

    Segui la procedura.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration
    Monday, February 06, 2012 3:51 PM
    Moderator
  • Infatti, mi confermi, dunque il mio sospetto più recente. Appena avrò provato mi aggiorno. Posso per caso scaricare una immagine iso, masterizzare su DVD per poi ripristinare dall'immagine sull'hard-disk? 
    Monday, February 06, 2012 4:24 PM
  • No.

    Crea il disco di ripristino anche da un altro pc CON LA STESSA VERSIONE di Windows 7.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration
    Monday, February 06, 2012 4:28 PM
    Moderator
  • Grazie Franco. Il tuo supporto è stato preziosissimo. Ho finalmente completato la messa in sicurezza dei file fondamentali, ho ripristinato alle condizioni di fabbrica, ho creato il disco di ripristino e mi sembra che finalmente funzioni, vedo il pannello di cui mi parlavi, in un secondo momento tenterò il ripristino dell'immagine di cui avevo detto. In questa apoteosi rimango solo con una punta di amarezza, se si dice che chi è causa dei suoi mali pianga se stesso, in questo caso magari non c'è da piangere ma da commiserarmi un pochino si. Ad un certo punto mi ero convinto che forse avrei potuto rimettere in sesto la baracca semplicemente mettendo a posto il master boot record, temendo che la causa del blocco fosse di fatto un rootkit a livello di MBR. La partizione windows, quella interessata da problemi, risultava su d dal prompt dei comandi di ripristino (mentre dalla shell di windows adesso la vedo come volume C:)comunque ho dato questi comandi: bootsect /nt60 d: /RebuildBcd bootsect /nt60 d: /fixMbr bootsect /nt60 d: /fixboot adesso quando riavvio il primo messaggio è che si richiede un controllo di coerenza sul volume di ripristino, dopo questo controllo l'avvio è tuttavia bloccato. Se salto questo passaggio invece il sistema di avvia. Da notare che la partizione di ripristino non è in verità danneggiata ed in effetti avviando da F11 viene caricato windows, e tutta la procedure di ripristino alle condizioni di fabbrica l'ho fatto da disco interno senza dover usare il CD di ripristino creato da Cyberlink. Ho tentato di riparare il problema con l'ausilio dell'utility di fixing dei problemi di start-up per mezzo del disco di ripristino appena creato. Un problema viene individuato a carico di uno dei quattro volumi della partizione del disco interno, il tentativo di riparazione non va però a buon fine con messaggio d'errore 0x480 dal log. Il messaggio interattivo dice solo che l'utilità non è in grado di riparare da sola il problema e viene quindi automaticamente avviata l'utility di ripristino Cyberlink con le sue solite opzioni, fra cui il consiglio di contattare Hp. Prima di combinare altri guai ho cercato di documentarmi e qualcuno scrive che HP ha un Mbr customized, il che mi spiegherebbe lo strano comportamento dell'utility di riparazione. Posso evitare di contattare Hp, che sembra prevedere in questi casi (problemi con il disco) un servizio telefonico a pagamento?
    • Edited by Gianm Tuesday, February 07, 2012 12:40 AM
    Tuesday, February 07, 2012 12:28 AM
  • Ho capito pochissimo di quello che hai scritto.

    Praticamente nulla.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    Tuesday, February 07, 2012 7:39 AM
    Moderator
  • Mi spiace, l'esposizione è confusa perché evidentemente non ho le idee chiare sul problema residuo. Come detto ho completato il ripristino alle condizioni di fabbrica per quanto riguarda la partizione Windows. Ma ho cambiato qualcosa nell'ordine di boot, usando il comando bootsect. Si tratta di un cambiamento che non impedisce né le funzionalità di ripristino dal disco interno né l'avvio del sistema operativo reinstallato, a patto di saltare questo controllo di coerenza sul volume di ripristino che si autoavvia di default.

    A parte questo problema il ripristino alle condizioni di fabbrica ha funzionato bene, ho potuto accedere all'unità di backup e ripristino e creare un disco di ripristino Windows, che ho testato e funziona. Fra le opzioni del pannello che hai riportato in precedenza ho selezionato la voce di ripristino all'avvio, che genera automaticamente un report. Adesso sto provando ad usare i tools di HP per una scansione dello start up, sperando che riescano ad individuare e risolvere il problema. Se anche questo dovesse fallire riproverò a lanciare il "ripristino all'avvio" salvare il report su una pennetta e magari inviarlo. Ma comunque la questione potrebbe essere a questo punto di interesse per un altro thread e per un altro gruppo. Grazie.  

    Tuesday, February 07, 2012 11:31 AM
  • Ok.

    Se ho capito bene parte lo scandisk ad ogni avvio.

    E' questo?

    Se è così segui qui:

    Digita :

    regedit

    e dai invio nel box di ricerca del menù start.

    Vai alla chiave:

    HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\CONTROL\SESSION MANAGER

    Biclicca sulla chiave BOOTEXECUTE.

    Dovrebbe avere come stringa:

    AUTOCHECK AUTOCHK *

    Se questa stringa, che è di default è già presente sostituiscila con questa:

    AUTOCHECK AUTOCHK /K:x*

    Attenzione : X è la lettera del disco quindi se è C cambiala di conseguenza.

    Verifica bene e chiudi regedit.

    Riavvia.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration



    Tuesday, February 07, 2012 11:34 AM
    Moderator
  • Non sono sicuro che sia solo questo. Perché in condizioni normali se ci sono problemi lo scandisk all'avvio parte sul volume C dove si trova la partizione di windows: invece in questo caso è sul volume D: dove si trova la partizione di ripristino. Inoltre lo short dst test degli HP tool fallisce il test. Lo trovo piuttosto strano. Da shell in modalità amministratore ho dato il comando chkntfs d: ed il messaggio di risposta è d: è danneggiata. In pratica il controllo di coerenza va liscio fino al controllo del diario USN, il messaggio a schermo dice che è stato controllato, ma anziché a questo punto chkdsk anziché restituire il controllo alla procedura di avvio sembra rimanere in stallo.

    Anche più semplicemente nell'utilità di deframmentazione la partizione d: non compare con la sua etichetta (d:) recovery_tools come era prima di reinstallare, ma con \\?\volume{...}\ dove ho omesso il codice numerico identificativo.

    In conclusione, per logica mi aspetto che aggiungendo alla chiave di registro la specifica /K:d* il problema all'avvio non si verifichi più, ma non avrei effettivamente risolto il problema, che non ho ancora identificato, a carico del volume d, l'avrei solo messo in sordina. E' corretto? Può darsi che una reinstallazione dal disco di ripristino creato con l'utilità cyberlink, anziché dall'hard disk interno, possa risolvere il problema alla radice?



    • Edited by Gianm Tuesday, February 07, 2012 2:38 PM
    Tuesday, February 07, 2012 2:21 PM
  • Se la partizione di recovery è danneggiata DOVREBBE rigenerarsi ripristinando l'immagine creata da Cyberlink.

    Ma anche ripristinando l'immagine creata con l'utility di Windows 7 dovrebbe recuperarla se era sta inclusa.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    Tuesday, February 07, 2012 3:45 PM
    Moderator
  • Sto provando il ripristino dai 4 dvd creati da Cyberlink, però dalla premessa non è in linea con quel che speravo. Infatti il primo messaggio parla solo di formattazione della partizione windows. Se è come penso non resta che sperare nel mio nuovissimo disco di ripristino :-) Però adesso ho un dubbio anche sull'immagine creata da Windows 7: non sono sicuro di ricordare, ma che l'immagine deve contenere tutte le partizioni e non solamente quella corrente, è la proposta di default se non sbaglio, basta selezionare il nodo più in alto per includere tutto o va specificato manualmente in altro modo? 
    Tuesday, February 07, 2012 7:03 PM
  • La spunta dovrebbe essere sempre impostata di default anche nella partizione di recovery.

    Se il clone di Cyberlink non ripristina non ti resta che provare il ripristino dall'immagine creata con l'utility di Windows 7.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    Tuesday, February 07, 2012 7:06 PM
    Moderator
  • Sembra risolto. Grazie per il sostegno generoso. Non mi resta che ripristinare dall'immagine disco che ho da parte. 
    Tuesday, February 07, 2012 9:45 PM
  • Welcome.

    La prossima volta apri una domanda nel Forum appropriato:

    http://answers.microsoft.com/it-it

    Riservato agli utenti consumer.

    Questo invece è un Forum per Professionisti IT.

    Dato che avevamo iniziato il thread lo abbiamo concluso.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    Tuesday, February 07, 2012 9:50 PM
    Moderator