none
Problem with HBA during Live Migration

    Question

  • We have 4-node Windows 2012 Hyper-V cluster on HP blades. We deploy VM with virtual HBA. After Live Migration of this VM we lost HP Tape Library drives (connected to the "Live Migration target" blade). Windows Device Manager does not show them and "Scan Hardware Changes" does not solve this problem. Tape drives reappear after Windows rebooting only. We have no problems with disk drives (HP EVA) connected to physical node (blade) and with ones connected to VM - we have problem only with tape library.

    Tape drive connected only to physical host (we don't use them in VMs). We install actual QLogic (QMH2562) and tape drivers for Windows 2012 from HP Support Pack.

    Tuesday, May 14, 2013 8:23 AM

Answers

All replies

  • If I followed your explanation correctly, you are saying that you have a Hyper-V host with an attached tape library.  When you live migrate a VM that has a vHBA to this Hyper-V host, the host loses connectivity to the tape drive.  Is this correct?  Is the tape drive connected via fibre channel?  Have you reported this to HP?  Does you have the latest drivers from HP?  HP is the one providing the drivers here, so I would start with them.

    .:|:.:|:. tim

    Tuesday, May 14, 2013 12:00 PM
  • Hi,

    I would like to confirm what is the current situation? Have you resolved the problem or do you have any further progress?

    If there is anything that we can do for you, please do not hesitate to let us know, and we will be happy to help.


    Lawrence

    TechNet Community Support

    Friday, May 17, 2013 9:04 AM
  • After investigation we detect that server may lost not only library, but may lost any path (how many virtual ports used by VMs so many paths). Moreover, physical server losts paths not only during Live Migration but during starting of VM with vHBA on this host.

    We organize virtual lab on 2 new blades but we can't reproduce this strange situation (test VM with virtual HBA doesn't "kill" FC paths on virtual lab, but "kills" FC path in productive environment after inter-cluster migration).




    • Edited by Roman1974 Tuesday, June 11, 2013 9:42 AM
    Monday, June 10, 2013 5:49 AM
  • Physical server can not have more then 8 paths (physical paths + vHBA ports) like this thread: http://social.technet.microsoft.com/Forums/windowsserver/en-US/5c4801b8-7aa1-4c22-a40d-390718f37f73/hard-path-limit-of-8-in-vm-with-hyperv-virtual-fibre-channel.

    We'll wait updated QLogic drivers.

    • Marked as answer by Roman1974 Friday, July 12, 2013 6:12 AM
    Friday, July 12, 2013 6:12 AM
  • Tape libraries are not supported on virtual machines configured with a Virtual Fibre Channel adapter.

    http://technet.microsoft.com/en-us/library/hh831413.aspx

    Sunday, December 22, 2013 1:36 AM