none
Public Folders and Universal Distribution Groups

    Question

  • Can you not add universal distribution or security groups to public folders? You could do this in the past.

    I have a universal distribution group and Exchange 2013 will not let me add it to the public folder:

    Add-PublicFolderClientPermission -AccessRights Owner -User "AllUsers@knowmoreit.com" -Identity "\KNO"

    I get this message:

    The user "AllUsers@knowmoreit.com" is either not valid SMTP address, or there is no matching information.
    
    NotSpecified: (:) [Add-PublicFolderClientPermission, InvalidExternalUserIdException

    I checked and this distribution group has the Primary SMTP address set to AllUsers@knowmoreit.com, it is not hidden, RecipientType is "MailUniversalDistributionGroup".

    What am I missing here?

    Thursday, October 03, 2013 3:48 AM

Answers

  • So I had to create a univeral security group, then run Enable-DistributionGroup on it from Exchange and then I could add it.

    For some reason if I just create a universal security group or distribution group it isn't letting me add it

    • Marked as answer by Quadrantids Friday, October 04, 2013 9:23 PM
    Friday, October 04, 2013 9:22 PM

All replies

  • Hi,

    First, I recommend you check whether the Identity you specified is right.

    Besides, I recommend you specify the User parameter with the alias of the distribution group you mentioned above to check the result.

    If there is any update, please feel free to contact me.

    Best regards,
    Belinda


    Friday, October 04, 2013 8:05 AM
  • I tried the sAMAccount name too and ended up with the same result. I'm trying on another Exchange 2013 environment I have access to and will post back shortly! Thanks!
    Friday, October 04, 2013 2:43 PM
  • Looks like , in Exchange 2013 it is not supported ...

    In Exchange 2010 , I am able to add owner to DL as well.


    MCITP - Exchange 2010 | MCITP - Windows Server 2008 R2

    Friday, October 04, 2013 3:23 PM
  • So I had to create a univeral security group, then run Enable-DistributionGroup on it from Exchange and then I could add it.

    For some reason if I just create a universal security group or distribution group it isn't letting me add it

    • Marked as answer by Quadrantids Friday, October 04, 2013 9:23 PM
    Friday, October 04, 2013 9:22 PM
  • Thanks for Update.

    MCITP - Exchange 2010 | MCITP - Windows Server 2008 R2

    Saturday, October 05, 2013 2:01 AM