none
MDT 2012 - Custom rules by taskSequenceID not working now?

    Question

  • In MDT2010, I used to have different rules based on which task was selected.  I did this by doing this to my rules file:

    [Settings]

    Priority=TaskSequenceID,Default

    [Default]

    some rules for default

    [1]

    some rules for task id 1

    And all was well.  Now since upgrading to 2012, it's ignoring this.  I cannot for the life of me get it to use different rules for each task sequence.  It seems to me that rules are processed *before* the task is selected.  I'm able to have custom rules for chassis type, model, serial, gateway, etc - but not task sequence.

    Does anyone have this working, am I missing something obvious?

    Friday, June 22, 2012 5:49 PM

All replies

  • I use multiple task sequences in my CustomSettings.ini also. After I make the changes to the cs.ini, I also have to go into the task sequence, and change the Gather rule under the Initialization task. Just click the radio button that says "Gather local data and process rules", and in the text box put CustomSettings.ini.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Saturday, June 23, 2012 2:02 PM
  • I did all those things too, and it still doesn't work.  Are you using 2010, or 2012? 

    Mine worked fine in 2010, but as soon as I upgraded to 2012, it stopped working. 

    Monday, June 25, 2012 11:54 AM
  • I am using 2012, but to be honest with you I did not use it prior to the upgrade. I set it up after 2012 was installed.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, June 25, 2012 11:57 AM
  • I am using 2012, but to be honest with you I did not use it prior to the upgrade. I set it up after 2012 was installed.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Interesting - so I just did too.  Brand new Server 2008 / MDT 2012 install.

    1 - Set up a new task, ID "7APPLY"


    2 - Edited the customsettings.ini rules file, so TaskSequenceID is the highest priority setting, Created an entry in the customsettings.ini with the "7APPLY" heading, with the rules I wanted.


    3 - Edited the 7APPLY task to process rules and gather settings:

    And nope... run that task, and the wizard never prompts for anything, and runs with the name "hdimage1 Testing Image" instead of "Apply 7 Test" like it should.

    All of this is on a totally fresh install, nothing else changed.

    Monday, June 25, 2012 1:03 PM
  • Remove _SMSTSORGNAME from the [Default] section and see if it takes then. I think the [Default] section takes priority over the [TaskSequenceID].

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, June 25, 2012 1:20 PM
  • Yea just tried that; and I moved all my settings from Default to 7APPLY to see what would happen - it just completely ignored everything in 7APPLY. 

    This is so weird.

    Monday, June 25, 2012 1:34 PM
  • Ahh... so my searching again today yielded this link:

    http://social.technet.microsoft.com/Forums/pl-PL/mdt/thread/e17a1952-d1f7-41ef-8231-0d6fcc41882e

    Which, lo and behold, my DeployWiz_Validation.vbs is pretty much empty for me:

    ' // ***************************************************************************
    ' // 
    ' // Copyright (c) Microsoft Corporation.  All rights reserved.
    ' // 
    ' // Microsoft Deployment Toolkit Solution Accelerator
    ' //
    ' // File:      DeployWiz_Validation.vbs
    ' // 
    ' // Version:   6.0.2223.0
    ' // 
    ' // Purpose:   Main Client Deployment Wizard Validation routines
    ' // 
    ' // ***************************************************************************
    
    Option Explicit
    
    So that's likely my problem.  Now to figure this part out... ugh.

    Monday, June 25, 2012 1:43 PM
  • Just checked out that link, I wouldn't have guessed that one.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, June 25, 2012 3:41 PM
  • I don't see [7Apply] being called anywhere in your custom settings ini.

    Since you are not making any reference to it, its only processing "TaskSequenceID" and "Default" as result you are defaulting to value of "hdimages1 testing image"

    I think you need to reference it from somewhere "Priority" or from one of the subsections.


    For ex.

    If you would have:

    1.
    Priority=7apply,TaskSequenceID,Default
    then you would get "Apply 7 Test"

    2.
    Priority=TaskSequenceID,Default,7apply
    in this case you would get "hdimages1 testing image"


    Once you assign a value in customsettings you can't re-assign it to something else.

    Monday, June 25, 2012 8:36 PM
  • Brano, I'm not sure I follow. His task sequence ID is 7Apply, so when it processes TaskSequenceID, it processes 7Apply from the subsection. 

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, June 25, 2012 9:49 PM
  • Anyone solve this.? I am running into the same problem. I can set TaskSequenceID but it's not picking up on "7Apply" as the ID variable. I can change "7Apply" to [TaskSequenceID] in the list of rules and it works. but that doesn't do much good. I can also but each of my different "7Apply" names in the Priority area instead of using TaskSequenceID and that works. So I guess I could list each ID in the priority and then that might work..?  Which is better then nothing i guess. 

    My DeployWiz_Validation.vbs is also empty. What's up with that.?  

    • Edited by CPTechSupport Wednesday, June 12, 2013 1:51 AM edited
    Tuesday, June 11, 2013 7:52 PM
  • Did you ever find a answer to your problem with the task sequence ID issue.?
    Thursday, June 20, 2013 8:29 PM
  • Patched file here: DeployWiz_SelectTS.vbs

    DikSoft - MCP


    DikSoft - MCP

    Friday, July 26, 2013 12:13 PM
  • Does anyone know if this is still an issue in MDT 2013 (Preview)?

    If it is then we need to raise it as a bug via the Connect site so that Microsoft have to resolve this in the next release.


    Jonathan Conway | My blog: Conway's IT Blog | Twitter: jonconwayuk | Linkedin: Jonathan Conway

    MCITP: Enterprise Administrator on Windows Server 2008/Enterprise Desktop Administrator on Windows 7 • MCP • MCSE 2003 • MCTS SCCM 2007, Windows 7 Config & Deploying • VCP

    Thursday, August 15, 2013 8:14 AM
  • I have logged this as a bug with the MDT team for MDT 2013 as the issue remains in the preview of the new MDT.

    Bug reference number is: 797776


    Jonathan Conway | My blog: Conway's IT Blog | Twitter: jonconwayuk | Linkedin: Jonathan Conway

    MCITP: Enterprise Administrator on Windows Server 2008/Enterprise Desktop Administrator on Windows 7 • MCP • MCSE 2003 • MCTS SCCM 2007, Windows 7 Config & Deploying • VCP

    Monday, August 19, 2013 6:43 PM