none
Lossy Audio when you RDP into Server 2012 R2

    Question

  • I recently decided to take the risk to upgrade my Terminal Server to Windows Server 2012 R2, to find out that what I worried about, came true. My audio applications have become Lossy via RDP, you can actually hear artifacts when playing audio. In Windows Server 2012, the audio was PERFECT, lossless and as if you are using the audio application on the computer. In fact, this was the BEST thing Microsoft has done with RDP for Windows Server 2012- improving the sound quality DRAMATICALLY via RDP. I know that RDP isn't designed for listening to music or viewing multimedia, but they honestly have changed that in Windows 8 and Server 2012. Seriously, they did.

    So my question would be- How do I DISABLE audio compression via terminal services on Windows Server 2012 R2, or do I have to go back to Windows Server 2012 which would honestly be a hassle being that I need to reinstall my terminal server? Otherwise, how do I deactivate my copy of Windows Server 2012 R2 so that I can reuse the license key?

    Or if there is no solution, this issue needs to be reported to Microsoft for us to at LEAST disable bandwidth consumption and multimedia streaming compression and restore back the RDP audio capabilities that we had in Windows Server 2012.

    Tuesday, September 24, 2013 10:34 PM

Answers

  • Hi,

    I would like to know if the audio is perfect on Windows Server 2012 R2 locally.

    Please check the following GP setting as well.
    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection

    Limit audio playback quality: Enabled
    Audio Quality: High

    On the Client PC, in the .rdp file that you use to connect to the server, make sure you have the following line:
    audioqualitymode:i:2

    If the issue persists, I’m afraid there is no method to downgrade to Windows Server 2012 and you need to reinstall the server. If you are the subscriber, there is no need to deactivate Windows Server 2012 R2. Last but not least, I will collect your feedback and report the issue.


    Niki Han
    TechNet Community Support

    Wednesday, September 25, 2013 3:43 PM
    Moderator

All replies

  • Hi,

    I would like to know if the audio is perfect on Windows Server 2012 R2 locally.

    Please check the following GP setting as well.
    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection

    Limit audio playback quality: Enabled
    Audio Quality: High

    On the Client PC, in the .rdp file that you use to connect to the server, make sure you have the following line:
    audioqualitymode:i:2

    If the issue persists, I’m afraid there is no method to downgrade to Windows Server 2012 and you need to reinstall the server. If you are the subscriber, there is no need to deactivate Windows Server 2012 R2. Last but not least, I will collect your feedback and report the issue.


    Niki Han
    TechNet Community Support

    Wednesday, September 25, 2013 3:43 PM
    Moderator
  • Hey Niki, thank you for replying back to me, also I apologize for not getting back here earlier.

    The "audioqualitymode:i:2" worked!

    This is my fault, this has nothing to do with Windows Server 2012 R2, I only suspected it because it seemed that 2012 wasn't compressing the audio, and the audio performance is better when I remote into it via my iPhone.

    I tested the audio though 2012 and to see that it was doing the same exact thing! I kept trying to uninstall updates to see what update was causing this.

    I have created a new domain, and none of those settings were set. I set the Audio Quality to High and then on the client, set the audio quality mode, and it fixed the problem!

    I did a quick research on the "audioqualitymode:i:2" and it streams lossless audio, which is amazing! I didn't know this worked in Windows 7. I have decided to keep my TS as Server 2012 R2 because it worked.

    In my old domain though, the lossless audio came automatically when I RDP into my Server 2012 TS without the need of specifying "audioqualitymode:i:2" so I am not sure why that happened.

    Anyways thank you for your help, and I apologize for the misleading false-flag title.


    Tuesday, October 08, 2013 6:49 PM