none
Why does my Bootable USB Hard Drive have issues with MDT 2012?

    Question

  • Hello, Everyone

    My Team and I have been successfully creating bootable USB Hard Drives to install window 7 sp1 created on MDT 2010 Update 1.  Recently we upgraded to MDT 2012.  Now I am seeing a major issue.

    Steps are:

    1. Connect USB Hard Drive.  Boot up and press "F12" to select USB Device so we can boot to the USB hard drive.
    2. The litetouch interface comes up and I answer it's questions.
    3. It begins formatting the drive and then it eventually reboots.
    4. The system boots up to this screen:  an operating system wasn't found.  Try disconnecting any drives that don't contain an operating system.  Press Ctrl+Alt+Del to restart.
    5. I restart and press F12 again to boot from the USB Hard Drive.
    6. I get a "dirty environment found" dialouge box in the WinPe stage.  I have the option of ignoring the in-progress deployment or contining it.  I continue it.
    7. Litetouch gives me an option to changes my entries from step #2.  I simply hit next all the way through.
    8. The install continues and complets normally.

    LOG FILES:

    SMSTS.log

    smsts.log

    litetouch.log

    LiteTouch.log

    I am able to get flash drives to work.  I have also tried reformatting the drives (using diskpart) and other utilities.

    Any assistance would be greatly appreciated.  We are HEAVILY leveraged to using USB Hard Drives.  I already know that some of you will want to reply "Why don't you use Flash drive?"

    Thank you


    IT Questor MDT 2010 Update 1 XpSp3 and W7x64Sp1

    • Edited by ITQuestor Friday, June 21, 2013 3:05 PM added graphics
    Friday, June 21, 2013 2:55 PM

All replies

  • I swear I read a blog post about changes to the MDT 2012 meida boot process, but I can't find it now. I guess you probably already know that booting from USB hdds is not supported due to hardware issues detecting drive 0.
    Friday, June 21, 2013 4:36 PM
  • Hi,

    Try this and see if it helps,

    Add a Windows 7 or 8 install disk to DVD drive and your USB hard disk attached

    Open CMD as administrator. D: = DVD drive letter, change if different.

    C:\windows\system32>D:   ( hit enter key. )

    D:\>cd\boot          ( hit enter key. )

    D:\boot>bootsect /nt60 E: ( hit enter key. ) E: = USB Harddisk change to yours.

    Now try again, doing as you described in your post

    1.Connect USB Hard Drive.  Boot up and press "F12" to select USB Device so we can boot to the USB hard drive.

    Also make sure the internal hard disk is attached to sata port 0. After you boot to the WinPE, press the F8 key to get the CMD window and check with Diskpart that your internal HD is Disk 0.

    If it is Disk 0 proceed with install, if you get the dirty environment error, just restart and remove the usb harddisk and allow MS to boot to internal HD to finish off installing, reattach USB HD now.


    Please bear in mind, that my answer is based on the details given in your post. The more I get the better the answer, Slan go foill, Paul




    • Edited by artiste1 Monday, June 24, 2013 10:21 AM edit
    Saturday, June 22, 2013 3:38 PM