none
Website requires login when accessing from external IP

    Question

  • When I try to access the company website on the company network, the site opens no problem.  However when I try to access website from an external IP (e.g., from home or mobile), I am asked to provide login information for the domain.  If I provide the login information, I get

    HTTP/1.1 200 OK
    Server: Microsoft-IIS/7.5
    Date: ...
    Connection: close

    I verified that Anonymous Authentication is enabled in IIS.  I assume the DNS entry is correct because I get the site internally.  The website used to be accessible externally.  This problem started after trying to assign each website to it's own 192.168.1.x address for configuring SSL.  The individual IPs returned the above response, so I figured it didn't work.  I decided to restore the previous settings and removed the SSL binding from the site.

    As I've tried figuring out how to fix this for a couple days now with no results, I'm coming here for any help I can get.

    Friday, September 20, 2013 7:07 PM

Answers

  • Think I found the problem:

    http://www.iis.net/learn/get-started/whats-new-in-iis-8/iis-80-server-name-indication-sni-ssl-scalability

    Friday, September 27, 2013 9:01 PM

All replies

  • Might ask the IIS experts over here.

    http://forums.iis.net/

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Friday, September 20, 2013 7:27 PM
  • Thanks, Dave.  I have posted there as well (http://forums.iis.net/p/1201592/2058121.aspx?p=True&t=635152891617687392&pagenum=1)

    If there is anything non-IIS related that may be the cause I'd like to know though.

    Friday, September 20, 2013 7:54 PM
  • Hi William,

    Based on my research, the issue was caused by IP address configuration.

    As the last reply in the post which you released on IIS forum referred, 192.168.1.x is a private address, which can only be accessed from internal network.

    We need to set up an public address for external access.

    As for SSL implement, which can secure data between applications across an untrusted network, I suggest that we keep using it.

    I hope this helps!

    Best Regards,

    Amy Wang



    Tuesday, September 24, 2013 2:08 AM
  • There is a single public IP address (e.g., 118.118.118.118) coming into the router.  All websites share this address on the internet.

    The router is setup with DHCP.  The entire network gets assigned private IP addresses.

    Server1 has

    • a static IP of 192.168.1.10
    • a single NIC with two IP addresses 192.168.1.10 and 192.168.1.11

    Server2 (a VM on Server1) has

    • a static IP of 192.168.1.50
    • shares the single NIC of Server1

    All websites have

    • Host A records in DNS pointing to either 192.168.1.10, 192.168.1.11, or 192.168.1.50
    • hostnames in IIS

    Status

    • Hostname: aaa.mydomain.com IP: 192.168.1.10 is accessible from the internet
    • Hostname: bbb.mydomain.com IP: 192.168.1.11 is not accessible from the internet (returns the above mentioned error message) but is accessible internally (site opens)
    • Hostname: ccc.mydomain.com IP: 192.168.1.50 is accessible from the internet

    I'd like to figure out why bbb.mydomain.com is not accessible so that I can use SSL.

    Tuesday, September 24, 2013 5:29 AM
  • Hi William,

    According to your description, two of your three sites are accessible from Internet without any problems.

    Would you please compare the settings between these three machines, and correct the problematic machine’s settings?

    If this could not solve this issue, please refer to the IIS experts about the computer configuration on IIS Manager.

    Thank you for your understanding and support!

    Best Regards,

    Amy Wang
    Wednesday, September 25, 2013 8:19 AM
  • Hi Amy, thanks for responding.

    There are two machines, not three (Server1 and Server2).

    The feedback in the IIS forum is that my problem is not within IIS.  This seems to be confirmed because the sites are accessible internally.

    The only difference between the two machines is the assignment of an additional IP to the NIC of Server1.  I used the directions from this site: http://www.tutorialspoint.com/shorttutorials/assign-multiple-ip-addresses-to-windows-8-computer

    The problem is in using that additional IP address.

    Wednesday, September 25, 2013 8:53 PM
  • Think I found the problem:

    http://www.iis.net/learn/get-started/whats-new-in-iis-8/iis-80-server-name-indication-sni-ssl-scalability

    Friday, September 27, 2013 9:01 PM
  • Hi William,

    Thank you so much for your sharing! I’m glad it all worked out.

    Please feel free to ask us if there are any issues in the future.

    Best Regards,

    Amy Wang

    Monday, September 30, 2013 1:10 AM