none
Customising UAG dialogue boxes

    Question

  • I am currently in the process of customising our new UAG portal to have a more corporate look and feel. I have successfully modified the logon page (using OWA theme) and also the portal home page. In fact, I have managed to modify every part I need to, except for the dialogue boxes.

    The boxes in question are the Selective Remote Desktop, Session Timeout and Session Expired boxes. 

    I have located and modified (re-coloured) the files in InternalSite\Images\CustomUpdate (dialog_footer_right, dialog_footer_middle, dialog_footer_left etc etc) but the dialogue boxes remain their original blue colour. 

    I have tried, as a test, modifying the original files in InternalSite\Images but this has no effect either. I have removed every original coloured file I can find, and replaced them with my re-coloured ones, but still somehow the dialogue boxes are blue!!!

    Can anyone shed any light on why?

    Thanks!

    Friday, July 05, 2013 2:36 PM

All replies

  • Can anyone help with this please?

    Thanks

    Monday, July 29, 2013 6:48 AM
  • Hiya, 

    The best I have been able to find on the matter, is the below summary from the referenced book:

    http://www.packtpub.com/article/customizing-look-feel-UAG

    Monday, July 29, 2013 7:00 AM
  • Thanks for your reply. Unfortunately, I've actually purchased the book from which that article is taken, and it doesn't help :( Somehow, despite no blue coloured copies of the image files existing on the box, somehow the dialogue boxes are still blue!!
    Monday, July 29, 2013 7:50 AM
  • Hiya, 

    Doesn't it come from the following section of the template.css?

    /* UAG dialog box styles */
    .DialogBox_Layout
    {
    }

    For some reason I am unable to trigger any of the dialog boxes :( 

    Just spinning up a dev box to do some testing also :)
    Monday, July 29, 2013 9:36 AM
  • Thanks for that!

    That is the location I presumed it must be. I have a customupdate version of the file, and although other settings can be changed with this file, I don't seem to be able to affect the dialogue boxes! 

    The image file paths all reference /images/customupdate/ images, which are all modified in colour by myself. In desperation, I have also copied over the /images/ versions of the files, and modifiying the non-customupdate template.css. Somehow, the dialogue boxes are still blue, despite all the image files having been modified to my corporate orange!!

    Easiest way to launch a dialogue box, I have found, is to publish remote desktop (user defined) application. 

    If your test box allows you to modify the dialogue box colours, then I have more of a problem :(

    Cheers!

    Monday, July 29, 2013 11:31 AM