none
Mensagem de erro "COM Surrogate parou de funcionar"

    Question

  • Tenho recebido esta mensagem toda vez que eu abro algum diretório que tenha um arquivo de filme em DiviX. Pesquisando na Internet decobri que esta mensagem esta relacionada a um conflito de codec. O que acontece é que, na busca de um DVD Player compativel com o Vista, eu andei instalando/removendo varios softwares de DVD Player. Eu tentei remover todos os pacotes de codecs que apareciam na lista de "Programas e Recursos", mesmo assim a mensagem continuou aparecendo. Utilizando o softwrae GSpot eu consegui verificar que ainda existem codecs instalados que não aparecem na lista de "Programas e Recursos", eu ainda não sei qual codec exatamente esta em conflito, mas o que eu gostaria de saber é como remover estes codecs? eu tentei apagar o arquivo própriamente dito mas o Vista não me autorizou. Alguém tem alguma idéia? Grato
    Monday, April 23, 2007 1:25 PM

Answers

  • cara tenta isso, va em

    C:\Program Files\Common Files\Ahead\DSFilter
    e renomeie o arquivo NeVideo.ax para NeVideo.ax.bkp que o erro deve cessar

    Monday, August 20, 2007 9:53 PM

All replies

  • Hey Solive,

     

    Vi um erro parecido com o teu em outro topico em ingles:

     

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=1435875&SiteID=17

     

    aparentemente, removendo o URGE resolve o problema. Vi alguns outros topicos relacionando o problema a uma atualização do windows media player. Nestes casos, a recomendação foi downgrade para a versão anterior.

    Monday, May 21, 2007 2:44 PM
  • cara tenta isso, va em

    C:\Program Files\Common Files\Ahead\DSFilter
    e renomeie o arquivo NeVideo.ax para NeVideo.ax.bkp que o erro deve cessar

    Monday, August 20, 2007 9:53 PM
  • Valeww brother, até agora deu certo o teu esquema aí, só tenho uma dúvida:

    pode surgir algum efeito colateral a alteração da extensão no nome daquele arquivo?

    Valewww

    Wednesday, November 07, 2007 4:22 AM
  • Valeu brother!

    Sua orientação funcionou numa boa.

    Sunday, December 02, 2007 11:40 AM
  •  

    sim, o efeito colateral eh que o Nero Showtime para de funcionar =D

     

    de qualquer forma, pq voces usam nero?

    q coisa 0o

     

    Abraço a todos!

    100+

    []'s CivilWars.

    Friday, December 28, 2007 4:01 PM
  • Cara, vc acertou na mosca...., o meu Vista tava dando pau toda hora... e agora... acabou o problema!!!!

     

    Monday, January 07, 2008 6:59 PM
  • Obrigado brother estava com o mesmo problema, mas agora tenho outro não consigo ter legendas nos filmes

    no Media Player, quais codec utilizar?

    Obrigado e Cumps.

     

    Saturday, February 16, 2008 12:55 PM
  •  

    Combined Community Codec Pack

     

    Abraço a todos!

    100+

    []'s CivilWars.

    Saturday, February 16, 2008 7:23 PM
  • Essa foi muito boa, meu computador estava com o mesmo defeito, agora tá ok! Mas uma dúvida, posso continuar usando o Power DVD, ou existe algum outro programa que não gere conflito com o vista?

     

     

    Tuesday, July 15, 2008 3:41 AM
  • pode continuar usando sim, de preferencia baixa uma versao mais atual que ela tem compatibilidade completa com o vista.

    pode ficar despreocupado (a?), funciona direitinho.

     

    Abraço!

    100+

    []'s CivilWars.

    Tuesday, July 15, 2008 4:44 AM
  • Olá, acabei de ver uma dica num site sobre esse erro o link esta abaixo:

     

    h ttp://www.windowsbrasil.com.br/index.php?view=article&catid=21&id=270&option=com_content&Itemid=62

     

    Espero que tenha ajudado.

     

    Wednesday, July 16, 2008 12:46 AM
  • Brother não tem esse arquivo no meu micro, tem alguma outra sugestão?

    Deletei o nero 8, estou usando o Power DVD 7.

    cada vez que abro a pasta onde estão os videos da essa mensagem "COM surrogate parou de funcionar".

    O QUE FAÇO?

     

    Saturday, October 11, 2008 4:26 PM
  • Olha, tentei fazer o que vc disse e não consegui achar a pasta e o arquivo "Ahead\DSFilter" não esta dentro do "Common Files" e parece não existir dentro do meu pc, tem uma outra solução aí?

    Tuesday, November 25, 2008 11:58 PM
  • se voltares a receber, minimiza, pois assim já não apareçe mais.espero ser util

     

    Tuesday, December 30, 2008 12:12 AM
  • Nao consegui encontrar a Ahead, talvez  o meu problema seja de outra origem.. Se alguem encontrar nova solução, compartilhem... vlw!
    Junior
    Saturday, March 14, 2009 10:51 PM
  • Em das FAQ do K-lite Mega Codec ak aparece a seguinte informação...

    talvez seja util...

    How to fix "COM Surrogate has stopped worked" errors on Windows Vista?
    A: This error may pop up when you browse a folder that contains many video files in it.

    To see what exactly caused the error go to:
    Start -> Settings -> Control Panel -> System and Maintenance -> Problem Reports and Solutions -> View Problem History -> Then double-click on the COM surrogate error. Then have a look at the 'Fault Module Name' item.

    Workarounds:

    •Open DivX Decoder configuration. Uncheck "Use advanced hardware overlay".
    •If you got an old version of DivX installed, then uninstall that. If you get the problem with the DivX version that is included in the pack, then disable it with the Codec Tweak Tool. Use ffdshow instead to decode DivX video.
    •Disable the "Nero MPEG-1/2/4 & AVC video decoder" filter (NeVideo.ax). You can do that with the Codec Tweak Tool.
    Solution:

    •Disable thumbnail generation in Windows Vista. Open Windows Explorer and click on Organize -> Folder and Search Options -> View -> Enable Always show icons, never thumbnails.

    Friday, April 17, 2009 3:45 PM
  • Cara a mensagem não voltou a aparecer novamente, valeu pela ajuda...

    Estou com mais um pequeno problema, quando insiro um cd ou um dvd pelo (DVD PLAY) ele não faz a leitura do disco, sabe me dizer o que é?

    Já desinstalei todos os codec's imaginavéis que tinha no meu pc, mas até agora nada...

    Será que alguém pode me dar uma ajuda?

    Obrigado!
    Friday, June 05, 2009 5:04 AM
  • amigo tem como desinstalar este componentes sim.,,,excluir as vezes não adianta/

       mas desinstalar sim,,,sem voce tem windows player,,,ou outro,,,ou voce entrar no arquivos,,seus,,

         lá,,,se confunde siste,,,apaga,,,,um como windows,,,player,,,se quer,,,desistalr mometaneamente,

         este codecs são fixados originais,,,do seu player original fabrica,,,então confuda sistema,,,initizando arquivo apanas,,,

         arquivos,,,ou retira aplicativo,,,

          e coloca seu novo player,,,confuda sistema e ele fica inutizado,,,é só conflito,,,de gravações,,limpa tudo retira que baixou

      e instala de novo daquele,,,que gostou,,,,ou conflito pode ser do mesmo que instalou,,,abraço amigo,,,não desista

       

    Monday, December 07, 2009 8:26 AM
  • nero experiencia, maximo 15 dias,,,,depois perde validade,,,ai você instala de novo u compra,,,um novo,,,
       nero e bom sim,,,,mas tem seu tempo quando é de graça,,,passou teste instala de novo desistala aquele,,,
       vai renovando,,,  se tive paciencia fazer isto cada 15 dias    ????ou compra,,,será sempre teu sistema e bom sim tem saber usar,,falou
    Monday, December 07, 2009 8:31 AM
  • puuuuta ki ____ resolvel aqui o meu.

     

     

    kkkkkkkkkkkkkkkk

     

    valew sangue bom..

     

    agradecido !!!

    Monday, March 29, 2010 9:58 PM
  • Caros amigos:

    Meu note book deu esta e outras mensagem de erro quando queria ver algum vídeo MPEG principalmente. De acordo com a dica acima sobre o NERO eu fiz mas pouco tempo depois voltou o problema. Busquei novamente a pasta e eliminei tudo sobre o NERO. Parei de usá-lo. Fiz isso já há uma semana e até agora não ocorreu mais. No caso apareceu estas três mensagens abaixo:

    Windows Media Player parou de Funcionar

    COM Surrogate parou de funcionar

    Processo de Host do Windows (Rundll32) parou de funcionar

     

    C:\Program Files\Common Files\Ahead\DSFilter
    e renomeie o arquivo NeVideo.ax para NeVideo.ax.bkp que o erro deve cessar.

    Não bastou desistalar o nero, no endereço acima eliminei todas as pastas referente ao NERO a parece que resolveu. Agora tenho assistido vídeos MPEG e outros a não tive mais problema.

    Abraços a todos....

    Tuesday, June 15, 2010 1:56 AM
  • Caro colega, verifique se não é o seu firewall o causador do conflito. Se utiliza o KASPERSKY, ele é a causa desse problema que vinha me afetando também. Na verdade é o FIREWALL dele que provoca o erro e trava o micro, que mostra a menssagem: "COM Surrogate não está respondendo". No entanto, para os fãs deste ótimo antivírus, saibam que não é necessário desinstalá-lo para solucionar o problema. Sigam os seguintes passos para resolver o problema e continuarem utilizando o KIS 2011 (quem utiliza outra versão é só tentar localizar os botões e opções que são semelhantes):

    1 - abra a janela do KASPERSKY

    2 - clique em "configurações" no canto superior direito

    3 - na coluna da esq cllique em "firewall"

    4 - no lado dir clique em "configurações..."

    5 - em "regras de aplicativos" observe se mais abaixo está marcado como "TODOS OS APLICATIVOS"

    6 - em "grupos e aplicativos" localize "MICROSOFT"  e clique no "+" a sua frente p/ expandir os itens a ele relacionados e procure pelo aplicativo "COM Surrogate"

    7 - clique com o botão direito do mouse em cima desse item (COM Surrogate) e vá em "Regras de aplicativos..."

    8 - clique na aba "exclusões" e marque todas as opções, clicando em seguida em OK, OK de novo e depois em "aplicar"

    PRONTO! Agora vc pode visualizar sua imagens no Windows e provavelmente executar vídeos sem travamentos.

    Monday, September 13, 2010 4:55 PM
  • Bom galera eu uso o Win 7 32 bits nele não aparece a pasta Ahead, portanto consegui resolver instalando o codec ffdshow e reiniciando o pc.

    Por enquanto esta tudo beleza aqui.

    Pelo que vi isso é um problema comum no win vista e seven 64 porém deu no meu 32. Vai saber?

    Se der o mesmo problema de novo volto avisar, mas por enquanto esta ai a dica.

    Friday, October 22, 2010 3:03 AM
  • ----brother, muito obrigado pela informação, esse erro estava a mexer com a minha tranquilidade....Valeu...thanks
    Wednesday, December 01, 2010 3:57 PM
  • Essa dica do Kapersky foi muito legal. Resolveu o problema aqui. 

    Valeu!!!!!!

    Tuesday, January 25, 2011 5:36 PM
  • Esse procedimento deu super certo, muito obrigado
    Friday, July 22, 2011 3:31 PM
  • Muito bom mano...
    Saturday, December 17, 2011 10:33 PM
  • Comigo solucionou ao renomear o arquivo 

    ffdshow.ax para ffdshow.ax.bkp que está na pasta:

    C:\Program Files\Common Files\Common Share\Filters\FFDShow.

     

    Na mensagem de erro ao exibir detalhes do erro aparece o nome do arquivo problematico, vá até alguma pasta que contenha ele, mas que o nome da pasta esteja  relacionado a "Filtros", no meu caso a pasta "Filters\FFDShow", use a pesquisa do Windows para achar o arquivo na pasta correta.

     

    Espero qu eu tenha ajudado alguém, demorei pra sacar qual era o arquivo correto a renomear.

     

    PS:. não sei quais serão os efeitos colaterais.. provavelmente podem atrapalhar na legenda de algum filme, mas se for o caso creio que é só renomear o arquivo de volta quando necessário .

     

    Abraço.

    • Proposed as answer by Henriruque Sunday, February 05, 2012 5:56 AM
    Sunday, February 05, 2012 5:56 AM