none
WINDOWS 2008 R2 WITH WINDOWS 8 WALLPAPER USING GPO NOT WORKING

    General discussion

  • I have come across a really annoying problem with Active Desktop Wallpaper GPO on Windows 8

    It is set to redirect to a wallpaper which is located in a dir on the server.

    when the user first logs onto a windows 8 PC, the correct background is applied.

    however when I change the background on the server... the user will still get the previous background on the windows 8 computers. If i click personalisation it shows the updated wallpaper but it simply won't refresh to it!

    The only way to get it to work is removing the users local / roaming profile and then the updated wallpaper is displayed!

    the wallpapers work fine on XP and Windows 7 PC's...

    PLS HELP


    SUNIL PATEL SYSTEM ADMINISTRATOR

    Wednesday, June 26, 2013 8:41 AM

All replies

  • Hi,

    I would like to know the details about your wallpaper policy configuration. And based on my understanding, the issue is that the wallpaper policy is applied the first logon, and after the wallpaper policy changed, Windows 8 client could not get updated. 

    As far as I know, wallpaper policy is an user configuration, so it applies to users not computers, for this issue, the computer version make differs, and it seems like that your users use roaming profile. I would like suggest you use a new user account without roaming profile logon to Windows 8 client to check the result.

    In addition, what means by changing the background on the server, do you mean that you change the wallpaper for the policy. If so, run gpupdate/force to force group policy updating.

    Regards,

    Yan Li


    Cataleya Li
    TechNet Community Support

    Friday, June 28, 2013 4:50 AM
    Moderator
  • i am changing wall paper images on server.not policy but its work in all pc with xp and win7.

    i am configuring this in user settings


    SUNIL PATEL SYSTEM ADMINISTRATOR

    Saturday, June 29, 2013 7:10 AM
  • i am replacing another images with same name like wall.jpg

    SUNIL PATEL SYSTEM ADMINISTRATOR

    Saturday, June 29, 2013 7:11 AM
  • I also got the same problem.

    The desktop policy which i deployed from the server 2008 R2 is working fine with the Win 7 Clients.

    Does anyone know how to fix this issue on windows 8 client?
    Wednesday, September 18, 2013 3:36 AM
  • Dear Dishan

    Please set one time wall.jpg and then second time use wall.bmp

    you need to use jpg and .bmp one by one till there is no update from Microsoft

    this is my personal experience and i solved by this trick


    SUNIL PATEL SYSTEM ADMINISTRATOR

    Wednesday, September 18, 2013 3:53 AM
  • I have the same problem, but even you run gpupdate /forcé the wallpaper didnt change, I find some information about update GPO templates with 2012/Windows 8, but i didnt find some procedure to do that ????
    Wednesday, September 18, 2013 6:45 PM
  • Hi! Sunil...

    Thanks for the Tip... I've changed the extention of the wallpaper file to *.bmp and it's really working... hope microsoft will release a Fix soon.. :-)

    Wednesday, October 02, 2013 5:32 AM
  • Buenas tardes:
    El problema radica en el cache que maneja Win 8, 8.1 en la ruta:
    HKCU\Control Panel\Desktop\TranscodedImageCache
    Por alguna razón se mantiene la imagen del fondo de escritorio, se soluciono generando un bat que limpia la cache en el cierre de sesión:
    WallpaperFix.bat
    -----------------------------------------------------------------------------------------------------------
    @echo off
    echo.
    REG ADD "HKCU\Control Panel\Desktop" /f /v "TranscodedImageCache" /t REG_BINARY /d ""
    echo.
    echo Import Complete.
    -----------------------------------------------------------------------------------------------------------
    política:
    Imagen
    Thursday, February 13, 2014 2:22 PM
  • I get this problem.

    I just change the name of the wallpaper each time and that sort of works...sort of however some users still are stuck with the old wallpaper. It must be caching it somewhere in their profile.

    and then I found the post at the bottom of this page:

    created a batch file:

    @echo off
    echo.
    REG ADD "HKCU\Control Panel\Desktop" /f /v "TranscodedImageCache" /t REG_BINARY /d ""
    echo.

    echo Import Complete.

    put that on user log off policy and now it appears to have started working!


    Tuesday, June 24, 2014 2:56 PM
  • Thanks! Worked.

    I had to put it in log off scripts


    Tuesday, June 24, 2014 3:39 PM