none
Unable to save credentials when connecting through an RDP Gateway

    Question

  • I've recently set up an RDP Gateway, but my users are unable to connect to it when the "Remember my password" box is checked on the Enter your credentials screen.

    If the box is unchecked, the connection proceeds without issues.  The same credentials are used for the RD Gateway Server and the RD Session Host and both are running Windows Server 2008 R2.  The clients are all using Windows XP SP3.  We've tried it with Remote Desktop Client versions 6.0.6001.18589 and 6.1.7600.16385, and get the same issue.

    If the box is checked, no errors are displayed, but the Enter your credentials screen is displayed repeatedly.

    Any ideas what could be causing this?

    Tuesday, July 23, 2013 4:09 PM

Answers

  • I found the answer to this eventually.

    The reason the credentials don't save correctly, is because in this version of the RDP client, the program itself doesn't store the credentails, but uses the machine's credentials store instead.  This can be accessed on Windows XP at Control Panel (Classic) -> User Accounts -> Advanced Tab -> Manage Passwords.  Then, add a server entry for the RD Session Host(s) and the RDP Gateway.

    If the Add button is missing from this dialog, the feature is probably locked out by Local Security Policy, or Group Policy.

    • Marked as answer by GBurch1 Thursday, August 01, 2013 3:46 PM
    Thursday, August 01, 2013 3:32 PM

All replies

  • Hi,

    To implement single sign-on functionality in Remote Desktop Services, ensure that you meet the following requirements:

    • You can only use single sign-on for remote connections from a computer running Windows 7, Windows Vista, or Windows XP with Service Pack 3 to an RD Session Host server running Windows Server 2008 R2 or Windows Server 2008. You can also use single sign-on for remote connections from one server running Windows Server 2008 R2 or Windows Server 2008 to another server running Windows Server 2008 R2 or Windows Server 2008.
    • Ensure that the user accounts that are used for logging on have appropriate rights to log on to both the RD Session Host server and the client computer.
    • Your client computer and RD Session Host server must be joined to a domain.

    How to enable Single Sign-On for my Terminal Server connections,pls refer to http://blogs.msdn.com/b/rds/archive/2007/04/19/how-to-enable-single-sign-on-for-my-terminal-server-connections.aspx

    Introducing Web Single Sign-On for RemoteApp and Desktop Connections:http://blogs.msdn.com/b/rds/archive/2009/08/11/introducing-web-single-sign-on-for-remoteapp-and-desktop-connections.aspx

    Regards,

    Clarence

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, July 24, 2013 6:02 AM
  • Hi Clarence,

    Many thanks for the quick response.  Just to clarify the situation, I'm not looking to use the Single Sign On option for connections through the RD Gateway, I'm trying to allow users to save their credentials for their connections.

    Our setup does meet the requirements that you listed at the start:

    • Clients are all Windows XP SP3
    • RD Gateway Server is Windows 2008 R2
    • RD Session Hosts are Windows 2008 R2
    • All machines are part of the same domain (Windows Server 2008 DC's, but Windows 2003 Functional Level)
    Wednesday, July 24, 2013 9:49 AM
  • I found the answer to this eventually.

    The reason the credentials don't save correctly, is because in this version of the RDP client, the program itself doesn't store the credentails, but uses the machine's credentials store instead.  This can be accessed on Windows XP at Control Panel (Classic) -> User Accounts -> Advanced Tab -> Manage Passwords.  Then, add a server entry for the RD Session Host(s) and the RDP Gateway.

    If the Add button is missing from this dialog, the feature is probably locked out by Local Security Policy, or Group Policy.

    • Marked as answer by GBurch1 Thursday, August 01, 2013 3:46 PM
    Thursday, August 01, 2013 3:32 PM