none
Test-OutlookConnectivity WARNING: An unexpected error has occurred and a Watson dump is being generated: Object reference not set to an instance of an object.

    Question

  • Hi All,

    When we do a test-outlookconnectivity -protocol:http the result is a success but then we get the following:

    ClientAccessServer   ServiceEndpoint                               Scenario                            Result  Latency
                                                                                                                      (MS)
    ------------------   ---------------                               --------                            ------  -------
    xxxxxxxxxxxx... xxxxxxxxxxxxxx                 Autodiscover: Web service request.  Success   46.80

    WARNING: An unexpected error has occurred and a Watson dump is being generated: Object reference not set to an instance
     of an object.
    Object reference not set to an instance of an object.
        + CategoryInfo          : NotSpecified: (:) [Test-OutlookConnectivity], NullReferenceException
        + FullyQualifiedErrorId : System.NullReferenceException,Microsoft.Exchange.Monitoring.TestOutlookConnectivityTask

    So it looks like it's not completing successfully.

    I can't find anything on this in particular, and don't really know how to go about solving it - We are fully up to date, Exchange 2010 Sp2 with Rollup 5-v2

    Any help appreciated!

    Wednesday, January 16, 2013 8:50 AM

All replies

  • Hi,

    Can you connect via Outlook Anywhere?

    How about if you run Test-OutlookConnectivity -Protocol:http |FL?

    Besides, please check application event log to see if there is any error recorded when the issue occurs.

    Thanks.


    Fiona Liao
    TechNet Community Support

    Thursday, January 17, 2013 5:56 AM
  • hi,

    I have the same issue also on Exchange 2010 SP2 RU5v2

    I ran your command and get the below

    [PS] C:\Installs\report\Activesync>Test-OutlookConnectivity -Protocol:http |FL


    RunspaceId                  : ebd2c626-1634-40ad-a17e-c9a713d1a62b
    ServiceEndpoint             : autodiscover.domain.com
    Id                          : Autodiscover
    ClientAccessServer          : CAS01.domain.com
    Scenario                    : Autodiscover: Web service request.
    ScenarioDescription         :
    PerformanceCounterName      :
    Result                      : Success
    Error                       :
    UserName                    : Gazpromuk.intra\extest_645e41faa55f4
    StartTime                   : 8/21/2013 4:08:50 PM
    Latency                     : 00:00:00.1250048
    EventType                   : Success
    LatencyInMillisecondsString : 125.00
    Identity                    :
    IsValid                     : True

    WARNING: An unexpected error has occurred and a Watson dump is being generated: Object reference not set to an instance of an object.
    Object reference not set to an instance of an object.
        + CategoryInfo          : NotSpecified: (:) [Test-OutlookConnectivity], NullReferenceException
        + FullyQualifiedErrorId : System.NullReferenceException,Microsoft.Exchange.Monitoring.TestOutlookConnectivityTask

     Any help would be greatly appreciated, I also get random failures of OWA, EAS and web services, very frustrating

    I have no errors in the app event log

    thanks


    Faisal Saleem Windows Systems Analyst 07595781867


    • Edited by Faisaleem Wednesday, August 21, 2013 3:14 PM
    Wednesday, August 21, 2013 3:13 PM