locked
Can not Ping static IP address in Windows 8

    Question

  • I have a small network, a wireless router connected to a switch, and about 10 computers connected with CAT5, and 5 Wireless computers.

    There is a HP1320n laser jet printer connected to the switch, and every computer and ping the printer and print just fine, Except the 1 test laptop that I installed Windows 8 on. The Printer has a static IP address and when the Windows 8 machine tries to ping the printers address I get a reply form my own address with the message Destination Host Unreachable.

    I have tried turning the firewall off, but I am not really sure what else to try.

    As a test I changed one of the other PC's to a static address in the same range, and the Windows 8 machine cannot ping that machine either.

    The router's address is 192.168.1.1 and it dynamically assigns 192.168.1.100 - 120 /255.255.255.0

    The printer is 192.168.1.99 /255.255.255.0 and the other test wired PC is 192.168.1.98 /255.255.255.0 and they have 192.168.1.1 as the default gateway.

    Again all of the other computers running WinXp/Vista/ connected by Wire or WiFi can connect or ping these static address just fine.

    Is there something new in Windows 8 that I am overlooking?

    Tuesday, March 13, 2012 5:54 AM

All replies

  • Try update your Windows and install latest network driver.
    • Marked as answer by Niki HanModerator Monday, March 19, 2012 2:20 AM
    • Unmarked as answer by drabney Wednesday, March 21, 2012 10:16 PM
    Tuesday, March 13, 2012 12:05 PM
  • Thank you for the advice, however I still have the same issue. In addition to updating the driver, I have also tried using the RJ45 connection, and a USB WiFi adapter. Again the Windows 8 machine cannot connect to or ping any device on the network if that device has a static address. Which is kind of funny because it can connect if the address is assigned by DHCP....even the exact same address i.e. 192.168.1.100 works if it was assigned dynamically but will fail every time if the address is static.

    Again this worked fine in Windows Vista, and still works if I boot the system with a Knoppix disc.

    Wednesday, March 21, 2012 10:25 PM
  • Your installation is connected to a home group, what is  your current network settings. Your network information shows you , that you connect to a public , or private network. Look this settings , and check your advanced setting to see if you try to connect with home group credentials instead of  username ,password.

    P Velachoutakos

    • Proposed as answer by gnulinux Thursday, November 15, 2012 2:06 PM
    Friday, May 11, 2012 11:33 PM
  • Your installation is connected to a home group, what is  your current network settings. Your network information shows you , that you connect to a public , or private network. Look this settings , and check your advanced setting to see if you try to connect with home group credentials instead of  username ,password.

    P Velachoutakos

    You are right. I change the network group from public to home, and now it is just fine. Think you. 

    • Edited by gnulinux Thursday, November 15, 2012 2:10 PM
    Thursday, November 15, 2012 2:10 PM