none
RDS \ VDI Gateway Server and URL query?

    Question

  • Hi All

    I have VDI working successfully internally and have now created the RDS Gateway Server (all on Windows Server 2012) in the DMZ for remote client access.  I've created the CAP and RAP policies, and have also registered the required web, however when attempting connection I get presented with the default IIS 7.0 web site splash page. 

    How do I connect the RDS GW Servers services to the IIS URL, so that users connecting are presented with the VDI web login page?

    Any thoughts much appreciated!

    Saturday, October 26, 2013 10:01 AM

All replies

  • Hi,

    You will need to enter "/rdweb" to load the RDS page.

    https://siteaddress.com/rdweb

    Saturday, October 26, 2013 7:23 PM
  • Thanks Ryan

    Modified the URL as suggested, however now get the IE 404 'File not found' error?

    On installing the GW Server I don't recall being prompted for what URL it is linked to, how is it linked to an external URL address? or is this configured on the internal infrastructure and the GW Server is fed this information in some manner? 

    Monday, October 28, 2013 9:12 AM
  • I think i understand what you are trying to achieve now, Are you trying to connect to the gateway via the web interface.

    There are two ways to connect via the Gateway, one is to open the remote desktop connection client and configure the gateway and the other is to connect to the RDweb site and select the Remote App or desktop you want. If users are external they will be connected through the gateway.

    have a look at https://social.technet.microsoft.com/wiki/contents/articles/10974.deploying-and-configuring-rd-gateway-in-windows-server-2012.aspx 

    Monday, October 28, 2013 12:42 PM
  • Thanks Ryan

    Ive noticed that when reading the GW Server, the 'RD Gateway External FQDN' does not match the URL we are looking to specify for users to connect too.  Does this need to match?

    Also when reviewing the RDS deployment settings I notice that the Certificate for the GW Server is showing as Untrusted an in 'Error ' state.  I had used a self-signed certificate, I presume this needs to be classed as healthy and working for users to be presented with the RDWeb login page?

    Ive also updated the default IIS site on the GW Servers 'Host Header' with the URL we are looking for users to connect to.  But still getting the 404 'File not found' error.

    Any thoughts much appreciated.

    Tuesday, October 29, 2013 5:14 PM
  • You will need to use a trusted certificate to allow external users access through the gateway.

    Have a look at the following article to assist you with the configuration of certificates. 

    SSO & Certificates:

    http://ryanmangansitblog.wordpress.com/2013/03/10/configuring-rds-2012-certificates-and-sso/ 

    RDS Gateway Deployment:

    http://ryanmangansitblog.wordpress.com/2013/03/27/deploying-remote-desktop-gateway-rds-2012/

    Wednesday, October 30, 2013 4:06 PM
  • Thanks Ryan

    So self-signed certs wont work? and as such the 'Gateway' needs to be classed as being 'Trusted'.  With that in mind from the (very useful) blogs I have a further query, weve registered the url to be remote.companyname.com, does the certification need to match this or the actual FQDN of the RD Gateway Server? Or can we use a cert that includes both by using 'Subject Alternative Name' as part of the cert?

    Finally, I notice that the Default website has /rpc beneath it, rather than /rdweb, is this normal \ expected?

    Thanks again for thoughts.

    Wednesday, October 30, 2013 7:38 PM