none
MDT 2012 - U1 on Win8: "Please install PowerShell..."

    Question

  • I built a new Windows 8 machine and then installed MDT 2012-U1 and the Windows 8 ADK.  All of these are the final RTM releases and not betas or release candidates.

    When I start MDT I get the error:

    “Initialization Error PowerShell is required to use the Deployment Workbench.  Please install PowerShell then relaunch Deployment Workbench.”

    I've tried reinstalling MDT and uninstalling the ADK but I still get the error.

    I've uninstalled both and then installed just MDT by itself but still get the error.

    Monday, August 20, 2012 11:10 AM

All replies

  • i seem to remember that you need powershell 3.0 for MDT to work on windows 8
    Monday, August 20, 2012 12:01 PM
  • MDT should work with Powershell 2.0 or 3.0, 3.0 should already be installed as part of Windows 8. Make sure it has not been uninstalled, or try to install powershell 2.0 (or reinstall powershell 3.0)

    David Sebban | Nelite North America | http://www.nelite.com/community/b/dsebban/default.aspx

    Monday, August 20, 2012 4:52 PM
  • Please install appropriate powershell version in windows8.
    Monday, August 20, 2012 7:24 PM
  • Had the same problem, simply see System requirements of MDT 2012 update1

    Supported operating systems: Windows 7, Windows Server 2003 R2 Enterprise Edition (32-Bit x86), Windows Server 2003 R2 Standard Edition (32-bit x86), Windows Server 2008 R2, Windows Server 2008 Service Pack 2, Windows Thin PC, Windows Vista Service Pack 2, Windows XP Service Pack 3

    • Supported operating systems the MDT can deploy: Windows 8, Windows 7, Windows Server 2012, Windows Server 2008 R2, Windows Vista Service Pack 2, Windows Server 2008 Service Pack 2, Windows Server 2003 R2, Windows XP Service Pack 3, Windows Embedded PoSReady 7, Windows Thin PC
      * MDT 2012 can be installed on Windows 8 or Windows Server 2012, used with the Windows 8 Assessment and Deployment Kit (ADK). ADK usage is required for Windows 8 and Windows Server 2012 deployments.

    http://www.microsoft.com/en-us/download/details.aspx?id=25175#system-requirements

    So, you can deloy Win8, but MDT 2012 is NOT supported to run on Win8 :-|
    I build myself with hyper-V a Win7/WAIK/ADK/MDT2012U1 and use this only for MDT work...not the easiest way, but a way to get busy ;-)

    Lets wait for update 2....

    Hope this helps

    Iggy




    my Windows 7 Deployment Blog http://www.eyeonwin.com


    • Edited by IPCtec Wednesday, September 26, 2012 9:43 AM
    • Proposed as answer by IPCtec Wednesday, September 26, 2012 10:53 AM
    Wednesday, September 26, 2012 9:41 AM
  •  

    The reason I was seeing this was because of the following validation exception,

     some file cannot be loaded because the execution of scripts is disabled on this system. For more information, see about_Execution_Policies at http://go.microsoft.com/fwlink/?LinkID=135170..

    you can run this cmdlet in windows powershell as adminsitrator

     Set-ExecutionPolicy RemoteSigned -Scope CurrentUser

    • Proposed as answer by xingyuan Thursday, December 20, 2012 3:19 AM
    Thursday, December 20, 2012 3:18 AM
  •  

    The reason I was seeing this was because of the following validation exception,

     some file cannot be loaded because the execution of scripts is disabled on this system. For more information, see about_Execution_Policies at http://go.microsoft.com/fwlink/?LinkID=135170..

    you can run this cmdlet in windows powershell as adminsitrator

     Set-ExecutionPolicy RemoteSigned -Scope CurrentUser

    Works for me.

    The problems occurs after I installed MDT/ADK on a drive(D,E,F...) other than C.

    Friday, July 12, 2013 4:13 PM
  • Has anybody gotten this to work installed to a drive different than the C: Drive?  Also we have a policy of allsigned in the domain.  Is that going to cause me problems?
    Thursday, January 09, 2014 1:35 PM