none
SSIS performance counter

    Question

  • Hi,

    I cant view SSIS performance counters when clicked perfmon.exe add counter list, I tried to install counters using  following command

    lodctr c:\"program files"\"microsoft sql server"\100\dts\binn\perf-DTSPipeline100DTSPERF.INI

    I got its already installed, but still not able to view the performance counter SSISDTSPIPELINE and Instance counters.

    Regards,

    Navin

    lodctr c:\"program files"\"microsoft sql server"\100\dts\binn\perf-DTSPipeline100DTSPERF.INI
    
    

    Navin.D http://dnavin.wordpress.com

    Thursday, January 16, 2014 11:37 AM

Answers

  • Hi Navin,

    The issue is usually related to the registry keys. Here, I suggest that you do as follows:

    1. Click Start, click Run, type regedit, and then click OK.

    2. In Registry Editor, locate the following registry entry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MsDtsServer100\Performance

    3. Check whether the value of the PerIniFile registry entry is perf-MsDtsServer100DTSSVCPERF.INI.

    4. Click Start, click Run, type cmd, and then click OK.

    5. Copy (or type) the following commands, and then press ENTER after each line:

    cd C :\Program Files\Microsoft SQL Server\100\DTS\Binn
    unlodctr MsDtsServer100
    lodctr /T:perf-MsDtsServer100DTSSVCPERF.INI

    6. Run the following command lines separately to stop and start the remote registry

    net stop "Remote Registry"
    net start "Remote Registry"

    7. Force a WMI synchronization using   winmgmt /resyncperfctr "<<PID>>" where PID is the process id of the WinPriv.exe

    For more detailed information, please see the following blog:
    http://blogs.msdn.com/b/psssql/archive/2009/03/03/troubleshooting-sql-server-2005-2008-performance-counter-collection-problems.aspx 

    Regards,
    Mike Yin

    If you have any feedback on our support, please click here


    Mike Yin
    TechNet Community Support


    Tuesday, January 21, 2014 8:45 AM

All replies

  • It must be because you are not a full Admin on the machine, just a power user. The counters come already with the SSIS installation.

    Arthur My Blog

    Thursday, January 16, 2014 3:07 PM
  • I am admin on the server.


    Navin.D http://dnavin.wordpress.com

    Friday, January 17, 2014 2:31 AM
  • Hi Navin,

    The issue is usually related to the registry keys. Here, I suggest that you do as follows:

    1. Click Start, click Run, type regedit, and then click OK.

    2. In Registry Editor, locate the following registry entry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MsDtsServer100\Performance

    3. Check whether the value of the PerIniFile registry entry is perf-MsDtsServer100DTSSVCPERF.INI.

    4. Click Start, click Run, type cmd, and then click OK.

    5. Copy (or type) the following commands, and then press ENTER after each line:

    cd C :\Program Files\Microsoft SQL Server\100\DTS\Binn
    unlodctr MsDtsServer100
    lodctr /T:perf-MsDtsServer100DTSSVCPERF.INI

    6. Run the following command lines separately to stop and start the remote registry

    net stop "Remote Registry"
    net start "Remote Registry"

    7. Force a WMI synchronization using   winmgmt /resyncperfctr "<<PID>>" where PID is the process id of the WinPriv.exe

    For more detailed information, please see the following blog:
    http://blogs.msdn.com/b/psssql/archive/2009/03/03/troubleshooting-sql-server-2005-2008-performance-counter-collection-problems.aspx 

    Regards,
    Mike Yin

    If you have any feedback on our support, please click here


    Mike Yin
    TechNet Community Support


    Tuesday, January 21, 2014 8:45 AM