none
No me deja instalar ningún paquet de Net Framework

    Question

  • Acabo de volver a instalar xp sp3, y todo normal, lo único que no me deja es instalar a través del windows update los distintos tipos de paquetes de Net Framework, sólo me dan errores de instalación, como que el directorio temp no es el correcto, que no se pueden escribir los archivos de registro, etc.
    ¿Alguien me puede ayudar?
    Gracias
    Monday, January 18, 2010 6:30 PM

Answers

  • Hola de nuevo, nada, he intentado con la aplicación que me ha indicado la página y he realizado todos los pasos y sigue igual, siempre me da el mismo error, formatearé y beré si se me soluciona el tema, ya que tengo aplicaciones que necesitan el 3.5.

    Muchas gracias por todo, aunque seguiré investigando porque esto es la primera vez que me pasa y me gustaría resolverlo para cuando se nos dé otro caso.
    Antes de formatear, probá lo siguiente:

    Clic botón derecho sobre Mi PC --> Propiedades. Andá a la pestaña "Opciones avanzadas" y hacé clic sobre "Variables de entorno". Allí editá las variables TMP y TEMP y especificá en ellas alguna ruta válida (por ejemplo, podés crear antes una carpeta llamada "Temporales" en el disco C: y especificar la ruta completa en las variables). Por las dudas, cambiá tanto las variables de usuario como de sistema.

    Reiniciá el equipo y fijate si el error continúa.

    Saludos!
    Friday, January 22, 2010 9:40 PM

All replies

  • Hola,

    En Agregar o quitar programas, en el Panel de Control, aparece listada alguna versión de .NET Framework? En ese caso, eliminala y luego probá descargando los instaladores y ejecutándolos manualmente. En este link podés descargar el .NET Framework 3.5 (que incluye las versiones 2.0 SP1 y 3.0 SP1): http://download.microsoft.com/download/6/0/f/60fc5854-3cb8-4892-b6db-bd4f42510f28/dotnetfx35.exe

    Comentanos luego cómo te fue.

    Saludos!
    Monday, January 18, 2010 9:27 PM
  • Nada, sigue exactamente igual, cuando trato de instalar cualquier paquete de net framework, comienza a descomprimir y se para la instalación y me coloca algo así como "El directorio temporal 'C:\.........\temp_dir\' no es un directorio válido. El programa de instalación no puede continuar". Ya estoy deseperado, pues me lanza siempre que tengo esas instalaciones pendientes y no me deja instalarlas.

    Un saludo
    Tuesday, January 19, 2010 10:47 AM
  • Nada, sigue exactamente igual, cuando trato de instalar cualquier paquete de net framework, comienza a descomprimir y se para la instalación y me coloca algo así como "El directorio temporal 'C:\.........\temp_dir\' no es un directorio válido. El programa de instalación no puede continuar". Ya estoy deseperado, pues me lanza siempre que tengo esas instalaciones pendientes y no me deja instalarlas.

    Un saludo

    Podrías mostrarnos toda la captura del mensaje completo de error?

    Sergio Calderón | Microsoft Student Partner
    Tuesday, January 19, 2010 11:51 AM
  • La verdad es que ahora no dispongo del pc para mostrarlo, pero es una ventana con la leyenda que os he descrito:


    "El directorio temporal 'C:\.........\temp_dir\' no es un directorio válido. El programa de instalación no puede continuar".


    Donde he puesto los puntos suspensivos van una serie larga de letras y números aleatorios, cada vez que intentaba una instalación cambiaban.
    ¿Con esto em podeis ayudar?

    Gracias
    Tuesday, January 19, 2010 4:51 PM
  • Hola Malolo68,

    Qué tal? Espero que todo vaya bien :)

    Encontrarás una posible solución a tu inconveniente en la siguiente nota técnica: http://support.microsoft.com/kb/923100/es

    Si encuentras algún problema al realizar los pasos indicados, coméntalo aquí y con gusto te ayudaremos.

    Un saludo,
    Átilla Arruda - Microsoft Corporation
    Thursday, January 21, 2010 6:26 PM
  • Hola de nuevo, nada, he intentado con la aplicación que me ha indicado la página y he realizado todos los pasos y sigue igual, siempre me da el mismo error, formatearé y beré si se me soluciona el tema, ya que tengo aplicaciones que necesitan el 3.5.

    Muchas gracias por todo, aunque seguiré investigando porque esto es la primera vez que me pasa y me gustaría resolverlo para cuando se nos dé otro caso.
    Friday, January 22, 2010 6:02 PM
  • Hola de nuevo, nada, he intentado con la aplicación que me ha indicado la página y he realizado todos los pasos y sigue igual, siempre me da el mismo error, formatearé y beré si se me soluciona el tema, ya que tengo aplicaciones que necesitan el 3.5.

    Muchas gracias por todo, aunque seguiré investigando porque esto es la primera vez que me pasa y me gustaría resolverlo para cuando se nos dé otro caso.
    Antes de formatear, probá lo siguiente:

    Clic botón derecho sobre Mi PC --> Propiedades. Andá a la pestaña "Opciones avanzadas" y hacé clic sobre "Variables de entorno". Allí editá las variables TMP y TEMP y especificá en ellas alguna ruta válida (por ejemplo, podés crear antes una carpeta llamada "Temporales" en el disco C: y especificar la ruta completa en las variables). Por las dudas, cambiá tanto las variables de usuario como de sistema.

    Reiniciá el equipo y fijate si el error continúa.

    Saludos!
    Friday, January 22, 2010 9:40 PM
  • Efectivamente, el error continua, he tenido que formatear, he realizado una instalación limpia con otro cd original de xp y no me ha dado ningún problema, se han instalado todas las actualizaciones a través del windows update, por lo que la conclusión que he sacado, es que el xp que instalaba, no lo hacía correctamente.
    de todas formas muchas gracias a todos por la ayuda.
    Un saludo
    Wednesday, January 27, 2010 8:39 PM
  • Efectivamente, el error continua, he tenido que formatear, he realizado una instalación limpia con otro cd original de xp y no me ha dado ningún problema, se han instalado todas las actualizaciones a través del windows update, por lo que la conclusión que he sacado, es que el xp que instalaba, no lo hacía correctamente.
    de todas formas muchas gracias a todos por la ayuda.
    Un saludo


    Amigo el mismo error me acaba de pasar, dure como 7 horas tratando de solucionar el problema del Framew... la solucion te la dio Pablo Maximiliano Sanchez el moderador, cuando te dijo que hicieras esto:

    entra a Mi PC --> Propiedades. Andá a la pestaña "Opciones avanzadas" y hacé clic sobre "Variables de entorno". Allí editá las variables TMP y TEMP y especificá en ellas alguna ruta válida (por ejemplo, podés crear antes una carpeta llamada "Temporales" en el disco C: y especificar la ruta completa en las variables). Por las dudas, cambiá tanto las variables de usuario como de sistema.

    Pero en ves de ir al paso donde dice que editaras las variables TMP y TEMP lo que tenias que hacer era borrarlas y listo sin mas ni menos luego reiniciar y solucion al problema.

    de esa forma solucione el asunto...

    Gracias amigo..

    Friday, August 19, 2011 5:36 AM
  • Muchas gracias por tu respuesta me sirvio de mucho

    lo que hice fue entrar Mi PC --> Propiedades. Andá a la pestaña "Opciones avanzadas" y hacé clic sobre "Variables de entorno" y lo deje de esta forma

    Friday, August 30, 2013 3:01 PM