none
The way SharePoint open office documents will differ if the user try to open them from the document library directly, or if users try to open the document from the search result page.

    Question

  • I have a document library where I have uploaded an excel sheet to it. Now If I click on the excel sheet directly from the document library page , I will get the following error ““The webpage cannot be displayed””. While if I do a search and I open the excel sheet from the search result page , it will open the excel sheet using the excel services inside the browser !!.

    So can anyone advice on this ?

    Also if I have a PowerPoint document , and I try to open it from the document library I will get the following error “The webpage cannot be displayed” , and the URL will be prefix with the following “ms-powerpoint:ofv|u|”. while if i do a search and i open the PowerPoint from the search result page i will be prompted to either open or save the document ? So why SharePoint is reacting totally different when trying to open document library items from the document library Or from the search result page?

    Wednesday, September 18, 2013 3:49 PM

All replies

  • Hi,

    Could you please check the default open behavior of document from Library Settings -> Advanced Settings?

    Thanks


    Thanks, Suneetha

    Wednesday, September 18, 2013 5:31 PM
  • Hi,

    Could you please check the default open behavior of document from Library Settings -> Advanced Settings?

    Thanks


    Thanks, Suneetha


    thanks for the reply. for the document library setting i set the "Opening Documents in the Browser" =     Open in the client application.
    And For the Web application general setting i set the "Browser File Handling" =     Permissive.
    Wednesday, September 18, 2013 8:56 PM
  • Hi,

    The behavior in the document library could be probably because of the Documents handling setting. Please try setting it to default behavior (Open in browser) as i hear from you that the default behavior is to open from browser.


    Thanks, Suneetha

    Thursday, September 19, 2013 6:08 AM
  • Hi,

    The behavior in the document library could be probably because of the Documents handling setting. Please try setting it to default behavior (Open in browser) as i hear from you that the default behavior is to open from browser.


    Thanks, Suneetha


    But the default behavior is open in the browser which i do not need, i need to prompt the user with a download dialog and ask the user to open , or save the document. any way i changed the document library setting to be "Use the server default (Open in the browser) " ,, and as i was expecting it did not solve the issue... what do u think ?

    • Edited by johnjohn123 Thursday, September 19, 2013 8:59 AM
    Thursday, September 19, 2013 8:45 AM
  • Hi,

    The behavior in the document library could be probably because of the Documents handling setting. Please try setting it to default behavior (Open in browser) as i hear from you that the default behavior is to open from browser.


    Thanks, Suneetha


    Currently I have set the following;-
    1. On the library advance setting :- I define  “Open in the client application”
    2. On the web application setting:- I define stricked for Browser File Handling

    And I have noted if I delete the browser cache and I access the document , then I will be prompted with the download dialog. but if I re-click on the same document I will be redirected to the
    The webpage cannot be displayed
    And the ms-powerpoint:ofv|u| will be added to the beginning of the URL. So could this be a caching problem ?
    Thursday, September 19, 2013 7:26 PM
  • Inside my machine i have office 2010 , and visio 2013. so i have disabled the SharePoint foundation support inside visio 2013 and thing s is working fine when accessing the SharePoint from my machine. but i am afraid of the fact that i should ask each user to do the same step inside their machine ? Anyone can advice eon this ?
    Friday, September 20, 2013 12:37 PM