none
office 2010 error

    Question

  • how to fix this error??

    every opening office word 2010 prompt this massage 

    ________________________________

     

    This error usually occurs because of macro security settings. If you know that the macro comes from a source that you trust, you can change your macro security settings to allow you to enable the macro.

    If the file opens in Protected View, click Enable Editing, and then click Enable Content. Editing functions are restored and the active content, including macros, will run. This file is now trusted; security prompts will no longer appear unless the file is opened on another computer.

    Change macro settings

    You can change macro security settings in the Trust Center. However, if you work in an organization, your system administrator might have changed the default settings to prevent anyone from changing any settings. Use the following instructions to change macro settings for your Office programs.

    Click the File tab. The Backstage view appears.

    Under Help, click Options. The Options dialog appears.

    Click Trust Center, then click Trust Center Settings.

    In the Trust Center click Macro Settings.

    Macro settings explained:

    Disable all macros without notification - Macros and security alerts about macros are disabled. If there are files with unsigned macros that you do trust, you can put those files into a trusted location. Files in trusted locations run without being checked by the File Validation process. 

    Disable all macros with notification - Macros are disabled, but security alerts appear if there are macros present. Enable macros on a case-by-case basis. 

    Disable all macros except digitally signed macros - Macros are disabled, but security alerts appear if there are macros present. However, if the macro is digitally signed by a trusted publisher, the macro runs if you have trusted the publisher. If you have not trusted the publisher, you are notified to enable the signed macro and trust the publisher.

    Enable all macros (not recommended, potentially dangerous code can run) - All macros run. This setting makes your computer vulnerable to potentially malicious code.

    Trust access to the VBA project object model - Disallow or allow programmatic access to the Microsoft Visual Basic for Applications (VBA) object model from an automation client. This security option is for code written to automate an Office program and manipulate the VBA environment and object model. It is a per-user and per-application setting, and denies access by default, hindering unauthorized programs from building harmful self-replicating code. For automation clients to access the VBA object model, the user running the code must grant access. To turn on access, select the check box.

    Note   Microsoft Publisher and Access have no Trust access to the VBA project object model option.

    This error might also occur for the following reasons:

    The certificate of trust that is attached to the macro is invalid. Unless you are certain that the macro is safe, it is recommended that you not trust or run the macro. Use the following instructions to view valid or invalid digital signatures.

    Click the File tab. The Backstage view opens.

    Click the Info tab.

    Under Signed Document, click View Signatures.

    The Signatures pane appears with a list of valid signatures.

    For more information, in the Signatures pane, click the down-arrow next to each signature.

    The certificate is no longer trusted, was revoked by the issuing authority, or is damaged. Unless you are certain that the macro is safe, it is recommended that you not trust or run the macro.

    Visual Basic for Applications (VBA) is not installed on your computer. In this case, no VBA macro can be run, regardless of whether the macro has a valid certificate of trust. You or your administrator may have chosen not to install VBA, or the version of Microsoft Office that you are using may not install VBA by default. If your version of Microsoft Office does not provide VBA as an installable feature, you can upgrade to a version that provides VBA support.

    If you are unable to change the security settings, it is possible that another program has locked the security settings. Close all Microsoft Office programs, then restart your program and change the security settings.

     


    sasanka
    Sunday, February 13, 2011 3:29 PM

Answers

  • Hi,

    This issue might be caused by the .COM add-in for ScanSoft PDF Professional 4. Go to File -> Options-> Trust Center-> Trust Center Settings-> Add-Ins, disable the plug-in, and restarted Word, the macro warnings should be disappeared.

    If that does not help, check if the issue occurs in safe mode. Press the Ctrl key when you start Word.

    If the problem does not occur in the safe mode, this issue might be related to some third-party add-ins in the Office program, we can try to disable them one by one to isolate the root cause.


    Best Regards,

    Sally Tang

    • Marked as answer by Sally Tang Friday, February 18, 2011 2:37 AM
    Wednesday, February 16, 2011 9:10 AM

All replies

  • Hi,

    This issue might be caused by the .COM add-in for ScanSoft PDF Professional 4. Go to File -> Options-> Trust Center-> Trust Center Settings-> Add-Ins, disable the plug-in, and restarted Word, the macro warnings should be disappeared.

    If that does not help, check if the issue occurs in safe mode. Press the Ctrl key when you start Word.

    If the problem does not occur in the safe mode, this issue might be related to some third-party add-ins in the Office program, we can try to disable them one by one to isolate the root cause.


    Best Regards,

    Sally Tang

    • Marked as answer by Sally Tang Friday, February 18, 2011 2:37 AM
    Wednesday, February 16, 2011 9:10 AM
  • thank you very much. In add ins I have made the correction you recommended and those interruptions stopped.
    • Proposed as answer by SST_20133 Tuesday, October 02, 2012 9:13 AM
    Monday, April 09, 2012 3:12 AM