none
wmpnetwk.exe utilise constament 50% de mon processeur

    Question

  • Bonsoir,

    Alors mon problème à commencer tôt ce matin, sans aucune raison apparente.
    Le processus wmpnetwk.exe occupe 50% du processeur et 400Mo de ma ram.
    Ce qui affecte énormément les performances de mon ordinateur.
    Désactivé ce processus résoudrait le problème, sauf que j'utilise le serveur multimédia DLNA sur ma console de salon, donc ce processus est vital pour mon système.
    Si vous aviez des idées ce serait sympa.

    Merci de votre attention.
    Tuesday, June 09, 2009 9:16 PM

Answers

  • bonjour,

    ce probleme vient d'un des fichiers que WMP essaye d'indexer, je m'expplique:

    le processus de streaming a besoin de récupérer les meta données des fichiers pour les streamer par la suite, quand ce processus occupe une portion importante de cpu pendant trop longtemp c'est en fait qu'il n'arrive pas à trouver ces données pour un ou plusieurs fichiers et qu'il re tente indéfiniement de les analyser, en résultant une utilisation excessive du CPU.

    essaye de voir quels nouveaux fichiers as-tu mis dans ta bibliotheque multimedia (avi, mp3, divx, xvid..) avant que ce probleme d'apparaisse. tu arretes ensuite le service, tu déplace ces fichiers sur un disque externe, tu redémarres le service et là il devrait tourner normalement en dessous des 5% CPU. puis tu peux re-importer tes fichiers petit à petit afin de trouver lequel a des informations illisibles pour le re-ripper.


    cordialement,


    PierrE.

    Http://www.redkaffe.com - Recherche poste en region Aixoise :)
    • Proposed as answer by Pierre JOUBERT Wednesday, June 10, 2009 5:26 AM
    • Marked as answer by Clavus Wednesday, June 10, 2009 6:15 AM
    Wednesday, June 10, 2009 5:26 AM
  • bonjour Clavus,

    je pense qu'il dit chercher à comprendre/trouver ou sont passés les fichiers qu'il a dans sa DB de référence...il doit donc parser les possibles endroits de stockage pour re-indexer sa base de données.
    tu peux la 'reseter', l faut que tu ailles dans: "C:\Documents and Settings\{your user name}\Local Data\Application Data\Microsoft\Media Player" et (aprés avoir activé l'affichage des fichiers cachés et fichiers systemes) eliminer tout ce qui s'y trouve.

    redémarre ton pc et lance WMP il va recréer sa base proprement.

    Cordialment,

    PierrE.

    Http://www.redkaffe.com - Recherche poste Consultant/Formateur en region PACA ou IDF
    • Marked as answer by Clavus Sunday, June 14, 2009 9:42 AM
    Sunday, June 14, 2009 9:19 AM

All replies

  • bonjour,

    ce probleme vient d'un des fichiers que WMP essaye d'indexer, je m'expplique:

    le processus de streaming a besoin de récupérer les meta données des fichiers pour les streamer par la suite, quand ce processus occupe une portion importante de cpu pendant trop longtemp c'est en fait qu'il n'arrive pas à trouver ces données pour un ou plusieurs fichiers et qu'il re tente indéfiniement de les analyser, en résultant une utilisation excessive du CPU.

    essaye de voir quels nouveaux fichiers as-tu mis dans ta bibliotheque multimedia (avi, mp3, divx, xvid..) avant que ce probleme d'apparaisse. tu arretes ensuite le service, tu déplace ces fichiers sur un disque externe, tu redémarres le service et là il devrait tourner normalement en dessous des 5% CPU. puis tu peux re-importer tes fichiers petit à petit afin de trouver lequel a des informations illisibles pour le re-ripper.


    cordialement,


    PierrE.

    Http://www.redkaffe.com - Recherche poste en region Aixoise :)
    • Proposed as answer by Pierre JOUBERT Wednesday, June 10, 2009 5:26 AM
    • Marked as answer by Clavus Wednesday, June 10, 2009 6:15 AM
    Wednesday, June 10, 2009 5:26 AM
  • Bonjour,

    D'accord je vois mieux d'où vient le problème, je vais donc vérifier ma bibliothèque multimédia sur le champ, et voir le résultat.

    Merci pour cette réponse, et bonne journée.
    Wednesday, June 10, 2009 5:41 AM
  • bonjour,

    aucun probleme, on est tous là pour ça :)

    tiens nous informés,

    PierrE.

    Http://www.redkaffe.com - Recherche poste en region Aixoise :)
    Wednesday, June 10, 2009 7:13 AM
  • Bonjour,

    Il se trouve qu'après avoir vidé totalement ma bibliothèque multimédia, WMP lui même c'est mis à occupé une énorme part de mon CPU 90% minimum, il a l'air de chercher je ne sais quoi...
    J'ai fais une Impr. écran si ça peut donné une idée.

    Sunday, June 14, 2009 4:51 AM
  • bonjour Clavus,

    je pense qu'il dit chercher à comprendre/trouver ou sont passés les fichiers qu'il a dans sa DB de référence...il doit donc parser les possibles endroits de stockage pour re-indexer sa base de données.
    tu peux la 'reseter', l faut que tu ailles dans: "C:\Documents and Settings\{your user name}\Local Data\Application Data\Microsoft\Media Player" et (aprés avoir activé l'affichage des fichiers cachés et fichiers systemes) eliminer tout ce qui s'y trouve.

    redémarre ton pc et lance WMP il va recréer sa base proprement.

    Cordialment,

    PierrE.

    Http://www.redkaffe.com - Recherche poste Consultant/Formateur en region PACA ou IDF
    • Marked as answer by Clavus Sunday, June 14, 2009 9:42 AM
    Sunday, June 14, 2009 9:19 AM
  • Merci pour cette aide Pierre,

    j'ai fais la manipulation WMP fonctionne normalement.
    J'ai réimporter la plus part de mes fichiers, wmpnetwk semble bien se porter pour l'instant.
    Je vais donc importer le reste de mes vidéos petit à petit pour identifier le fautif.

    Encore merci, et bon dimanche.
    Sunday, June 14, 2009 9:55 AM
  • bon dimanche à toi également,


    PierrE.

    Http://www.redkaffe.com - Recherche poste Consultant/Formateur en region PACA ou IDF
    Sunday, June 14, 2009 9:58 AM