locked
Hyper-V Virtual Switch (Windows 8)

    Question

  • I have installed Hyper-V on Windows 8 (Release Preview) to setup test labs, but when I install a External Switch (From Switch Manager)and it replaces my Physical network adapter with a virtual one but my Guest OS still can not connect to the internet but my Host OS can!

    Am I missing some thing?

    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk

    Sunday, June 17, 2012 10:15 PM

Answers

  • I don't know, but it usually is a driver problem.
     
    I rarely use sleep though, so maybe someone else has more experience
    with it.
     
    You might try asking about it in the W8itprovirt forum as that's
    dedicated to Hyper-V...
     

    Bob Comer - Microsoft MVP Virtual Machine
    • Marked as answer by o0MattE0o Friday, June 29, 2012 9:19 PM
    Sunday, June 24, 2012 11:23 AM

All replies

  • Any help apriciated, would like to test Server 2012 but can't without a Guest network connection...
    Also my PC only has one Physical Network Adapter?

    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk

    Monday, June 18, 2012 10:55 AM
  • Hi,

    If you want to let the guest virtual machines connect to internet, you need to connect them to the External Virtual Switch which you created. Then these virtual machines will get IP address from your LAN.

    When you said the virtual machines couldn’t connect to the internet, please check whether these virtual machines have proper IP addresses and related settings configured properly.

    You can also check the following Hyper-V networking guides.

    How does basic networking work in Hyper-V?
    http://blogs.technet.com/jhoward/archive/2008/06/16/how-does-basic-networking-work-in-hyper-v.aspx

    Hyper-V: What are the uses for different types of virtual networks?
    http://blogs.technet.com/jhoward/archive/2008/06/17/hyper-v-what-are-the-uses-for-different-types-of-virtual-networks.aspx

    • Proposed as answer by Murat Demirkiran Monday, June 18, 2012 8:57 PM
    • Marked as answer by o0MattE0o Monday, June 18, 2012 9:08 PM
    • Unmarked as answer by o0MattE0o Monday, June 18, 2012 9:26 PM
    • Unproposed as answer by o0MattE0o Thursday, June 21, 2012 10:04 PM
    Monday, June 18, 2012 1:28 PM
  • Its working ok now but I did create a Internal switch first then an external  and attaché the two too the Virtual Server.

    But I only have external now and all is ok ...

    OK I just added a second Virtual NIC (Internal) and I loss internet connection on the VM? going to try Private!


    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk





    • Edited by o0MattE0o Monday, June 18, 2012 9:27 PM
    Monday, June 18, 2012 9:09 PM
  • Hi,

    If you want to let the virtual machines connect to internet, the easiest way should be connect them to the External Virtual Network. The virtual machines connect to the Internal Virtual Network can only communicate with each other and the Hyper-V host machine they are running on.

    For more information, please check the guides in my last reply.

    Tuesday, June 19, 2012 5:48 AM

  • Got it working, but I had to do the follow which is a little long winded compared to VMWare: -

    1. Create a Private Virtual Switch (this will not do any thing to your physical network card)
    2. Create a External Virtual Switch (this will take over your physical network card)
    3. Add two network cards to your VM
      a. 1st Network card as Private
      b. 2nd Network card as External
    4. Start VM
    5. Allow to install
    6. Change Private Network card to disconnect
    7. Rename network cards (helps in future)
      a. Allow External to Connect to the internet
      b. I also disabled IPv6,
    8. Re-Connect Private Network

    P.S.
    I don't know why it would not allow me to just add two virtual switches in any order and just run as I was expecting but I posted this just so any one else with some issues can try this as well?


    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk

    Thursday, June 21, 2012 10:03 PM
  • Just say thanks for you help but have corrected the issue!

    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk

    Thursday, June 21, 2012 10:05 PM
  • Not working again :( strange ?????


    Virtual Switch's: -
     


    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk


    • Edited by o0MattE0o Friday, June 22, 2012 9:04 PM
    Friday, June 22, 2012 8:48 PM
  • Virtual Server: -

    Host Computer: -

    and yes I can get to the internet on the host running hyper-v as I'm using it to post this?


    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk


    • Edited by o0MattE0o Friday, June 22, 2012 9:07 PM
    Friday, June 22, 2012 9:06 PM
  • My Virtual Server has the following network cards
    External Connection
    192.168.0.3

    Private Connection
    10.10.10.1

    Now according to Hyper-V a : -

    External Switch
    Creates a virtual switch that binds to the physical network adapter so that virtual machines can access a physical network

    Private Switch
    Creates a virtual switch that can be used only by the virtual machines that run on this physical computer?

    I still do not have any network connection but can some one please explain this?
    Image is of my router displaying an ip address of 10.10.10.3 which is the IP Address of the Private network switch?
    And it is also showing the IP Address of the Server but still not getting any internet connection?

    I would class this as a show stopper bug? (can some one please help)


    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk

    Saturday, June 23, 2012 6:19 PM
  • Your router shouldn't be able to see the private network ip address at
    all, so that 10.10.10.3 shouldn't be there so it looks like a
    configuration error of some kind, maybe somehow you have the private
    switch and external switch connections in the VM switched, though I
    can't tell, not enough info.
     
    You wouldn't expect to get any internet connectivity on the private
    switch, nor the 10.10.10.3 IP address, it's not in the same subnet as
    your router.
     

    Bob Comer - Microsoft MVP Virtual Machine
    Saturday, June 23, 2012 6:59 PM
  • All I have done is the following: -

    Server

    1. Open Hyper-V Manager
    2. Click "Virtual Switch Manager..."
    3. Select "External"
    4. Click "Create Virtual Switch"
    5. Rename switch to "External Virtual Switch"
    6. Choose default settings for External Network
    7. Click "Apply"
      Wait for host to regain internet connection, and test that internet is still working on host
    8. Click "New virtual network switch"
    9. Select "Private"
    10. Click "Create Virtual Switch"
    11. Rename switch to "Private Virtual Switch"
    12. Choose default settings for Private Network
    13. Click "Apply"
    14. Click "OK"

    Virtual Machine (repeated for all)

    1. select a chosen "Virtual Machine"
    2. Click "Settings..."
    3. select "Network Adapter"
    4. Under "Virtual switch choose"
      "External Virtual Switch"
    5. Select "Add Hardware"
    6. Select "Network Adapter"
    7. Click "Add"
    8. Under "Virtual switch choose"
      "Private Virtual Switch"
    9. Click "Apply"
    10. Click "OK"

    Start the virtual machine and I just don't get any internet connection?


    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk

    Saturday, June 23, 2012 8:31 PM
  • How are you configuring things inside the VM?
     
    It could be as simple as a gateway problem.  you have to be real
    careful on multihomed machines, only one NIC, the external one, should
    have a gateway address, the other one it should be blank.
     

    Bob Comer - Microsoft MVP Virtual Machine
    Saturday, June 23, 2012 9:27 PM
  • Thanks I give that a try and give my External card a static gateway address...

    My VM Setup

    Network Card 1

    External

    Obtain an IP Address automatically

    192.168.0.*

    Obtain DNS sever Address automatically

    -

    Network Card 2

    Private

    IP Address

    10.0.0.1

    Subnet mask

    255.255.255.0

    Default gateway

    Empty

    Preferred DNS Server

    10.0.0.1 / 127.0.0.1


    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk

    Saturday, June 23, 2012 9:40 PM
  • That looks okay, but try switching the two. configure NIC 2 as the
    external one and NIC 1 as internal.
     

    Bob Comer - Microsoft MVP Virtual Machine
    Saturday, June 23, 2012 10:02 PM
  • Ok worked out what the issue is :(

    If the host goes to sleep you will no longer be able to use the network card? even If you try and restart the computer host or VM even swapping the network cards around or adding new ones dose not help?
    Also the network card dose not want to keep the default physical gateway, I'm going to try and recreate the virtual switch and see if turning the host off will create the same issue?

    *I know in live environment's your servers don't go to sleep but hopefully the turning the host of dose not have the same affect?


    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk

    Saturday, June 23, 2012 10:56 PM
  • "If the host goes to sleep you will no longer be able to use the
    network card? even If you try and restart the computer host or VM even
    swapping the network cards around or adding new ones dose not help?"
     
    Normally that wouldn't happen, but some drivers have a problem waking
    back up after sleep.
     
    "Also the network card dose not want to keep the default physical
    gateway, I'm going to try and recreate the virtual switch and see if
    turning the host off will create the same issue?"
     
    It shouldn't, I do that all the time.
     

    Bob Comer - Microsoft MVP Virtual Machine
    Saturday, June 23, 2012 11:33 PM
  • I have a look and see if there is some updated drives the only thing is when my PC dose wake up the host is ok with internet?

    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk

    Sunday, June 24, 2012 8:34 AM
  • I don't know, but it usually is a driver problem.
     
    I rarely use sleep though, so maybe someone else has more experience
    with it.
     
    You might try asking about it in the W8itprovirt forum as that's
    dedicated to Hyper-V...
     

    Bob Comer - Microsoft MVP Virtual Machine
    • Marked as answer by o0MattE0o Friday, June 29, 2012 9:19 PM
    Sunday, June 24, 2012 11:23 AM
  • I'm still testing, because I have not had much time between work

    But looks like downgrading to Windows 7 drivers and not the ones windows 8 installed is working, I have not lost connection yet...

    Thanks for you help Bob Comer

    Technical Beta Tester || Matthew John Earley BSc (hons) || www.o0MattE0o.myby.co.uk


    • Edited by o0MattE0o Friday, June 29, 2012 9:22 PM
    Friday, June 29, 2012 9:21 PM
  • Just after add the External Virtual Switch on the Network Connections Disable and  Enable it again and configure if you use a manual config or just leave bye DHCP.

    Friday, November 16, 2012 8:31 PM
  • I confirm that, in my case, it was a network driver issue.  

    I rolled back the driver (marvell NIC) provided by the publisher to the drivers included in Windows 8 DVD ... and it has solved the issue.

    Luc

    Sunday, December 09, 2012 5:45 AM
  • after reading all these forums, this worked! FFS! (the disable and re-enable after creating)

    Thanks though. stupid windows 8

    Tuesday, April 30, 2013 10:14 AM