none
WCF-Custom adapter and error " Security requirements are not satisfied" error

    Question

  • We are trying to call a secure third party web site. We are getting the below error message now.

    "Security requirements are not satisfied because the security header is not present in the incoming message."

    We are using BizTalk Server 2009 and WCF-Custom adapter. When we call the service

     (ASMX), we are attaching the username and password with the SOAP message. However, we keep getting this error message. Can anyone please help me out as early as possible? Thanks.

    Tuesday, February 07, 2012 9:17 PM

All replies

  • In order to troubleshoot this a few things are missing:

    - Can you post the metadata of the service?

    - Enable WCF tracing, it will give more detailed information about what is exaclty missing...

    - Can you get a correct sample message that the service expects? In that way we can compare your message with the sample.


    If this post answers your quenstion, please mark it as such. If this post is helpful, click 'Vote as helpful'.

    Wednesday, February 08, 2012 6:36 AM
  • I am not sure my employer allow me to post the service information in public.  I will update you on this soon. Can you please provide me information how I can pass username and password when I use "basicHttpBinding" port. I am using the SOAP.Username and SOAP.Password biztalk message context properties to attach the user name and password. However, I am getting the below error,

    "Security requirements are not satisfied because the security header is not present in the incoming message."

    Wednesday, February 08, 2012 3:58 PM
  • Do you have a stack trace?

    Do you know if this message is coming from WCF or BizTalk or from the destination service? It is difficult to point you in the right direction without identifying which component is throwing your error.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline

    Wednesday, February 08, 2012 11:27 PM
  • Hi Ashok,

    Hope this and this links can help you to fix the issue.


    ___________________________________________________________
    If this is helpful or answers your question - please mark accordingly.



    Raj, http://rajwebjunky.blogspot.com

    Monday, February 13, 2012 10:06 AM