none
Enable Microphone on Windows server 2008

    Question

  • Can anyone tell how to enable Microphone on Windows server 2008 ?

    I have tried lot of ways:-

    • On your server, modify the following registry setting:  HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp
      fDisableAudioCapture     REG_DWORD     0x00000000
    • I don't see any Enable Audio Recording re-direction rdp settings on the server group policy.

    Is there a way to enable microphone on Windows Server 2008?

    Tuesday, September 24, 2013 1:59 AM

Answers

  • Make all update... but if the RDP client does not allow it, i tend to think you can't.

    As audio redirection is by default only to hear the sound, not to record.

    From there I see assumption like mine, that it's not a Windows 2008 option, but was integrated into 2008R2.

    Thanks 


    MCP | MCTS - Exchange 2007, Configuring | Member of TechNet Wiki Community Council | French Moderator on TechNet Wiki (Translation Widget)

    Thursday, September 26, 2013 1:43 AM

All replies

  • This one may help.

    http://blogs.technet.com/b/aviraj/archive/2010/08/06/windows-7-amp-windows-server-2008-r2-case-of-missing-playback-recording-disabled-devices.aspx

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Tuesday, September 24, 2013 2:05 AM
  • When i go to Start –> Control Panel –> Sound, click on Recording, I see no audio devices are installed. Even if i click Show disconnected devices and Disable devices, I don't see any microphone option.

    I've managed to install the playback devices, so i can listen to music from the server,

    I am using windows server 2008 R2 Standard 32-bit operating system.


    • Edited by Koz0s Tuesday, September 24, 2013 2:41 AM
    Tuesday, September 24, 2013 2:30 AM
  • 2008 R2 is 64 bit only.

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Tuesday, September 24, 2013 3:04 AM
  • This one may also help.

    http://www.win2008r2workstation.com/enable-sound/

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Tuesday, September 24, 2013 3:08 AM
  • hi Dave,

    Thanks for the reply.

    i think i have windows server 2008 32 bit. I can hear the sound on the server, sound devices are detected but microphone is not detected.

    I have started the Windows Audio Service, had enabled "Allow audio redirection" in group policy.

    I have unchecked "Audio" under RDP-TCP. That is, start > run > tsconfig.msc > rdp-tcp > properties > client settings > uncheck audio > ok

    I don't see any option for Microphone. I have found a way to enable microphone in Windows Server 2008 R2 but not able to find it for Windows Server 2008.

    Is there a way to enable recording o microphone in windows Server 2008? o you can enable only in Windows Server 2008 R2?


    Tuesday, September 24, 2013 2:31 PM
  • I think it should work. Have you verified the operating system with the hardware manufacturer?

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Wednesday, September 25, 2013 1:49 AM
  • Hi

    I just found that; Configure Audio Recording Redirection on an RD Session Host Server, but it's tagged win2008 r2, not 2008...

    Updated the RDP client ? if yes you are dependent of that in my own opinion, so if the GPO does not apply and the RDP client does not bring the device... I would try on r2 to rule that out.


    MCP | MCTS - Exchange 2007, Configuring | Member of TechNet Wiki Community Council | French Moderator on TechNet Wiki (Translation Widget)

    Wednesday, September 25, 2013 2:14 AM
  • I think it should work. Have you verified the operating system with the hardware manufacturer?

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    I verified with the hardware manufacturer, it is Windows Server 2008. It will work if i can find "allow Recording redirection" rdp setting in the Group policy which i am not able to find. I have even enabled"Record audio on remote computer" in local resources under RDP settings. But, I still don't see any microphone detected in Sound Recording.
    Wednesday, September 25, 2013 5:15 AM
  • Hi

    I just found that; Configure Audio Recording Redirection on an RD Session Host Server, but it's tagged win2008 r2, not 2008...

    Updated the RDP client ? if yes you are dependent of that in my own opinion, so if the GPO does not apply and the RDP client does not bring the device... I would try on r2 to rule that out.


    MCP | MCTS - Exchange 2007, Configuring | Member of TechNet Wiki Community Council | French Moderator on TechNet Wiki (Translation Widget)


    Yes, I have tried the process mentioned by you. But on Windows server 2008, I get only "Allow audio redirection" option. There is no option for microphone or recording.
    Wednesday, September 25, 2013 5:17 AM
  • Make all update... but if the RDP client does not allow it, i tend to think you can't.

    As audio redirection is by default only to hear the sound, not to record.

    From there I see assumption like mine, that it's not a Windows 2008 option, but was integrated into 2008R2.

    Thanks 


    MCP | MCTS - Exchange 2007, Configuring | Member of TechNet Wiki Community Council | French Moderator on TechNet Wiki (Translation Widget)

    Thursday, September 26, 2013 1:43 AM