locked
proxy settings for metro apps

    Question

  • If I try to connect to any website or online service with a metro app it fails due to proxy settings.  If I open up the desktop version of IE it reads my proxy settings from group policy and connects properly.  However, the metro IE or other metro apps fail to connect to the internet unless I go to the desktop IE and uncheck the "use a proxy server for your LAN" checkbox.  Is there a way to sync proxy settings between metro apps and the desktop?
    Wednesday, February 29, 2012 5:51 PM

All replies

  • Try the Windows 7 method to manually modify Registry to add a global proxy settings for your system.

    http://support.microsoft.com/kb/819961/en-us


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    • Proposed as answer by Dmitry Kolchev Saturday, August 25, 2012 12:38 AM
    Wednesday, February 29, 2012 6:07 PM
  • Thanks for the reply, but that's exactly what my group policy is already doing.  It modifies these keys so the metro apps should be reading from those values
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    Wednesday, February 29, 2012 6:17 PM
  • Hello,

    We have the exact same problem (already there in Windows 8 DP).

    The registry keys didn't change anything, they are already there (gpo).

    Marc.

    Thursday, March 01, 2012 12:23 PM
  • I have the exact same issue. Desktop ie10 works great with the proxy settings, but any metro app can't get to internet. The Store comes up saying I am not connected to internet.

    When I set it to not use a proxy and gave it a masquerade on the firewall, they all worked. Where do we set the proxy for the metro part of Windows 8?


    All the registry keys mentioned in this thread are present and correct on my box.
    • Edited by Woobanger1 Friday, March 02, 2012 12:04 PM
    Friday, March 02, 2012 12:03 PM
  • Exactly same issue here...
    Friday, March 02, 2012 3:30 PM
  • Same issue here
    Saturday, March 03, 2012 1:51 PM
  • same issue here too
    Saturday, March 03, 2012 9:42 PM
  • MSFT Team, could you confirm this issue will be handled and referenced as a bug ?

    Thanks

    Monday, March 05, 2012 9:37 AM
  • Same issue here too.
    Monday, March 05, 2012 10:45 AM
  • Same here
    Monday, March 05, 2012 11:08 AM
  • Global Proxy Settings are something that really should have been considered before now, good ol' Microsoft.
    Monday, March 05, 2012 2:08 PM
  • I have the same problem with our Forefront TMG. The problem seems to be authentication (NTLM?). If I use a proxy with authentication all metro apps fail. Some even ask for credentials for the proxy, but even then fail. If I use a proxy without authentication it works.

    PS: The global proxy settings can be set from Internet Options.

    Monday, March 05, 2012 2:14 PM
  • I have the same issue
    Tuesday, March 06, 2012 8:43 AM
  • I'm having almost the same issue.

    When I open the metro version of IE10 I'm prompted for user credentials which when entered allow me to browse to the internet (there are some intranet issues probably due to bypass local address settings not working as expected).

    Once authenticated against the metro version I am able to continue to browse using he metro version of IE10 however if I open any metro application that requires a web connection I see the same app failure. If I disable proxy and use an unathenticated gateway I am able to use the metro applications and IE10 without an issue.

    Windows 8 is currently running on a Samsung Series 7 slate, joined to a domain and is successfuly working on wifi using 802.1x without any issues. Most of our Windows 7 policies are working without an issue except for integarted proxy authentication for metro applications.

    Question,

    1. How do I enable integrated proxy authentication for metro style applications?

    Tuesday, March 06, 2012 9:57 AM
  • Hi Guys,

    Could you please try the below ?

    1- Open "Local Group Policy Editor"

    2-Navigate to "Computer Configuration - Administrative Templates - Network Isolation"

    3-Enable "Proxy Definitions Are Authorative" and "Subnet definitions are authorative"

    Try again Metro Internet Explorer... should be ok for this one... but not sure for other apps


    Tuesday, March 06, 2012 10:38 AM
  • MSFT Team, could you confirm this issue will be handled and referenced as a bug ?

    Thanks


    I am tracking this internally. I am trying to determine if there is a common proxy configuration that is causing this as the majority of reports I have had appear to be from behind a corporate proxy.

    If possible could you provide further detail on the proxy configuration you are using, authentication requirements, WPAD usage etc.

    Thanks

    Andrew


    Tuesday, March 06, 2012 11:47 AM
  • Hi Andrew,

    I'm using Internet Explorer Maintenance under a user based policy to configure the proxy server address, port number (8080), exceptions for internal addresses and enable the bypass proxy server for local
    addresses feature.

    I'm not using any automatic configuration scripts and "Enable Integrated Windows Authentication" is enabled.

    We aren't having the issue with the desktop version of IE10.

    Please let me know if you need any further information.

    Cheers,

    Matt


    Tuesday, March 06, 2012 12:00 PM
  • Microsoft Forefront TMG 2010, authentication against corporate AD required, usually done automatically (NTLM/Kerberos?), no WPAD (done through group policies).

    I've set the proxy setting through the Internet Settings. Proxy described above works for IE10 desktop, but not for any Metro apps including IE10. Some ask for proxy credentials, but still fail if supplied. Proxy not requiring authentication works for both.

    Tuesday, March 06, 2012 12:06 PM
  • Microsoft ISA server, corporate AD authentification - no WPAD

    By default:

    IE10 desktop OK

    IE10 Metro --> No connectivity

    Metro Apps --> No connectivity

    Enabling "Proxy Definitions Are Authorative" and "Subnet definitions are authorative" in policy editor :

    IE10 desktop OK

    IE10 Metro --> manual authentication recquired (password has to be typed 2 times...) --> Internet access OK

    Metro Apps --> No connectivity (no authentication window)

    Tuesday, March 06, 2012 12:33 PM
  • Proxy set manually via group policy.  Using a Smoothwall firewall (if that matters) with NTLM identification, non-transparent authentication
    Tuesday, March 06, 2012 2:09 PM
  • Hi there.

    Christophe P's advice didn't help for me, but this did. It's the setting below the ones that he mentioned

    1- Open "Local Group Policy Editor"

    2-Navigate to "Computer Configuration - Administrative Templates - Network Isolation"

    3- Open "Internet Proxy Servers for Metro Style Apps" and set the value to your proxy server address like 172.16.0.1:8080.

    All apps like People, IE Metro Works fine now. If you already have an URL in IE, type in a new one, and it works. NOT with the referes button or F5


    Kobberoe

    • Proposed as answer by Adam Lonsdale Wednesday, March 14, 2012 11:25 AM
    Tuesday, March 06, 2012 2:14 PM
  • Hi Kobberoe,

    Great to hear that's working for you now.

    Does your proxy recquire authentication ?

    Thanks

    Tuesday, March 06, 2012 2:26 PM
  • Hi there.

    Christophe P's advice didn't help for me, but this did. It's the setting below the ones that he mentioned

    1- Open "Local Group Policy Editor"

    2-Navigate to "Computer Configuration - Administrative Templates - Network Isolation"

    3- Open "Internet Proxy Servers for Metro Style Apps" and set the value to your proxy server address like 172.16.0.1:8080.

    All apps like People, IE Metro Works fine now. If you already have an URL in IE, type in a new one, and it works. NOT with the referes button or F5


    Kobberoe


    Thanks for testing this. If others could validate whether this has a positive effect it would be great.
    Tuesday, March 06, 2012 2:27 PM
  • That's not working for me...

    Tuesday, March 06, 2012 2:32 PM
  • I managed to reproduce this issue in my test lab with TMG, no authentication and the Win 8 client in not a domain member.  Configured IE proxy settings and Internet access was possible from Desktop but not Metro Apps.  Ran this command:

    netsh winhttp import proxy source=ie

    Then rebooted.

    Metro Apps can now use the proxy as expected.

    Cheers, Steve

    ____________________

    EDIT: I should add that if UAC is on then you need to run netsh from an elevated prompt

    Tuesday, March 06, 2012 2:38 PM
  • That's not working for me...

    It does seem like authentication is playing a part here.

    Could you possibly take a network trace and make it available to me? Feel free to email:

    andrew 'dot' willows 'at' microsoft 'dot' com

    Tuesday, March 06, 2012 2:42 PM
  • This looked promising, but it did not work for my environment.  Store, Finance, Weather...none of them connect after updating this group policy setting, running gpupdate /force, and giving the ole' reboot
    Tuesday, March 06, 2012 2:55 PM
  • Hi Andrew

    I agree with your assessment.  I've just enabled authentication on the TMG and Metro Apps can no longer connect while IE is still working. 

    Tuesday, March 06, 2012 2:59 PM
  • I managed to reproduce this issue in my test lab with TMG, no authentication and the Win 8 client in not a domain member.  Configured IE proxy settings and Internet access was possible from Desktop but not Metro Apps.  Ran this command:

    netsh winhttp import proxy source=ie

    Then rebooted.

    Metro Apps can now use the proxy as expected.

    Cheers, Steve

    ____________________

    EDIT: I should add that if UAC is on then you need to run netsh from an elevated prompt

    This didn't do it in my environment either.  Also, not sure if this started up after issuing this command, but I noticed my WiFi icon shows "limited" connectivity even though I can browse all intranet and internet websites.  If I open the Weather metro app it has an icon of my WiFi with a red X, like I have no internet access or my NIC is disabled.  For giggles I plugged in a wired connection and now my WiFi shows as "connected" and my wired connection as "limited".  Again, I can browse all websites from the desktop


    • Edited by sallenk Tuesday, March 06, 2012 5:52 PM
    Tuesday, March 06, 2012 3:09 PM
  • Quick update - I have reached out to the product group for assistance with this and am awaiting their input. If you are running the Comsumer Preview as a Hyper-V guest please be aware of the following known issue:

    http://social.technet.microsoft.com/Forums/en-US/w8itprogeneral/thread/c40c1cec-5a7d-4f07-978f-edb1b35ecae1
    Tuesday, March 06, 2012 4:39 PM
  • No Hyper-V here... physical machine
    Tuesday, March 06, 2012 4:46 PM
  • To confirm the issue is definately with proxy authentication. Has anyone made any progress?

    Wednesday, March 07, 2012 7:48 AM
  • I've sent a capture and some TMG logs over to Andrew so just waiting on the outcome of that.

    Cheers, Steve

    Wednesday, March 07, 2012 9:09 AM
  • Capture sent too... waiting feedback now
    Wednesday, March 07, 2012 9:48 AM
  • Thanks Christophe and Steve, I have your logs and am currently reviewing. As soon as I have an update I will post it here.

    * UPDATE * - I now have a local repro here testing with the Weather App. With proxy authentication enabled we see an error:

    "This page failed to load."

    "There was a problem. Please Try again"

    Wednesday, March 07, 2012 10:20 AM
  • Any update?

    Cheers

    Thursday, March 08, 2012 8:39 AM
  • The product group investigated this yesterday and we believe this to be an issue with Network Isolation. Tommybeck posted a solution above which I would like everyone to try and feedback on their results (we often see similar problems with different underlying causes so this may not work for everyone).

    1- Open "Local Group Policy Editor"

    2- Navigate to "Computer Configuration - Administrative Templates - Network Isolation"

    3- Open "Internet Proxy Servers for Metro Style Apps" and set the value to your proxy server address like 172.16.0.1:8080.

    We shouldn't need to amend other settings in here for now.

    I would encourage a restart here, although this shouldn't be necessary but during testing it may help clear down any cached data that could interfere.

    Thanks

    Andrew

    • Proposed as answer by Karim Mustafa Tuesday, March 13, 2012 1:32 PM
    Thursday, March 08, 2012 9:01 AM
  • Still same issue here.

    According the network trace, the issue is not about catching the proxy. Metro apps communicate with proxy but get access denied. It seems it's all about authentication.

    Thursday, March 08, 2012 9:30 AM
  • Still same issue here.

    According the network trace, the issue is not about catching the proxy. Metro apps communicate with proxy but get access denied. It seems it's all about authentication.


    Thanks Christophe, I am still working with the product group as I also believe there could be multiple underlying causes which are displaying similar end results. Hopefully the suggestion above will help some users but this thread will remain open until we resolve your problem.
    Thursday, March 08, 2012 9:34 AM
  • Hi Andrew

    No change here and my logs confirm Christophe's assessment.  The proxy is being contacted but it is denying part of the request.  More interestingly the username is being received at the TMG (in my case) but access is being denied - possibly something wrong with the transmission of the password or domain authentication.

    Cheers, Steve

    Thursday, March 08, 2012 9:44 AM
  • The product group investigated this yesterday and we believe this to be an issue with Network Isolation. Tommybeck posted a solution above which I would like everyone to try and feedback on their results (we often see similar problems with different underlying causes so this may not work for everyone).

    1- Open "Local Group Policy Editor"

    2- Navigate to "Computer Configuration - Administrative Templates - Network Isolation"

    3- Open "Internet Proxy Servers for Metro Style Apps" and set the value to your proxy server address like 172.16.0.1:8080.

    We shouldn't need to amend other settings in here for now.

    I would encourage a restart here, although this shouldn't be necessary but during testing it may help clear down any cached data that could interfere.

    Thanks

    Andrew

    Tried it, including restart. Does not work for me. I strongly beleive my problem lies with authentication. I tried TMG with and without authantication and it only fails with authentication.
    Thursday, March 08, 2012 10:35 AM
  • Thanks for taking the time to test this. I will update this thread again once I have discussed further with the development team. Apologies for the time this is taking to resolve.
    Thursday, March 08, 2012 10:40 AM
  • Behind an Authenticating NTLM Microsoft ISA

    Machine Domain Joined

    Desktop IE working no problem

    Metro IE and other App intially not working

    Made alteration "Internet Proxy Server for Metro Style Apps" and rebooted (Important) only

    Metro IE now works

    Other Apps still do not if that helps

    Monday, March 12, 2012 1:26 PM
  • Still same issue. HTTP/1.1 407 Proxy Authentication Required (Access is denied).

    Tuesday, March 13, 2012 10:22 PM
  • I changed the local group policy settings and restarted my PC. I note that I am logging in with a windows live ID. I had to open IE on the Dekstop to authenticate with the proxy, and checked "Remember my settings". All metro Apps now work fine for me.
    Wednesday, March 14, 2012 11:24 AM
  • I changed the local group policy settings and restarted my PC. I note that I am logging in with a windows live ID. I had to open IE on the Dekstop to authenticate with the proxy, and checked "Remember my settings". All metro Apps now work fine for me.

    Thanks Adam, we are still looking at this internally and the steps you have provided about are one workaround the product group have found to work.

    If others could test Adam's steps and update this thread it would help with pinpointing the underlying cause of this.

    Thanks to everyone that is investing time in helping to resolve this problem.

    Andrew

    Wednesday, March 14, 2012 1:23 PM
  • Hello, and thanks for the help.

    I have a similar problem here. I'm behind a proxy at work. Desktop firefox and IE are online but I can't use any metro APP. I'm stuck on the loading application monochrome fullscreen with the application's icon.

    On a side note, I'm not logged on a Live ID account. Its a local account (no AD).


    I'd like to add some elements (not sure if it's relevant)

    - I can't connect to windows update (desktop mode) either (error code 8024402F)

    - When I try to link my account with Live ID (using metro configuration app), I get a proxy authent prompt, my Live ID account is found (password asked), but the final account update does not work, I get an error (code 0xd000005e).

    - I tried to create a new account with my Live ID, but I can't get past the login screen (not connected to internet)

    it's as if some pages are able to use the proxy, and other are not.


    I tried Adam's steps, changing the local group policy, reboot, and authent with IE desktop, it didn't change anything (no metro app, can't update account, and not connected on the login screen)

    edit : Enabling "Proxy Definitions Are Authorative" and "Subnet definitions are authorative" like some suggestion here didn't work either

    Wednesday, March 14, 2012 3:22 PM
  • I'm seeing the same issue with TMG authentication. Watching the TMG logs from a second machine while trying to launch metro apps results in authentication errors.

    When I first installed Win8 I also found that Desktop IE wasn't transparently passing NTLM creds to internal websites such as SharePoint and custom IIS apps. Double checked that sites were being identified as 'intranet' and IE was configured to automatically login in that zone. At least IE prompted for creds however, metro apps just seems to give up and die. As an aside this seems very strange, I would expect the app to start and then say no network connection available. Similarly I don't understand while a simple app like 'Reader' can't start, why wouldn't that work offline?

    There really needs to be a central, system wide place to affect such a change. If it has to stay in 'Internet Options' so be it, but that needs to cover metro as well and Windows needs to take care of passing the NTLM login or at least have a common login prompt with the option to save the creds for use with all apps.

    Wednesday, March 14, 2012 3:54 PM
  • I changed the local group policy settings and restarted my PC. I note that I am logging in with a windows live ID. I had to open IE on the Dekstop to authenticate with the proxy, and checked "Remember my settings". All metro Apps now work fine for me.

    Thanks Adam, we are still looking at this internally and the steps you have provided about are one workaround the product group have found to work.

    If others could test Adam's steps and update this thread it would help with pinpointing the underlying cause of this.

    Thanks to everyone that is investing time in helping to resolve this problem.

    Andrew

    FYI, I tried these steps and it didn't work in my environment.  I was never prompted to authenticate with the proxy with desktop IE (as I shouldn't)

    My computer is joined to a domain and using NTLM proxy, but not Microsoft proxy

    Thursday, March 15, 2012 4:09 PM
  • I'm also having the same issue. Tried the steps outlined above and no joy. IE Metro works but not the Metro Apps.

    Friday, March 16, 2012 12:13 PM
  • Here is the FTMG error I see when running a trace:

    Denied Connection, Status: 12209 Forefront TMG requires authorization to fulfil the request. Access to the Web Proxy filter is denied.

    Friday, March 16, 2012 12:19 PM
  • I am having similar issues here. Windows 8 CP, upgraded from Windows 7 Enterprise (64-bit) directly on hardware.

    The network here uses McAfee Webwasher proxy servers which don't require authentication. I manually configured the proxy servers (IP and port) in the desktop IE settings. Now desktop IE connects to the internet succesfully, and the metro IE does as well. However, other Metro apps like Mail, Maps, Store, Weather and so on do not connect to the internet. Bing Maps even stated "No network connection found" which of course isn't true.

    I am using a wired connection, logging on locally with a Microsoft account.


    MdeB - Microsoft Partner - MCITP & Computer Enthousiast

    Thursday, March 22, 2012 11:32 AM
  • Hi M,

    There are a couple of things we are tracking in this Forum thread.  It appears since your Proxy does not require authentication that the following should work.

    Did you try this:

    Edit Group Policy

    Go to this node:

    Local Computer Policy,  Computer Configuration, Administrative Templates, Network, Network Isolation

    There are several settings, if using your proxy to go outside your network you can edit:

    'Internet proxy Servers for Metro style apps' enable it and set the Domain Proxies field to your proxy and port: myproxy:8080

    Depending on your network configuration you may or may not need to set 'Proxy definitions are authoritative' to enable.

    -Jeff


    Jeff Sanders (MSFT)

    Thursday, March 22, 2012 12:02 PM
  • Hi Jeff,

    I tried this just now.

    Setting the first policy with the value of the proxy server (IP:port), didn't help. I double-checked if the policy was applied by running gpupdate, followed by rsop.msc. I also closed all Metro apps using Task Manager, in order to try "reset" things.

    Because this didn't work, I set the next policy, 'Proxy definitions are authoritative', also followed by gpupdate and rsop.msc to check it had applied. It did, but Metro apps still cannot connect to the internet.

    Just be sure I also tested if my desktop IE and Metro IE still had internet access after making these changes, and both do. Well, after some more testing I found out that the "Photos" App can load pictures from my Skydrive. However, the Photos app is the only Metro App that has internet connection. Weather, Maps, People, Store and so on still can not connect.


    MdeB - Microsoft Partner - MCITP & Computer Enthousiast

    Thursday, March 22, 2012 1:31 PM
  • M,

    Could you contact me here please:  http://blogs.msdn.microsoft.com/jpsanders/contact.aspx

    -Jeff


    Jeff Sanders (MSFT)

    Thursday, March 22, 2012 1:42 PM
  • Jeff, Andrew,

    Any update ?

    Did you fill internally this issue as a bug - known issue ?

    Or is it still in an earlier state ?

    Thanks !

    Monday, March 26, 2012 2:33 PM
  • Hi Christophe,

    I have filed bugs for the applications that do not handle proxy authentication correctly.

    -Jeff


    Jeff Sanders (MSFT)

    Monday, March 26, 2012 2:50 PM
  • Great. 

    Is there a way to follow the progress ?

    Thanks for your reactivity

    Monday, March 26, 2012 3:01 PM
  • No unfortunately there is not.  Keep an alert on this forum thread and I will post any updates here.

    -Jeff


    Jeff Sanders (MSFT)

    Monday, March 26, 2012 3:09 PM
  • No unfortunately there is not.  Keep an alert on this forum thread and I will post any updates here.

    -Jeff


    Jeff Sanders (MSFT)

    thanks, I'll keep an eye on this thread ;)
    Tuesday, March 27, 2012 1:28 PM
  • Hi Andy,

    This (kind of) worked for me.  IE fails initially but subsequent URLs seem to work in Metro mode.

    For me the App Store fails, but this could be a restriction by our firewall, which I need to investigate.

    Regards,

    Graham

    Friday, March 30, 2012 2:15 PM
  • Hmmm

    No news, one month.

    I'm afraid this will be solved in the next builds, so no workaround for that built.

    I can reproduce same problems with an Astaro / Sophos authenticated proxy.

    All metro apps seems to "forget" the authentication :

    looking in the live logs when I run a metro app (weather) I see :

    no activity in the proxy at all

    a Default drop rule fot the https traffic to 65.55.192.186:443

    And that's all...


    Laurent Gébeau http://www.toutwindows.com http://twitter.com/mtoo

    Monday, April 23, 2012 11:00 AM
  • Hi Laurent,

    The application teams have been working on fixing the bugs in their applications.  Not all apps fail given the workarounds but some still do.  Weather, Finance and Maps are known to have no workaround and they are being looked at.

    In the mean time, if these apps are critical for your enterprise you can have exceptions created in your proxy for these.

    -Jeff


    Jeff Sanders (MSFT)

    Wednesday, April 25, 2012 1:38 PM
  • Hi,

    I' m wondering if there is any more news on proxy authentication in metro view. We run a system which requires proxy settings and authentication to gain access to the internet. I have changed the settings in the GP editor as recommended in earlier posts, however while i get get onto IE from the desktop view, Metro IE just replies with 'Internet Explorer cannot display the webpage'.

    It does seem to me metro IE is having issues with authentication as i tested this on a side of our network which does not require authentication (only proxy settings) and i could browse with no issues.

    The windows store app will not work with or without authentication.

    Jo

    Tuesday, May 29, 2012 3:52 AM
  • Hopefully it'll be fixed in next Windows 8 build named "Release Preview"

    Jeff to confirm ?

    Wednesday, May 30, 2012 9:14 AM
  • Just tested the new release and still experiencing the same problem with metro app connectivity when using a proxy with NTLM auth.

    Oh dear. Was really hoping this was going to be fixed - can anyone else confirm they are still having the same issue?

    Friday, June 01, 2012 7:53 AM
  • Still fails for me using the Weather app.  Metro IE now prompts for a password and then connects.  My test machine is currently not domain joined but the TMG is.  I'll join it to the domain shortly and test again.
    Friday, June 01, 2012 9:26 AM
  • Yes still the same issue! IE10 works, metro apps not.
    Friday, June 01, 2012 9:31 AM
  • Having added my test machine to the same domain as my TMG I now do not get password prompts and the Metro apps appear to connect fine.  Still testing though but it seems like this does work in certain circumstances.
    Friday, June 01, 2012 10:04 AM
  • Just completed a fresh install of the Release Preview and some Metro apps + Desktop IE are functional. Here is the way I have the environment setup...

    • TMG proxy with authentication required. Example hostname: proxy.local
    • TMG Rule: "Allow" "All Outbound Traffic" from "All Protected Networks" to "External" for "All Authenticated Users"
    • On DHCP server, option 252 (proxy autoconfig) is set to: http://proxy.local/wpad.dat
    • IE / Internet Options / LAN Settings: The only item checked in there at all is "Automatically detect settings"

    When I fire up desktop IE or any Metro app I've confirmed via logging that the initial anonymous request to TMG is denied and then I see an authenticated request from Windows succeed.

    Tested OK:

    • IE (Metro)
    • IE (Desktop)
    • Store
    • News
    • Travel
    • Weather
    • People
    • Calendar
    • xbox LIVE
    • Video
    • Music
    • Finance
    • Sports
    • Maps
    • Skydrive
    • Photos
    • Camera

    Failed:

    • Mail (Loaded, accepted account info, but displays no content)
    • USA Today (no content, proxy auth failure)
    • Slacker Radio (crashes)
    • slapDASH (can't connect, proxy auth failure)

    So overall I'd say the experience is pretty much the same as Windows 7. MS apps that are proxy aware are able to work. Third party apps choke when TMG wants them to supply login info. Normally at that point I would just install the TMG Firewall client, however it's still non-functional on Windows 8. Guess we'll have to wait for the TMG team on that one, and given how the TMG client was a barely upgraded ISA client there is no telling how long we will wait.

    Friday, June 01, 2012 7:04 PM
  • still dont works with domain joined computer and tmg and connection with autodetection, desktop ie yes, metro no

    with tethering from my phone everything works fine

    ideas???

    Friday, June 01, 2012 10:20 PM
  • Metro apps seem to be working for me on the Release Preview.  I'm not using TMG, but I am using NTLM authentication thru my SmoothWall proxy.  So was this fixed because the metro apps were fixed or because MS fixed it in the Release Preview?  I'm a little worried that metro app functionality will be contingent on the developer writing code to accommodate proxy networks.
    Tuesday, June 05, 2012 9:32 PM
  • I will say that my group policy for enforcing proxy traffic that worked in consumer preview was not enforced in the release preview like it should.  I set a user GP for Policies --> Windows Settings --> Internet Explorer Maintenance --> Connection/Proxy Settings that points to my proxy that works in Windows 7 and in the consumer preview but is ignored on release preview.  In order to test metro app proxy authentication I had to remove the policy and manually set these settings in IE.  I then monitored proxy traffic and verified IE traffic and metro app traffic were going thru the proxy.
    Wednesday, June 06, 2012 5:03 PM
  • This explains why proxy settings weren't being enforced http://technet.microsoft.com/en-us/library/hh846772
    Wednesday, June 06, 2012 5:13 PM
  • As already mentioned, if you are using the currently available TMG client, then you might have issues. 

    It sounds like there are possible multiple causes here and I'd like to try to find out what kind of proxy configurations are being affected.

    Those still seeing issues, please let me know if the details about your proxy configuration.

    Is it an authenticating proxy?

    Are you using proxy configuration scripts?

    Are you using a client?  (TMG/ISA client)

    Do you show a proxy configuration on WinHTTP?

        netsh winhttp show proxy

    Thanks,

    Joel


    Joel Christiansen -MSFT- Windows 8 Beta Support

    Wednesday, June 06, 2012 9:36 PM
  • hello,
    i'm new here, can anyone please tell what is TMG ? and describe the steps for setting it up with a SOCKS proxy
    thanks,
    Tony
    Friday, June 08, 2012 11:19 AM
  • I to am having a problem behind our corporate proxy.  We also use :8080. 

    We have deployed http://wpad-net/wpad.dat.  That is not working for IE 10.  I must manually enter the full proxy:port w/ bypass local. 

    Those settings do not impact Metro. 

    When modifying the Local Group Policy, under Network Isolation I do not see "Internet Proxy Servers for Metro Style Apps",  All I have are Internet proxy servers for apps .



    Friday, June 08, 2012 2:32 PM
  • Hello, 

    I tried that, did need elevated rights.  No joy! Metro Apps still show Off Line 

    Friday, June 08, 2012 2:40 PM
  • In my Local Group Policy, 'Internet proxy Servers for Metro style apps' Does not exist as a listed option. Just "apps" not "Metro style apps"

    I have tried all of the suggestions listed above, Metro Apps are still showing disconnected from the network. 

    Again our corporate proxy is port 8080, with no authentication.

    Friday, June 08, 2012 2:49 PM
  • Joel, 

    I am running RP in a VmWare session.  Our corporate proxy is non authenticated and uses port 8080.  Typically on Win7 desktops we use wpad in IE 9.  Automatic config script = http://wpad-net/wpad.dat. 

    RP Win8 Desktop IE - wpad does not allow connectivity through the proxy. 

    RP Win8 Desktop IE - manual proxy configuration does allow connection through the proxy. 

    Metro style apps:  No internet connectivity.

    I have used the command line method for importing the IE proxy settings and that only enabled Metro IE10

    I have modified the Local Group Policy settings but there is no line entry value " Metro apps" only "apps" 

    I have configured the proxy in Network Isolation - no effect

    Getting a bit frustrated here - All Metro tiles are showing no internet connection. 

    When I connect up at home and remove all of the proxy settings then both Desktop and Metro apps work as advertised.

    Update @ 2:38 pm.  

    Metro Apps Status:

    Internet connection with Proxy work - Email, Calendar, SkyDrive & IE

    Internet connection with Proxy don't work - News, Financial, Sports, Travel, Weather, Store, Maps

    Jeff


    Friday, June 08, 2012 3:27 PM
  • Hi,

    I'm running RP in a physical computer. Our corporate Proxy server uses Identd authentication. 

    Whe use an automatic  proxy configuration script.  All Metro and non Metro Apps have internet connectivity.

    My problem is with Windows Store: I can browse al Apps but I cannot download and install any App.

    Finally I solved the problem running this command from an elevated command prompt (as indicated in a previous post)

     netsh winhttp import proxy source=ie

    Now I can install Apps from the store.

    Daniel

    • Proposed as answer by Brian Borg Monday, June 25, 2012 8:19 PM
    Monday, June 11, 2012 5:49 PM
  • Hi Joel,

    My standard HTTP proxy is still not working with metro apps, with the latest Windows 8 build.

    > Those still seeing issues, please let me know if the details about your proxy configuration.
    > Is it an authenticating proxy?
    No, just standard HTTP 1.0 requests on port 5400 with no authentication.

    > Are you using proxy configuration scripts?
    No, and Internet Explorer's proxy is set through the Registry via relevant Windows API functions.

    > Are you using a client?  (TMG/ISA client)
    I'm using a beta version of the SlipStream SP client. http://www.slipstream.com/our_solutions/isp_info.html

    Do you show a proxy configuration on WinHTTP?
    After setting it with 'netsh winhttp import proxy source=ie' via an administrator shell, and rebooting, yes I'm seeing my proxy configuration here. However, Metro apps still cannot browse when the proxy is set.

    Here is the output of 'netsh winhttp show proxy':
    C:\Windows\system32>netsh winhttp show proxy

    Current WinHTTP proxy settings:
        Proxy Server(s) :  http=127.0.0.1:5400
        Bypass List     :  <local>;127.0.0.1:5400;*update.microsoft.com;*windowsupda
    te.com;download.microsoft.com;codecs.microsoft.com;activex.microsoft.com;liveupd
    ate.symantecliveupdate.com;liveupdate.symantec.com;download.mcafee.com;*.phobos.
    apple.com;update.adobe.com;*.apple.com;*.mac.com

    Thanks! Please let me know if this information helps, and what you can do here.

    Cheers,
    Will

    Friday, June 15, 2012 4:48 PM
  • Hi guys,

    Does yours apps still not working with authenticated proxy? Only IE metro is working here.

    Thanks.


    Evandro Gomes

    Monday, June 25, 2012 7:38 PM
  • Mine's still not working through an unauthenticated proxy (Squid)...  Metro IE, store, Mail, Weather all work fine...  But the Wikipedia app from the Store and Tweetro both think there's no network available.

    Monday, June 25, 2012 9:26 PM
  • Steve,

    How did you get Metro IE to work with your unathenticated proxy?

    Thanks!


    • Edited by Will11 Monday, June 25, 2012 10:07 PM
    Monday, June 25, 2012 10:06 PM
  • As suggested earlier in this thread, running:

    netsh winhttp import proxy source=ie

    ...in an elevated command window does the trick (actually, I cheat and set up a batch file on the Desktop that I run elevated).  For some reason, periodically the Metro apps I mentioned above stop working (probably my organization's group policy updates).  Run the batch elevated and I'm right as rain for the most part.

    Monday, June 25, 2012 10:19 PM
  • I have just loaded the Release Preview on a machine running on a corporate domain. It was upgraded from the consumer preview under which Metro IE (hideous thing that it is) would not connect via the proxy whilst real IE would happily do so. To do this I had to take the machine home and use an open connection - this isn't helping me to find the love ;-)

    In the release preview both Metro IE and real IE no are able to access the web via the proxy set under real IE which is a step forward however I have not been able to connect with any of the other apps (maps, store, music etc) and my internet connections shows no internet access via the clearly functional Ethernet connection that I am using to send this message. I tried the netsh command suggested elsewhere but that requires 'elevated priviliges' although I am a local administrator.

    Help.

    Kev

    Monday, June 25, 2012 11:17 PM
  • I managed to do the local policy thing with changing permissions and now can access the store although it now fails to load apps with a most unhelpful message that 'something happened' and only the option to cancel or try again. Is there a real need to make it this hard?
    Tuesday, June 26, 2012 1:54 AM
  • Same for me here.

    Win 8 RP.

    Cisco Ironport proxy using NTLM auth. tried all the suggestions above but no joy.

    I do not find the network isolation settings in the suggest location. I found them here,  comp config/admin templates/network/network isolation?

    IE works on desktop, all metro apps appear as offline.  Network connectivity shows limited sometime but not always even though I'm on the same network each time?

    Andy

    Monday, July 09, 2012 4:45 PM
  • Hi, I'm having the same problem too before.

    I even tried all those answers posted here and it didn't work.

    What I did was first was to check my antivirus program, allowing all on the firewall profile.
    Then I tried my MetroApps and it work. Unfortunately, since i tried all those previously posted answers I'm having problems on the my desktops internet connection on the cache thing, so try restoring them to its default values.

    Thank you and hope it would work fine on you! :) ♥

    ------

    iamduanne@facebook.com
    iamduanne@live.com

    Wednesday, July 11, 2012 2:39 AM
  • Hi,

    I'm running RP in a physical computer. Our corporate Proxy server uses Identd authentication. 

    Whe use an automatic  proxy configuration script.  All Metro and non Metro Apps have internet connectivity.

    My problem is with Windows Store: I can browse al Apps but I cannot download and install any App.

    Finally I solved the problem running this command from an elevated command prompt (as indicated in a previous post)

     netsh winhttp import proxy source=ie

    Now I can install Apps from the store.

    Daniel

    I am having the same issue... i can use everything apart from download apps from the store. When i do try to do this i get the message:

    "Purchase error

    This app isn't available right now. Please try later"

    So far i have found that  setting the proxy IP adress and port here (Local Computer Policy, Computer Configuration, Administrative Templates, Network, Network Isolation) makes all the metro apps work (minus store download as mentioned above)

    If i then try to set netsh winhttp import proxy source=ie metro apps then lose connection to the internet. If I then reset this using netsh winhttp reset proxy then I get back to my previous position of most things work apart from store download.

    I am using 64 bit RP on a //Build Samsung slate. I don't know all of the details of our company infrastructure but it I am on a non-domain joined PC and our proxy requires authentication.


    UPDATE: Same problems in RTM build 9200 ...
    • Edited by Simon Carp Friday, August 10, 2012 3:13 PM
    Tuesday, July 31, 2012 1:28 PM
  • Hi!

    Here's my proxy configuration:

    Yes, mine is an authenticating proxy

    yes, I use 'squid' (as I did in windows 7) to escape having to authenticate each time

    I don't understand, as far as I know, I haven't ever dealt with TMG/ISA

    yes, on cmd, the command 'netsh winhttp show proxy' gives 'proxy server: 127.0.0.1 : 3128' and 'Bypass list: *.local;*.iitb.ac.in'. This is what I've entered in desktop IE to work with squid which has the actual proxy settings(netmon.iitb.ac.in)

    Status:

    On the classic desktop, everything(squid) works fine. IE works, applications like dropbox, dc etc all work without authentication(coz of squid).

    On metro apps, weather, mail, people, maps etc don't work. none asks for authentication also. Metro IE connects to local sites but not those requiring authentication(or prompt from squid).

    ps. I have, as mostly advised above, edited the local group setting and tried with both 'netmon.iitb.ac.in:80' and '127.0.0.1:3128' and with and without the ''Proxy definitions are authoritative'' still with the same result. That's as far as I have gone.

    I m running Windows 8 Release preview evaluation copy build 8400 and am signed in as Microsoft user(which was not easy and required multiple tries).

    Any suggestions ?

    Regards,

    Bharat  

     

    Thursday, August 09, 2012 6:51 PM
  • Same problem in Enterprise RTM 9200 X64

    No solution yet? Nothing in windows update too!

    Internet is ok but in metro intarface the internet does not function.

    Any other idea to solve this?

    Thursday, August 16, 2012 1:33 PM
  • Still nothing from MS...  Which is concerning, given that RTM has happened.

    I'm hoping that this is simply a matter of, they've fixed it and not back-ported to the preview release(s), because if it's still an outstanding item, they've done a spectacular job of shooting themselves in the foot IMO.

    Thursday, August 16, 2012 3:33 PM
  • Same issue here with RTM. Extremely poor show from Microsoft given that this was reported back in March.

    How can you expect enterprises to adopt the interface formerly known as Metro if you have given no thought whatsoever to the various types of proxy in use by various companies around the world.

    Here at my company we use something called Desktop Web Proxy from a company called Webroot. This is a cloud based web proxy/filtering service. A client is installed onto the computer that listens on port 3128 and then proxies out to Webroot's servers in the cloud.

    This works perfectly in the desktop on Windows 8, but the apps formerly known as metro cannot connect to the internet, including the store. Essentially rendering the whole modern UI useless for our company.

    I've tried the netsh winhttp set proxy command, also using gpedit.msc to set the  "Internet Proxy Servers for Metro Style Apps" setting with no effect. The apps refuse to connect.

    Any ideas?

    Thursday, August 16, 2012 4:57 PM
  • The same issue here. Windows 8 Enterprise downloaded from MSDN. I've used both the methods mentioned here (group policy and command line) to no luck. Both desktop and metro IE works fine while all other Metro Apps do not. TMG debug console shows that all their HTTP requests come without authentication (although IE sends stored credentials just fine).

    MS guys, this is CORPORATE version of Windows, and corporate networks are supposed to be always connected to Internet via proxy, usually with authentication. And not all the proxy servers understand Windows authentication methods.

    When this bug will be corrected?

    • Proposed as answer by Brent Landry Tuesday, August 21, 2012 6:03 PM
    • Unproposed as answer by Brent Landry Tuesday, August 21, 2012 6:03 PM
    Friday, August 17, 2012 10:26 AM
  • Hey all,  I don't moderate this particular forum but this is for pre-release... Jump over to the Windows 8 Networking Forums for RTM assistance:  http://social.technet.microsoft.com/Forums/en-US/w8itpronetworking/threads

    -Jeff


    Jeff Sanders (MSFT)

    Monday, August 20, 2012 1:48 PM
  • The solution for me with Win 8 RTM was to turn off the Internet access ncsi probing.   This is what alerts you if you have Internet access.

    Set the following key to zero:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing

    Edit: This was the Enterprise edition, behind a corporate proxy server.  IE was working but the Metro apps were not.  
    • Proposed as answer by Brent Landry Tuesday, August 21, 2012 6:03 PM
    • Edited by Brent Landry Tuesday, August 21, 2012 6:04 PM
    Tuesday, August 21, 2012 5:57 PM
  • In my case, after enable Windows firewall to "Automatic" and start service + restart windows, everything work perfectly over proxy.

    I am try IE10, store, weather, mail, chat...

    Before of that I am done next:

    Set the following key to zero:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing   (Brent)


    • Edited by amko77 Wednesday, August 22, 2012 3:06 PM
    Wednesday, August 22, 2012 6:38 AM
  • We can't even get the Store itself to launch. "We  weren't able to connect to the Store. This might have happened because of server problem or the network connection timed out. Please wait a few minutes and try again." App actually locks up. you hit back arrow, esc, and only way to close it is via task manager. We are behind a corporate authenticated proxy server. Fresh install of Win 8 Entx64. Can browse IE and other software with inetcpl.cpl proxy settings pointing at our server.  Looks like Windows 8 is not ready for the enterprise environment, or at least the App store isn't. Typical Microsoft, right hand never talks to the left hand.

    Wednesday, August 22, 2012 7:11 PM
  • The solution for me with Win 8 RTM was to turn off the Internet access ncsi probing.   This is what alerts you if you have Internet access.

    Set the following key to zero:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing

    Edit: This was the Enterprise edition, behind a corporate proxy server.  IE was working but the Metro apps were not.  
    Yes, this worked for me as well. Thank you. More about what it exactly is in Windows 7 here: http://blog.superuser.com/2011/05/16/windows-7-network-awareness/
    Sunday, August 26, 2012 6:39 PM
  • Brents' solution worked for me!

    Win7 Pro RTM (Build 9200). Tested via Squid and TMG


    • Edited by batb0t Wednesday, August 29, 2012 1:43 AM
    Wednesday, August 29, 2012 1:37 AM
  • what do I do if the proxy server requires basic authentication?
    Saturday, September 01, 2012 10:15 AM
  • not working here :(

    i tested all solutions in here 

    • Edited by ehsan- Tuesday, September 04, 2012 1:54 AM
    Tuesday, September 04, 2012 1:27 AM
  • Also tried everything in this thread (and on all other relevant threads I could find).

    Tried on both X64 and X86 and Professional and Enterprise RTM SKUs.

    No success. Only thing that works is to open up IE and modify the proxy settings. Note that the actual VALUE of the proxy settings is mostly irrelevant. It's just the act of CHANGING them through the UI that gets Apps to work. Even if I change the settings back to what they were originally, my apps will still continue to work.

    IE must be doing something special when you save the proxy settings through the UI.

    A diff of registry dumps before and after turned up nothing useful.


    Scott D Binette

    Tuesday, September 04, 2012 9:12 PM
  • I am using Windows 8 RP from the release date.

    Recently i faced problem in switching my local account to Microsoft account and My apps cannot connect to internet at the same time..
    The issue that was troubling me is the institute proxy.Even though all the proxy settings are set there is one more thing to do.

    I propose the following solution to the issue:

    netsh winhttp set proxy x.x.x.x:y bypasslist

    x-proxy server
    y-port

    Cons : You have to re-do the netsh command everytime you restart.
    Pros : Everything Works.

    • Proposed as answer by chaitanya2513 Tuesday, September 11, 2012 4:08 AM
    Tuesday, September 11, 2012 3:55 AM
  • Hi,

    I am using Windows 8 behind my campus proxy which requires authentication. Some observations seem strange.

    Here is what I have tried:

      • Set proxy address, port in Internet Options: IE metro was working but no other app was. I was not able to activate my Windows 8.
      • I ran a local squid server which forwards to the university proxy. Thus, the local proxy does not require authentication. Apps still do not work. Only IE metro works. With this, I was able to activate my Windows.
      • I tried the procedures suggested above involving changing group policies 'Internet proxy servers for apps'. But after this, even IE stopped working. Only Desktop IE worked. I tried setting both actual proxy and the local proxy (my squid proxy server) but none worked.
      • Then I tried the 'automatic configuration script' option in Internet Options. (My university provides an address for '*.pac' for automatic proxy configuration). Now, many applications started using the proxy. These include 'News', 'Travel', 'Sports', 'Finance', 'Games'. All of these ask for proxy authentication which is normal and good. But the part of signing into Microsoft account doesn't work. In 'SkyDrive', it asks for Microsoft Account login but never asks for proxy authentication. In 'Music', it asks for authentication and displays all music market content (popular songs stuff) but when I try to sign in, it doesn't. Messenger, Mail show the added Microsoft Account but do not work. They don't even ask for proxy authentication.
        Then I tried 'Store'. It just said 'Your network proxy doesn't work with Windows Store. Contact your system administrator ....'.

    Also, every time, I tried to switch to my Microsoft Account from PC Settings->Users section. It had detected the proxy as it asked for authentication. It was also able to get my Microsoft Account basic details. But when I click Finish, I got an error saying 'Sorry, we couldn't connect to Microsoft services right now. ......'

    I think Store does not support authenticated proxies.
    If it is possible to generate an automatic configuration script for my local proxy server, Store might just start working.

    Any suggestions on how this can be achieved?

    Friday, September 14, 2012 4:51 PM
  • Hi,

    I think I found a solution to the problem.

    I am using Windows 8 Professional RTM behind my campus proxy. It's a squid proxy with basic authentication.

    1) Install CC Proxy. This software created a local proxy server on my PC. I used my own IP address as my proxy server in LAN settings and this enabled me to access the internet without asking for proxy everytime as CCproxy used my campus proxy as the cascading proxy.

    2) type in the netsh command in prompt so that the apps start using the local proxy. (no authentication on local proxy due to CC Proxy)

    3) Metro apps are programmed to prevent access of internet through a local proxy.
    Download 'Loopback Exemption Utility; from the following URL- http://blogs.msdn.com/b/fiddler/archive/2011/12/10/fiddler-windows-8-apps-enable-loopback-network-isolation-exemption.aspx

    This allows metro apps to access internet through your locally created proxy.

    Refer to SKuzn 's post on this link- http://social.technet.microsoft.com/Forums/en-US/w8itpronetworking/thread/a2aa72be-4964-459a-a220-5cf00ce187a9

    Everytime you install a new metro app from the store, you need to exempt it for accessing internet through local proxy by using the Loopback Exemption Utility.

    This method works fine for me. All my apps are working.

    Also,

    set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing to 0.

    and Enable "Proxy Definitions Are Authorative" and "Subnet definitions are authorative" as mentioned in the above posts.

    • Proposed as answer by atomaster Sunday, September 16, 2012 9:19 AM
    Sunday, September 16, 2012 9:13 AM
  • I searched for a solution all around internet and I finally find a way how to do it:

    Open command prompt as admin and write:

    netsh
    winhttp
    import proxy source=ie

    Hope it helps, unfortunately I do not remember the source of this script.


    • Proposed as answer by Bijan Izzy Wednesday, September 26, 2012 4:23 AM
    • Unproposed as answer by Bijan Izzy Wednesday, September 26, 2012 4:23 AM
    Saturday, September 22, 2012 4:53 AM
  • I have a soulution with a program.

    I had this problem too.

    But i used proxyfire for seting proxy on my system.

    But when i installed this program i saw my metro panel dont work .... you can solve this problem :

    1: Install fiddler ( it is a web debbuger ) from this link ==> www.getfiddler.com/dl/Fiddler2Setup.exe

    2: Now please install this addson for fiddler for your windos 8 form here ==> https://www.fiddler2.com/dl/EnableLoopbackUtility.exe

    3: After that it will be start please click ""Excempt All""

    4: Restart your system

    5: you must open fiddler first and you can use it in tray with CTRL+M

    now you can use your proxy and proxy fire

    I promiss you . for this solution . it  work 100%

    I used it atleast for 10 system.



    • Edited by Shahab Zeinali Tuesday, September 25, 2012 10:14 AM
    • Proposed as answer by Bijan Izzy Wednesday, September 26, 2012 4:23 AM
    Tuesday, September 25, 2012 9:59 AM
  • It Worked Like a Charm

    Thank You :) <3<3<3<3<3

    ps. you saved me from getting back to windows seven :D

    Wednesday, September 26, 2012 4:32 AM
  • Also tried everything in this thread (and on all other relevant threads I could find).

    Tried on both X64 and X86 and Professional and Enterprise RTM SKUs.

    No success. Only thing that works is to open up IE and modify the proxy settings. Note that the actual VALUE of the proxy settings is mostly irrelevant. It's just the act of CHANGING them through the UI that gets Apps to work. Even if I change the settings back to what they were originally, my apps will still continue to work.

    IE must be doing something special when you save the proxy settings through the UI.

    A diff of registry dumps before and after turned up nothing useful.


    Scott D Binette

    Exact same behaviour here: no internet acces (on the desktop or in apps) until I modify the proxy setting, then everything works, except Windows update, that still gives an error code 8024401C> cannot reach server. (my config: win864 bits final, not in a domain, needs to authenticate to a tmg proxy)
    Thursday, October 18, 2012 4:28 PM
  • 1. Set your IE proxy as you would in the desktop 'Internet Options'.

    2. Open command prompt in admininistrator mode (Right-click on command prompt  -> Run as Administrator). Not doing this will result in access denial.

    3. Use the commands also mentioned above.

    netsh
    winhttp
    import proxy source=ie

    Don't worry, this is one time job. In future, when you change or turn off proxy in the desktop IE's Internet Option, the settings will automatically reflect on the Metro Apps as well.

    Let me know when it works for you. I'm successsfully using the commands on four of my Windows 8 RTM PCs inside a University campus with proxyfied network.

    • Proposed as answer by AnindyaMaiti Sunday, October 28, 2012 7:42 AM
    Sunday, October 28, 2012 7:42 AM
  • Works like a charme! Thanks man.
    Tuesday, October 30, 2012 10:57 AM
  • Hi Shahab,

    I've installed the software as you described. My all apps are running fine. But once i am trying to install new apps from app store, it shows unable to install. Also cannot update the installed apps. I think the new apps i was trying to download is not included in the exemptions list and that's why new apps are not running. My question is how i can include new apps in the exemption list? Or is there any other way to install new apps from apps store and update the installed apps?  I'll be glad if you can give me solution. Thanks.

    Wednesday, November 07, 2012 5:27 PM
  • hi to all
    I access internet using proxy which requires authentication....first neither of my metro app was working but after using loopback utility and netsh commands i am able to successfully use all metro apps but when i open windows store it gives me the following error despite asking for authentication..

    Your Network Proxy Doesn't Work With Windows Store.

    Contact Your System administrator for more information.

    Also in some apps like sport and news credentials are not saved despite checking the remember my credentials box and i have to provide them again and again(it really kills the joy of using metro app :( )....is it happening with everybody or m the only VICTIM. 

    Any help would be heartly Welcomed. 

    Tuesday, November 13, 2012 4:51 PM
  • Holy cow - It works. THANKS!!!!

    What a pain! Microsoft??????????

    Wednesday, November 14, 2012 4:00 PM
  • Work around for development

    I encountered this problem when I was trying to use a virtual machine (no domain) on a domain network with a proxy server requiring windows/kerberos authentication.

    Applications that requested proxy credentials e.g. IE 10 desktop worked fine when the proxy was set in IE 10.

    However, other metro apps did not.

    I use fiddler (the latest v4.4.2.1 beta) which used the "win 8 config" to set  proxying of Windows 8 metro apps and could see the authentication failures (401) against the proxy.

    So I edited the fidler rules file (File-> Customize rules) 

    And as per this blog and the file set my username and password.

    if (m_AutoAuth) {
                // Automatically respond to any authentication challenges using the 
                // current Fiddler user's credentials. You can change (default)
                // to a domain\\username:password string if preferred.
                //
                // WARNING: This setting poses a security risk if remote 
                // connections are permitted!
                // oSession["X-AutoAuth"] = "(default)";
    oSession.oFlags["x-AutoAuth"] = "domain\\user:password";
            }

    I set-up fiddler for https and selected the "Automatically Authenticate" option on the rules tab.

    Now I can see all Metro traffic through fidler to the proxy and, more importantly, debug my app!


     

    Stuart

    Tuesday, November 20, 2012 11:58 AM
  • Microsoft released a couple KBs for this last week that basically said that the answer is to tell your proxy to allow anonymous authentication to any site that Modern UI (Metro UI) apps might reach out to.  They even supplied a list you can start off with (how nice) but you'll need to add more and more sites to your list if you use more and more apps.<o:p></o:p>

    I can't begin to express how unsatisfactory this solution is.  If Microsoft is serious about getting Windows 8 into the enterprise environment proxies must be wholly supported.  The solution isn't for us to start tearing apart our defense-in-depth solutions.<o:p></o:p>

    Now I'm spending hours trying to find a satisfactory solution for something that should be supported out of the box.<o:p></o:p>

    Microsoft, wake up and address this in a way that doesn't involve third-party applications or allowing anonymous authentication.  The solution should be within the OS, even if it's a registry hack or some kind of advanced option to allow the credentials to be passed to the proxy.<o:p></o:p>

    Tuesday, January 22, 2013 3:47 PM
  • Same problem. Nearly a year later. This is crap.
    Thursday, January 31, 2013 1:54 AM
  • I found a weird solution. Looks like everytime you change the proxy settings on IE (desktop) you must restart the system in order to changes take effect. Looks like metro apps cache the last proxy used at system start.
    Tuesday, February 19, 2013 8:57 PM
  • Did anyone cheked if Metro Windows Update it's autenticating?

    Thanks in advance.

    Friday, February 22, 2013 3:25 PM
  • does anyone has a solution to this ???

    Follow me on Twitter <<<
    levalencia Blog <<<

    Tuesday, March 05, 2013 8:03 AM