none
Problem with RWW and Connect to Computer. VBScript: Remote Desktop Connection.

    Question

  • Problem: The wizard cannot configure Remote Desktop Connection Settings. Make sure that the client version of Remote Desktop Protocol (RDP) 6.0 or later is installed on this computer.

    Hi firstly I'd like to say that this problem has been driving me insane for the last 3 days, I have tried all solutions that I can find including Reseting IE Settings, Regsvr32 mstscax.dll, removing Norton Endpoint Security, Replacing tsweb.aspx file with a clean one.

    As far as I can tell this occurred a couple of days ago when I was fixing up some issues with Symantec using the same port as Network Policy Server. I had to change the port that Symantec used for Radius, because it was stopping the NPS Service from starting which in turn stopped the TS Gateway service from starting.

    I really need to know where to start troubleshooting this issue, I've tried looking through various logs but nothing stands out.

    Monday, February 07, 2011 10:24 AM

Answers

  • In article <4935cf8a-4d65-49e7-b73b-6fde2b7a1620
    @communitybridge.codeplex.com>, nospam@work.ok, Duncan McCormack says...


    In article <aea2433c-c37c-485a-ba41- b1882212525a@communitybridge.codeplex.com>, One IT1, One IT1 says...


    No that doesn't work either, I've also tried other suggestions like
    making sure you add the server to your Trusted Sites.

    If it's not working from workstations on the LAN or the server itself
    - I think we can rule out a client-side issue.

    How's the web services looking? Check the site in IIS.  Check other
    web connectivity, such as 'connectcomputer'.

    You mentioned you changed some registry settings - for timeout???

    Check the max value allowed - as if you go above this, it doesn't work.

    http://technet.microsoft.com/en-us/library/cc527532(WS.10).aspx


    Duncan.

    • Marked as answer by One IT NZ Tuesday, February 08, 2011 7:59 PM
    Tuesday, February 08, 2011 11:24 AM

All replies

  • In article <4c1554cd-b404-499a-b1f8-811b38952580
    @communitybridge.codeplex.com>, One IT1, One IT1 says...


    Problem: The wizard cannot configure Remote Desktop Connection
    Settings. Make sure that the client version of Remote Desktop Protocol
    (RDP) 6.0 or later is installed on this computer.

    Hi firstly I'd like to say that this problem has been driving me
    insane for the last 3 days, I have tried all solutions that I can find
    including Reseting IE Settings, Regsvr32 mstscax.dll, removing Norton
    Endpoint Security, Replacing tsweb.aspx file with a clean one.

    As far as I can tell this occurred a couple of days ago when I was
    fixing up some issues with Symantec using the same port as Network
    Policy Server. I had to change the port that Symantec used for Radius,
    because it was stopping the NPS Service from starting which in turn
    stopped the TS Gateway service from starting.

    I really need to know where to start troubleshooting this issue, I've
    tried looking through various logs but nothing stands out.

    What version of SBS?  What OS on the workstation(s)?

    First thing you needo to establish, is whether you can get a RWW connection working locally.  So... does it work from a LAN workstation?

    And to clarify, you've completely removed Symantec (Symantec what, exactly, BTW?) and still have the problem?

    Was it working before the Symantec changes you made?


    Duncan.

    Monday, February 07, 2011 11:21 AM
  • Hi thanks for your reply,

    Sorry I guess I should have put a bit more info just wasn't sure what you would need.

    The server is Windows 2008 SBS SP2

    The Clients I have tried are Windows 7 and Windows XP and also from the Server itself

    Does not work on any of them.

    Symantec Endpoint Security was installed but has since been completely uninstalled because it was interfering with the Network Protection Service and TS Gateway.

    It was working a couple of days ago before I made a change to a Symantec file to change the port that the Symantec Radius server ran on from 1812 to another port. This then allowed me to start the NPS service.

    The only other thing I changed was to do with the Timeout period in RWW, I think it was a registry setting.

    -----------------------------------

    Brett Smith
    One IT Ltd
    www.oneit.co.nz

    Monday, February 07, 2011 11:34 AM
  • In article <75d70b21-6e9b-43e6-98bc-
    aec1be1df96b@communitybridge.codeplex.com>, One IT1, One IT1 says...


    Hi thanks for your reply,

    Sorry I guess I should have put a bit more info just wasn't sure what
    you would need.

    The server is Windows 2008 SBS SP2

    The Clients I have tried are Windows 7 and Windows XP and also from
    the Server itself

    Does not work on any of them.

    Symantec Endpoint Security was installed but has since been completely
    uninstalled because it was interfering with the Network Protection
    Service and TS Gateway.

    It was working a couple of days ago before I made a change to a
    Symantec file to change the port that the Symantec Radius server ran
    on from 1812 to another port. This then allowed me to start the NPS
    service.

    The only other thing I changed was to do with the Timeout period in
    RWW, I think it was a registry setting.

    So from the Server, if you did a: <servername>/remote - that doesn't work either?

    I assume you've checked the auto-running services are all up.  I'd check with the Best Practices Analyser too to see if that pics anything up.  And re-run the Internet connection wiz is a gimme.


    Duncan.

    Monday, February 07, 2011 11:46 AM
  • Yes from the local console on the server I've tried both the external dns name and servername /remote both give the same result.

    Which Auto-running services should I be checking?

    I've run the BPA and it shows everything is ok.

    I ran the Fix My Network tool and that didn't find anything either.

    I'm just running the internet connection wizard but I don't know if that'll help.

    Well the ICW just crashed but I'm not sure if that was to do with the windows updates I just installed so I'll try again after a reboot.

    Any other suggestions.

    -----------------------------------

    Brett Smith
    One IT Ltd
    www.oneit.co.nz

    Monday, February 07, 2011 12:06 PM
  • In article <90b55c32-d74f-45a9-a8f5-0288e1c47eb7
    @communitybridge.codeplex.com>, nospam@work.ok, Duncan McCormack says...


    In article <75d70b21-6e9b-43e6-98bc- aec1be1df96b@communitybridge.codeplex.com>, One IT1, One IT1 says...


    Hi thanks for your reply,

    Sorry I guess I should have put a bit more info just wasn't sure what
    you would need.

    The server is Windows 2008 SBS SP2

    The Clients I have tried are Windows 7 and Windows XP and also from
    the Server itself

    Does not work on any of them.

    Symantec Endpoint Security was installed but has since been completely
    uninstalled because it was interfering with the Network Protection
    Service and TS Gateway.

    It was working a couple of days ago before I made a change to a
    Symantec file to change the port that the Symantec Radius server ran
    on from 1812 to another port. This then allowed me to start the NPS
    service.

    The only other thing I changed was to do with the Timeout period in
    RWW, I think it was a registry setting.

    So from the Server, if you did a: <servername>/remote - that doesn't
    work either?

    I assume you've checked the auto-running services are all up.  I'd
    check with the Best Practices Analyser too to see if that pics
    anything up.  And re-run the Internet connection wiz is a gimme.

    And I meant to add... check those required ports: 80, 443, 987, 3389 (and 4125? - I think that's SBS 2003 only).  Use netstat -ao to see what's getting what on the server, or netstat -ao| find ":<stick those ports in one by one>", eg netstat -ao | find ":443" .


    Duncan.

    Monday, February 07, 2011 12:07 PM
  • In article <e5b8fa48-1803-4610-ae80-037b6971d651
    @communitybridge.codeplex.com>, One IT1, One IT1 says...


    Yes from the local console on the server I've tried both the external
    dns name and servername /remote both give the same result.

    Which Auto-running services should I be checking?

    I've run the BPA and it shows everything is ok.

    I ran the Fix My Network tool and that didn't find anything either.

    I'm just running the internet connection wizard but I don't know if
    that'll help.

    Well the ICW just crashed but I'm not sure if that was to do with the
    windows updates I just installed so I'll try again after a reboot.

    Any other suggestions.

    Yep, see my other post re checking those ports.

    It's 1am man, go to bed :)


    Duncan. (Otautahi)

    Monday, February 07, 2011 12:09 PM
  • It's 1am man, go to bed :)

    Duncan. (Otautahi)

    I'm nocturnal. Lol.
    Monday, February 07, 2011 12:12 PM
  • I've tried all that, all ports are opened and re ran the ICW still no good. 

    Like I said I've tried almost everything.

    I'm hoping someone out there knows where to look next.

    -----------------------------------

    Brett Smith
    One IT Ltd
    www.oneit.co.nz

    Monday, February 07, 2011 12:31 PM
  • You mentioned you changed a timeout setting in the registry, which setting is that?

    Have you changed it back since having these issues? (apologise if i missed you mention it)

     



    Robert Pearman SBS MVP (2010)
    Monday, February 07, 2011 4:16 PM
    Moderator
  • The timeout setting was for the Outlook Web Access and Sharepoint Timeout.

    If I remember correctly the Outlook was a Registry setting and the Sharepoint was a file I had to modify.

    I'm pretty sure that's not it though.

    Monday, February 07, 2011 9:44 PM
  • From a windows 7 client machine, can you run internet explorer as an administrator and then try connecting. Be careful not to browse other sites because it will open your system right up to malware. This is just for testing to see if it works.

    Thanks.

    Tuesday, February 08, 2011 2:23 AM
  • No that doesn't work either, I've also tried other suggestions like making sure you add the server to your Trusted Sites.
    Tuesday, February 08, 2011 3:45 AM
  • In article <aea2433c-c37c-485a-ba41-
    b1882212525a@communitybridge.codeplex.com>, One IT1, One IT1 says...


    No that doesn't work either, I've also tried other suggestions like
    making sure you add the server to your Trusted Sites.

    If it's not working from workstations on the LAN or the server itself - I think we can rule out a client-side issue.

    How's the web services looking? Check the site in IIS.  Check other web connectivity, such as 'connectcomputer'.


    Duncan.

    Tuesday, February 08, 2011 4:54 AM
  • Is there an easy way to reinstall the Remote Web Workplace at all?
    Tuesday, February 08, 2011 5:35 AM
  • In article <4935cf8a-4d65-49e7-b73b-6fde2b7a1620
    @communitybridge.codeplex.com>, nospam@work.ok, Duncan McCormack says...


    In article <aea2433c-c37c-485a-ba41- b1882212525a@communitybridge.codeplex.com>, One IT1, One IT1 says...


    No that doesn't work either, I've also tried other suggestions like
    making sure you add the server to your Trusted Sites.

    If it's not working from workstations on the LAN or the server itself
    - I think we can rule out a client-side issue.

    How's the web services looking? Check the site in IIS.  Check other
    web connectivity, such as 'connectcomputer'.

    You mentioned you changed some registry settings - for timeout???

    Check the max value allowed - as if you go above this, it doesn't work.

    http://technet.microsoft.com/en-us/library/cc527532(WS.10).aspx


    Duncan.

    • Marked as answer by One IT NZ Tuesday, February 08, 2011 7:59 PM
    Tuesday, February 08, 2011 11:24 AM
  • In article <4935cf8a-4d65-49e7-b73b-6fde2b7a1620
    @communitybridge.codeplex.com>, nospam@work.ok, Duncan McCormack says...


    In article <aea2433c-c37c-485a-ba41- b1882212525a@communitybridge.codeplex.com>, One IT1, One IT1 says...


    No that doesn't work either, I've also tried other suggestions like
    making sure you add the server to your Trusted Sites.

    If it's not working from workstations on the LAN or the server itself
    - I think we can rule out a client-side issue.

    How's the web services looking? Check the site in IIS.  Check other
    web connectivity, such as 'connectcomputer'.

    You mentioned you changed some registry settings - for timeout???

    Check the max value allowed - as if you go above this, it doesn't work.

    http://technet.microsoft.com/en-us/library/cc527532(WS.10).aspx


    Duncan.

    Thank you sooo much Duncan.

    You hit the nail right on the head I had changed the timeout of the Remote Web Workplace to 720 (HEX) which was 1820 (DEC).

    Stupid me have now changed it back to 720 (DEC) which is lower than 1440 (DEC) and now it works beautifully.

    To change the client time-out setting for Remote Web Workplace

    1. Open Registry Editor.

    2. Open the following registry key:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SmallBusinessServer\RemoteUserPortal\PublicTimeOut

     

    That was the key I had changed in the registry.

    I can't believe this wasn't easier to find you'd think Microsoft would have had a big warning saying if you change this you will get the error: The wizard cannot configure Remote Desktop Connection Settings. Make sure that the client version of Remote Desktop Protocol (RDP) 6.0 or later is installed on this computer.

    Well hopefully this thread will make it higher in Google for anyone else that makes this mistake.

    Just goes to show that you should be very careful when you change anything in the Registry.

    Thanks Again everyone for their help.

    Just out of curiosity how do I add the details of the error message people will get to the community content portion of the http://technet.microsoft.com/en-us/library/cc527532(WS.10).aspx webpage so that people will know what happens if they make the mistake of changing the timeout too high.

     

    -----------------------------------

    Brett Smith
    One IT Ltd
    www.oneit.co.nz

     

    • Edited by One IT NZ Tuesday, February 08, 2011 8:13 PM Updated
    Tuesday, February 08, 2011 8:05 PM
  • In article <f4344088-aa89-4be7-97fa-
    e1fdf9ccc70b@communitybridge.codeplex.com>, One IT1, One IT1 says...

    In article <4935cf8a-4d65-49e7-b73b-6fde2b7a1620
    @communitybridge.codeplex.com>, nospam@work.ok, Duncan McCormack says...


    In article <aea2433c-c37c-485a-ba41- b1882212525a@communitybridge.codeplex.com>, One IT1, One IT1 says...


    No that doesn't work either, I've also tried other suggestions like
    making sure you add the server to your Trusted Sites.

    If it's not working from workstations on the LAN or the server itself
    - I think we can rule out a client-side issue.

    How's the web services looking? Check the site in IIS.  Check other
    web connectivity, such as 'connectcomputer'.

    You mentioned you changed some registry settings - for timeout???

    Check the max value allowed - as if you go above this, it doesn't work.

    http://technet.microsoft.com/en-us/library/cc527532(WS.10).aspx


    Duncan.

    Thank you sooo much Duncan.

    You hit the nail right on the head I had changed the timeout of the
    Remote Web Workplace to 720 (HEX) which was 1820 (DEC).

    Stupid me have now changed it back to 720 (DEC) which is lower than
    1440 (DEC) and now it works beautifully.

    To change the client time-out setting for Remote Web Workplace

    1.

    Open Registry Editor. 2.

    Open the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SmallBusinessServer\RemoteUserP
    ortal\PublicTimeOut


     

    That was the key I had changed in the registry.

    I can't believe this wasn't easier to find you'd think Microsoft would
    have had a big warning saying if you change this you will get the
    error: The wizard cannot configure Remote Desktop Connection Settings.
    Make sure that the client version of Remote Desktop Protocol (RDP) 6.0
    or later is installed on this computer.

    Well hopefully this thread will make it higher in Google for anyone
    else that makes this mistake.

    Just goes to show that you should be very careful when you change
    anything in the Registry.

    Thanks Again everyone for their help.

    Just out of curiosity how do I add the details of the error message
    people will get to the community content portion of
    the http://technet.microsoft.com/en-us/library/cc527532(WS.10).aspx
    <http://technet.microsoft.com/en-us/library/cc527532> webpage so that
    people will know what happens if they make the mistake of changing the
    timeout too high.

    Your post back should be enough Brett. However if you want the article revised, perhaps try emailing one of the MS support folk that are resident on this group.

    Thanks for reporting back.


    Duncan.

    Wednesday, February 09, 2011 12:12 AM
  • I can pass this on to Susan, she will know who to talk to to get this updated.
    Robert Pearman SBS MVP (2010)
    Wednesday, February 09, 2011 2:18 PM
    Moderator
  • And...
     

    --
    Merv  Porter   [SBS-MVP]
    ============================
    "Duncan McCormack" wrote in message news:28d7db1a-14be-4b8c-9798-f948f4cd3356...

    In article <f4344088-aa89-4be7-97fa-
    e1fdf9ccc70b@communitybridge.codeplex.com>, One IT1, One IT1 says...

    In article <4935cf8a-4d65-49e7-b73b-6fde2b7a1620
    @communitybridge.codeplex.com>, nospam@work.ok, Duncan McCormack says...


    In article <aea2433c-c37c-485a-ba41- b1882212525a@communitybridge.codeplex.com>, One IT1, One IT1 says...


    No that doesn't work either, I've also tried other suggestions like
    making sure you add the server to your Trusted Sites.

    If it's not working from workstations on the LAN or the server itself
    - I think we can rule out a client-side issue.

    How's the web services looking? Check the site in IIS.  Check other
    web connectivity, such as 'connectcomputer'.

    You mentioned you changed some registry settings - for timeout???

    Check the max value allowed - as if you go above this, it doesn't work.

    http://technet.microsoft.com/en-us/library/cc527532(WS.10).aspx


    Duncan.

    Thank you sooo much Duncan.

    You hit the nail right on the head I had changed the timeout of the
    Remote Web Workplace to 720 (HEX) which was 1820 (DEC).

    Stupid me have now changed it back to 720 (DEC) which is lower than
    1440 (DEC) and now it works beautifully.

    To change the client time-out setting for Remote Web Workplace

    1.

    Open Registry Editor. 2.

    Open the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SmallBusinessServer\RemoteUserP
    ortal\PublicTimeOut


     

    That was the key I had changed in the registry.

    I can't believe this wasn't easier to find you'd think Microsoft would
    have had a big warning saying if you change this you will get the
    error: The wizard cannot configure Remote Desktop Connection Settings.
    Make sure that the client version of Remote Desktop Protocol (RDP) 6.0
    or later is installed on this computer.

    Well hopefully this thread will make it higher in Google for anyone
    else that makes this mistake.

    Just goes to show that you should be very careful when you change
    anything in the Registry.

    Thanks Again everyone for their help.

    Just out of curiosity how do I add the details of the error message
    people will get to the community content portion of
    the http://technet.microsoft.com/en-us/library/cc527532(WS.10).aspx
    <http://technet.microsoft.com/en-us/library/cc527532> webpage so that
    people will know what happens if they make the mistake of changing the
    timeout too high.

    Your post back should be enough Brett. However if you want the article revised, perhaps try emailing one of the MS support folk that are resident on this group.

    Thanks for reporting back.


    Duncan.

    Wednesday, February 09, 2011 2:59 PM
    Moderator
  • I have the same problem. How do I open the registry editor?

    Thank you, I am not a tech guru, I would just like to remotely connect to my computer at work and I get the same message about needing remote desktop protocol 6.0 or later.

    Thank you

    Monday, December 03, 2012 3:29 AM
  • I have the same problem. How do I open the registry editor?

    Thank you, I am not a tech guru, I would just like to remotely connect to my computer at work and I get the same message about needing remote desktop protocol 6.0 or later.

    Thank you

    Start, and in the Run dialog, type 'regedit' (no quotes) and press Enter and click Yes to the UAC prompt - (in XP you might need to type 'regedit.exe'). 

    But is this your problem EveryEve?  If you just get the message about requiring remote desktop protocol 6 or later, check your work (Windows 7 presumably) PC that you wish to remote to, and check in Control Panel, System, Remote (tab), that "Allow connection from computers running any version of Remote Desktop (less secure)" is selected...

    Hope that helps, please let us know.

    Cheers,  Duncan.

    Monday, December 03, 2012 4:04 AM
  • Only problem I see here is everyone points to an article that recommends changing some registry keys on the actual server. I was able to connect to RWW just fine and suddenly that error started coming up and the only difference is that my OS was updated with RDP client v6.2 which messed things up. I tested RWW with a client running 6.1 and it works fine so looks to me like MS didn't do proper testing before releasing 6.2

    yaro

    Wednesday, April 10, 2013 4:39 PM
  • I found this at  Posted by Stoute

     "Click on "compatibility" settings and place the site in compat mode.

    now it al works again"

    It worked great!

    • Proposed as answer by Wayniack Thursday, May 23, 2013 5:37 PM
    Wednesday, April 24, 2013 5:18 AM
  • Wow...someone needs to give ARMeyer-CE some credit for this one! I see he has 0 (zero) points. I read through this entire thread and stopped at his post and thought "Why would that suddenly be an issue?". But it was such a simple change I figured "Why not!". Badda bing, badda boom!


    However, just to clarify a bit: the solution (in this instance) is to go to the 'Tools' menu in IE on your remote PC and select 'Compatibility View settings' --> then add the domain of your SBS 2008 server's RWW.

    Wayne S. CompTIA A+ CompTIA Network+ Microsoft MCP

    • Proposed as answer by Wayniack Thursday, May 23, 2013 5:47 PM
    Thursday, May 23, 2013 5:46 PM
  • P.S. I've mostly been a leach on these forums, mostly because I'm just a rookie and also because I am a one-man shop (so I don't have much time to look for posts to respond to other than my own). Anyway, if someone wants to approve my post (the improvement to AR's post) as an answer...I'd be grateful to have something other than a zero after my name! ;-)

    Thanks either way!


    Wayne S. CompTIA A+ CompTIA Network+ Microsoft MCP

    Thursday, May 23, 2013 5:50 PM
  • I found this at  Posted by Stoute

     "Click on "compatibility" settings and place the site in compat mode.

    now it al works again"

    It worked great!

    Agreed - this worked for me.  Had a self-signed Certificate expire on a client's SBS 2008 R2 server.  Re-ran the connect to Internet wiz, restarted IIS, WWW, TS Gateway, but blew chunks on the remote desktop session stating that my version of RDP needed to be v6.0 or better.  Confusing.

    Should have thought of this long ago before today, but these forums are a great help and certainly better than the cobbled together garbage on other 'forums' or webcrawlers.

    And, to add to Wayniack, IE9, 10, 11 hide the tools menu sometimes.  Remember, with SBS 2008, Remote desktop only works in IE, and to bring up the Tools menu, hit the 'ALT' key, your hidden menu will now show up.  Go to the 'Compatibility view settings' item, another window will show up, 'Compatibility view settings' window, and the domain (missing the tld probably, will be in the box as domain.com instead of remote.domain.com.  This is fine) will be populated.  Hit Add.

    Then SBS will probably log you out.  Log in again, and chances are that from this point you're golden.

    Thx again ARMeyer-CE and Wayniack!

    Wednesday, June 12, 2013 7:46 PM
  • You are the man!!!

    I installed 3 different sbs domain and I've understood why the RDP from RWW worked on some computer and not on other...  With this solution, it works well everywhere.

    Thank

    Thursday, July 18, 2013 12:53 PM
  • OMG finally :) that was for me the solution. thx
    Tuesday, September 10, 2013 4:57 PM
  • Hi Peter...thanks for the acknowledgement. If you're able, go to the 'Vote' button on my post and give me a bump. Cheers!

    Wayne S. CompTIA A+ CompTIA Network+ Microsoft MCP

    Friday, September 13, 2013 4:40 PM