locked
Microsoft Application Virtualization Server Install Problem: Database server not in drop down list

    Question

  • Hi:

    Been banging my head on this for the last 6 hours (missed the superbowl because of it!!)

    I am following the SoftGrid / MAV 4.5  Trial Guide exactly.

    My host server is running Windows Server 2008. I am setting up several VMs for the trial  (per the picture on page 7 - Figure 1)

    I am on page 11 where it deals with installing SQLExpress  and then installing the Virtual Server .

    I successfully install the SQLExpress (2008) (SQLEXP.exe) which I downloaded from connect.microsoft.com)

    I then run the Microsoft Application Virtualization Server installer.

    However, when I get to page 12 step 8 (Database Server Location Page) nothing shows in the drop down menu. (actually, one thing does show...the string "TestValue".

    Any thoughts?

    I tried this 4 times tonight...even built a whole new VM from scratch.   The only thing that I can think of is that I used SQLExpress 2008 instead of SQLExpress 2005 SP2.   Going to try that next.

    Anybody have similar experience?

    Ken
    Monday, February 04, 2008 9:36 AM

Answers

  • I figured it out!!

     

    Short Answer:  SQL Express listens on port 49187.   The SoftGrid install wizard defines a different port to listen on and the guide does not tell you to change it.

     

    So if you are following the guide....go to page 12, Step 8 (figure 3). 

    If you don't see your instance in the server pulldown list (I still cant!) , you can manually enter it at the bottom of the screen.   Use <servername>\SQLExpress   and CHANGE THE PORT NUMBER to 49187.

     

    Once I did that I was able to continue on in the wizard and get to Step 9, 10, 11, 12 13, 14,

     

    Alas, the game is not over yet.....

     

    When I hit "Install" on step 15 (page 15)  it goes through the install process.  Unfortunately at the end I get the following error message:

     

    Error 25120.  The installation program was unable to create the required IIS virtual directory"

     

    hummmmm..... now I got to figure that one out.   Any ideas?

    Tuesday, February 05, 2008 7:14 PM

All replies

  • Nope.... running SQLExpress 2005 (SQLEXPR32.exe or SQLEXPR.exe)  does not help me out either.   Still same problem....After I install SQLExpress 2005 and then run SoftGrid Virtual Application Server windows installer, I still ge the same problem... my screen does not look like Figure 3 on page 12 of the MAV Trial Guide.   Instead of having the SQLExpress instance in the drop down list, all it has is that same "TestValue" text .

    Any thoughts?


    Monday, February 04, 2008 10:24 AM
  •  

    On the machine that you are going to install the SoftGrid server create an odbc connection before installing.

    (Start - > Run & type odbcad32.exe .

    Also notice that networking protocols are disabled by default in SQL Server Express, check kb914277 on howto enable remote connections  http://support.microsoft.com/default.aspx?scid=kb;EN-US;914277 .

     

    Best Regards

     

    Pierre Eriksson

    http://www.mindgrape.se/forum

     

     

    Monday, February 04, 2008 12:13 PM
  • BTW... the URL for the SoftGrid Trial Guide that I am following is:  http://www.microsoft.com/Downloads/details.aspx?familyid=AA787491-8D08-4D2F-8960-9E9F00226C7E&displaylang=en

     

     

    Monday, February 04, 2008 6:49 PM
  • Pierre:

    Thanks so much for the response.

    I run obdc32.exe and get the administrator.  What kind of DSN do I set up?  I assume a System DSN. 

    As I go through the wizard it asks "Which SQL Server do you want to connect to? and it has a pull down.   There are no servers listed in that pull down.   This is the same if it is on USER or SYSTEM DSN tab.

    any more thoughts?

    Ken
    Tuesday, February 05, 2008 1:07 AM
  •  

    When you do a connection to SQL Express you need to specify "<MachineName>\SQLEXPRESS" as the SQL instance name.

    Make sure that the "SQL Browser" service is running and the Windows OS firewall is not blocking UDP port 1434.

    Also as I mention before make sure you have enabled remote connection.

     

    Here is a blog that describes typical problems with connecting to SQL Express. http://blogs.msdn.com/sql_protocols/archive/2006/03/23/558651.aspx

     

     

    BR

     

    Pierre Eriksson

     

    Tuesday, February 05, 2008 9:48 AM
  • Thanks.

    Actually, both the SQLExpress instance and the SoftGrid software is on the same VM.

    What protocol do they speak when they are on the same VM ?
    Tuesday, February 05, 2008 4:11 PM
  • I figured it out!!

     

    Short Answer:  SQL Express listens on port 49187.   The SoftGrid install wizard defines a different port to listen on and the guide does not tell you to change it.

     

    So if you are following the guide....go to page 12, Step 8 (figure 3). 

    If you don't see your instance in the server pulldown list (I still cant!) , you can manually enter it at the bottom of the screen.   Use <servername>\SQLExpress   and CHANGE THE PORT NUMBER to 49187.

     

    Once I did that I was able to continue on in the wizard and get to Step 9, 10, 11, 12 13, 14,

     

    Alas, the game is not over yet.....

     

    When I hit "Install" on step 15 (page 15)  it goes through the install process.  Unfortunately at the end I get the following error message:

     

    Error 25120.  The installation program was unable to create the required IIS virtual directory"

     

    hummmmm..... now I got to figure that one out.   Any ideas?

    Tuesday, February 05, 2008 7:14 PM
  • Something new I found out....

    Apparently, the port that the <machinename>/SQLEXPRESS  listens on is "randomly" chosen by the server.  (I am sure it is not truely random.)

    I found this out because I wanted to do a clean installation on a new VM.   This time, when I looked at the install log I notice that the port was different this time.  This time it was 49156 .   When I did it on another VM , the log said it was listening on 49187

    To find the log that has that info in it:
    By open the properties of the service, you will see the binary location, such as "C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\sqlservr.exe", so normally, if you do not change configuration for the log file location, it should be located ...\MSSQL.X\MSSQL\Log\. When you open the log file, you should see some keywords such as " Express Edition " and " Server name is '<machinename>\SQLEXPRESS' " and " Server named pipe provider is ready to accept connection on [ \\.\pipe\MSSQL$SQLEXPRESS\sql\query ]", etc.

    ref: http://blogs.msdn.com/sql_protocols/archive/2006/03/23/558651.aspx


    Wednesday, February 06, 2008 9:38 AM
  • The short answer is when you use SQL Express, you need to enable the SQL Browser service and enable all protocols in the SQL Configuration Manager.  This will allow your instance to show up at install.

     

    /Chris

    Friday, February 08, 2008 12:27 PM
  • In SQL Configuration Manager you could also set TCP port that it uses to fixed (1433 is standard port for SQL Server):

     

    Network configuration -> Procotols -> Properties from TCP/IP -> IP Addresses -tab -> TCP Port. If it's set to "0", then it uses dynamic port.

     

    /Kalle

    Friday, February 08, 2008 5:03 PM
    Moderator
  • I had the same problem but solved it by roughly following

    http://blogs.technet.com/virtualworld/archive/2007/04/24/sql-2005-server-installation.aspx

    (i didn't use a domain account for step 9)
    Sunday, February 10, 2008 2:13 PM
  • I checked the ERRORLOG under C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Log and it said what port it was listening to. Mine was 55083. I went back to the install and changed the port to 55083 and DB server <server name>\DBname and it went trough.

    Thanks dudeDad.
    Thursday, March 04, 2010 9:29 PM