none
Configuration error on my asp.net azure cloud service using Devexpress controls

    Question

  • Hi,

    I'm trying to publish my cloud service (which includes web role with devexpress 13.1 controls and worker role) to azure cloud.
    Everything works very good on my local computer and the publish process complete successfully but when i'm trying to view the website on the cloud I get the following error:


    Server Error in '/' Application.Configuration ErrorDescription: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

    Parser Error Message: Could not load file or assembly 'DevExpress.Web.v13.1, Version=13.1.5.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a' or one of its dependencies. The system cannot find the file specified.

    Source Error: 

    
    Line 31: <assemblies>
    Line 32: <add assembly="System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    Line 33: <add assembly="DevExpress.Web.v13.1, Version=13.1.5.0, Culture=neutral, PublicKeyToken=B88D1754D700E49A" />
    Line 34: <add assembly="DevExpress.Data.v13.1, Version=13.1.5.0, Culture=neutral, PublicKeyToken=B88D1754D700E49A" />
    Line 35: <add assembly="DevExpress.Printing.v13.1.Core, Version=13.1.5.0, Culture=neutral, PublicKeyToken=B88D1754D700E49A" />
    Source File: F:\sitesroot\0\web.config Line: 33 

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'DevExpress.Web.v13.1, Version=13.1.5.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a' could not be loaded.

    
    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.18045


    Does someone know how to fix it?

    Thanks for any help,
    Tom.
    Saturday, July 27, 2013 9:35 PM

Answers

  • Hi

    By the error message, it sounds like the project can't find the dll which register in web.config.

    Please set those dlls copytolocal=true in your project.

    I think that's may be the problem.

    Thanks.


    Please mark post as answered if it helped!

    Sunday, July 28, 2013 4:16 AM